TWD Season 1 is unable to Start

After installing my new Macbook Pro 2015, I decided to give The Walking Dead Season 2 a whirl and noticed that it gave me the option to import my Season 1 save game data. Of course very excited, I exited TWD2, installed TWD1 and tried to start the game. Oddly, it didn't want to start and showed 0% 0 bytes/sec next to the title in the game list. I checked at some places online and people suggested I should verify my cache. So, I go to Local Files, click Verify and it does it's thing. After a few seconds, it tells me that 1 out of 1 files failed the integrity check and will be re-downloaded. I see that it has been downloaded (in the Downloads window in Steam) as I see 1 file completed downloading. It however says 0 bytes / 0 bytes downloaded.

Again, further attempts to start the game fail. If I start the game, it just saying preparing to start for a while (about a minute or 2) and then says something about it not being able to do Cloud Sync of my save files. The entire reason why I wanted to restart TWD1 was so I could get the save game files imported into TWD2. What am I doing wrong?

I've tried deleting all local files for TWD1 and redownloading the entire game, but to no avail.

Output from the Support Tool for TWD:


This discussion has been closed.