User Avatar Image

Telltale + Linux: A Definitive Guide

posted by covox on - last edited - Viewed by 64.4K users
[MOD EDIT: Previous Linux guides on this forum: Sam & Max and SBCG4AP]

As a Linux guy who loves his adventuring, I'll try and keep this updated as best I can. These instructions were developed for Wine 1.1.29, under Ubuntu Jaunty 9.04, but should work under the newest build/distro. The example is for installing TOMI, but can be adapted to pretty much any downloadable Telltale title. This guide assumes you have set up your computer with the proper ATI/NVIDIA 3D drivers; most distros will ask you if you want them, the answer is hell yes! So let's get cracking!

  • Sam and Max Series 1
  • Sam and Max Series 2
  • SBCG4AP Series 1
  • Wallace and Gromit Series 1
  • Tales of Monkey Island Series 1
  • Sam and Max Series 3

1.) Visit WineHQ and get the latest build for your distro.

You should know by now that Wine is the de-facto way of running native Windows apps under your Linux of choice. What may not be obvious is that the copy bundled with most distros is freaking ancient; why, tens of thousands of fixes and improvements have potentially been committed since then! To put it in perspective, the "stable" one in your distro was sent out around the time colour television was first invented. The Wine guys release a new one literally every fortnight. So the first thing you should do is visit this page and follow the instructions for your distro to fix yourself up with the latest.

2.) Download WineTricks and install the d3dx9 package.

Wine hasn't replicated the Direct3D extension DLLs (e.g. d3dx9_41.dll) yet, and they're needed by some Telltale games. There's a quick way to fix this:
sh winetricks d3dx9
This will download the DirectX 9 installer and rip just the good bits out of it; you'll probably see a EULA or two, click yes. Congrats, you now have all the libraries you need.

SPECIAL STEP FOR SAM AND MAX SERIES 3 OWNERS: Telltale have finally taken their old IE6 based launcher and lashed it to a canoe, set it on fire then left it to slowly drift down a canal. The replacement is a nicer, faster, cross-platformier QT/WebKit deal. However, with WineTricks, you need to install the Visual Studio runtime files before the game will start.
sh winetricks vcrun2005

3.) Run the game installer. When it asks if you want to update DirectX, just say no.

Easy as. Most distros let you double-click the EXE to start Wine; I prefer the terminal.
wine LaunchOfTheScreamingNarwhal_Setup.exe

SPECIAL STEP FOR SAM AND MAX SERIES 3 OWNERS: You're done! Enjoy the game :)

4a.) Enter your purchased serial number into the box.

Grab it from here and paste it into the box. The launch window will switch to a white page after doing this; that means it's working! With luck, you can quit the launcher now by running in a terminal
wineserver -k
Next time you start the game up, you'll get a "Click here to run the game" link instead of the serial box. Congratulations!


4b.) Download this patching script and launch the demo with it.

Originally you needed this script to make the serial number entry work, but that regression got fixed! If you want to just play the demo, you'll need to crack open a terminal:
cd ~/.wine/drive_c/Program\ Files/Telltale\ Games/Tales\ of\ Monkey\ Island/Launch\ of\ the\ Screaming\ Narwhal
python MonkeyIsland101.exe
If all goes to plan, you should see some text in the launcher window offering a link to play the demo. Congratulations!

  • You only have to use once to register a serial number, but every time you want to play the demo.
  • If you're having trouble getting rid of the Telltale window after quitting the launcher, run "wineserver -k" to kill it.
  • If you're having trouble with sound (e.g. skipping, not being there at all) and you use a reasonably new distro, it's probably PulseAudio. It's pretty much always PulseAudio. Do yourself a favour and run "pulseaudio -k" to murder it before starting the game.
  • If the game crashes just as it loads into fullscreen mode, you can force it to load in a virtual desktop. This can be done either by running winecfg and changing the global setting, or on the fly by running Wine like the following example:
    wine explorer /desktop=Wine,800x600 MonkeyIsland101.exe

But I use a Mac! It has a UNIX logo on the box!
Telltale is porting stuff to Mac now. Did you miss the memo?

But if you mean specifically using Wine to play Windows-only titles...
Short version: Seeing as you guys don't mind paying $39.95 for a fancy lending list, you can take my word that investing the same amount in a copy of CrossOver Games would be the bargain of the century.
Long version: Apple's version of X11 is pretty crap and breaks with WineD3D. Apparently some fixes have been made to Xquartz, so I'll try it again soon.

What about Monkey Island's treasure-hunting feature?
Too much black magic.

NEW: I tried running Sam and Max Series 2, but instead of getting the serial number box I got a grey screen saying "Logging you in"! Also, the script complains about a missing noScriptDiv! What gives?
I just tried out S&M 201 yesterday, it appears to be slightly different in that it doesn't have any fallback HTML (like every other Telltale game) for entering the serial number and starting the game. To work around this, grab the latest copy of, which can now inject the missing bits of HTML. Unfortunately, you'll need to use it every time to run the game. Believe me, I'm crying as much as you are.

Well, I hope that worked for you guys. If it didn't, post here!
210 Comments - Linear Discussion: Classic Style
  • GozzoMan wrote: »
    But, if I run it in windowed mode (i.e. not wine virtual desktop, but selecting fullscreen to off inside the game), sometimes I get past the initial cut-scene and into the playable swordfight.

    Please ignore the quoted part: after a few other tests, getting to the swordfight seems to be totally random in respect to game settings. And it freezes nonetheless a minute into the playing.

    In other words: it freezes at a random time between more or less immediately (even in the options screen) and a few minutes after "new game", giving the aforementioned messages.
  • Hmm, I usually play in windowed mode. Whenever I try to switch to fullscreen, the X server instantly dies and I'm back to the login screen ! Any idea ?

    (using : Ubuntu 9.04, AMD64, nvidia 185.18.31)
  • the subtitles and texts that are unreadable. (look like "random data")

    Any idea ?

    I had this too with the garbled fonts.
    But when I tried to start the game from the installed directory instead of the wine link, the problem went away.

    cd ~/.wine/drive_c/Program\ Files/Telltale\ Games/Tales\ of\ Monkey\ Island/The\ Siege\ of\ Spinner\ Cay/
    wine MonkeyIsland102.exe

    Crisp fonts, good performance.
    Fullscreen 1440x900.
    Graphics quality on 9

    This is with pulseaudio enabled btw.
    I see a alot of references to Pulseaudio being a bad boy.
    Not so for me.

    Only problem I have left is that the game crashes on exit. No biggie.
    Oh... and the treasure hunt.
  • I had this too with the garbled fonts.
    But when I tried to start the game from the installed directory instead of the wine link, the problem went away.

    Ati or Nvidia? And which Wine-Version do you use?

    I ask, because I'm starting it always with this method. I'm using Ati and wine 1.1.27. I don't know, if this happened because of the newer catalyst-driver or because of the newer wine-version.

    Because... it worked perfectly before. :( (with Catalyst 9.7 and Wine 1.1.26, I think)
  • ChemBro wrote: »
    Ati or Nvidia? And which Wine-Version do you use?
    Ubuntu 9.10 beta x64 (Karmic Koala)
    Nvidia closed source driver 185
    Wine version 1.1.27 (in Karmic repo as "wine1.2")

    Hope that helps.
    If you need any other info just let me know.

    The patch from the first post IS required though!
  • The patch from the first post IS required though!

    Yes, but only to enter the game, not for the game itself. Maybe I wait for wine 1.1.28. Hope this will do it (else I blame the catalyst-driver).
  • I also have problems with the fonts, latest catalyst, wine1.2 from karmic. wine 1.0 from jaunty didn't work with the launcher of Epsiode 2, but otherwise it worked perfectly for Episode 1 8-(. I wish I could somehow get past the stupid launcher with wine 1.0 and I have a feeling the font issue would be resolved, too 8-(.
  • Seems like an ATI/Catalyst compatibility issue for sure - my Radeon 4830 does the same in all versions of Wine I've tried, although it was perfect for Episode 1 in Wine 1.0 :(
  • Okay, I installed Wine 1.1.26 and now I can see the font correctly. So it is definitely a wine issue. 1.1.26 = Font ok. 1.1.27 (and higher) = Font not ok (at least for Ati-Users).
  • Good news everybody, activation now works out of the box in wine-1.1.29, no patch required!

    You'll still need it to play the demo of course, as Telltale didn't add a link for that in their noscript page.

    The launcher still hangs (white page) after typing in your code, but if you kill it and restart it, it's fully activated :-)
This discussion has been closed.