Completely unplayable on Xbox?

So it isn’t just a problem with me I’ve noticed people on Twitter complaining about it. I usually never make threads like this but I sent an email to support a couple days ago about it. But since support takes awhile to respond I’ll just make this thread so people can wait. So the problem basically is as soon as the game gets selected it shows the title card and instantly just kicks you out. So yeah if anyone figured out a fix or just is waiting for a fix this is the place.


  • Well it’s working for me now mods you can close the discussion now.

  • Same exact problem im having and I was just playing it last night. I tried a hard reset on the xbox, tried resetting my router, I uninstalled both episodes and reinstalled them and it still didn't work so I don't think there's anything we can do about the issue, maybe with the new episode coming so soon caused some problem with the game itself.

  • Only took a 1000 tries and resets but it finally launched. Still don't know why only this game wouldn't launch when all others had no problem at all.

This discussion has been closed.