User Avatar Image

ATI Mobility Radeon 7500 problems with Sam and Max

posted by zig2101 on - last edited - Viewed by 975 users
I'm running an old sony vaio with windows xp and a ATI Mobility Radeon 7500 graphics card and when I run sam and max everything else seems fine but the video looks like random polygons are just floating around the screen, particularly coming out of max's eyes like white hot laser beams.

I'm using an older version of Omega's ATI Radeon drivers, because the last time I upgraded my drivers to the latest version, the refresh rate on my computer reduced dramatically and slowed everything down.
I tried turning down the detail but that doesn't seem to be the problem. do you have any suggestions or things I can try?

5 Comments - Linear Discussion: Classic Style
  • Unfortunately it's really hard to make any suggestions other than to update the video drivers. If they're very old drivers, chances are they're going to be incompatible.

    When you say the refresh rate dropped with new drivers... can't you just go into your display settings and crank it up again?
  • i think ATI stopped supporting older video cards so I've had to download new drivers from unofficial sources, like Omega Drivers and Driver Heaven, but the latest ones don't seem to work on my computer.
    actually it may not be the refresh rate.. when I run dxdiag it looks like direct3d isn't enabled. i'm guessing it's due to an incompatibility with the driver which also causes my display to be extremely slow. so i'll go post over on the driver forums of those websites to see if they can help.
  • If you find a specific driver that works, please post here so we know what to suggest for anyone else having this problem.

    I once installed drivers for my Nvidia Geforce 2 card that essentially broke direct3D, so I'm not surprised. It was almost like they were trying to force me to get a new video card by breaking it with the drivers. :eek: (I ended up rolling back to old drivers and direct 3D miraculously worked again.)
  • I got it to work after removing all the other drivers and going back to the simple vga drivers, then going to sony's site and downloading their latest drivers (although they were from 2004). it seems that the unofficial omega drivers is what caused my direct3d to be disabled.
  • Interesting. Thanks for the update.
This discussion has been closed.