User Avatar Image

Have tried Everything

posted by robotoboy20 on - last edited - Viewed by 167 users
I downloaded one of my episodes to catch up (since I havent played since episode 2) On Tales of Monkey Island "Lair of the Leviathan" I have tried everyway of unlocking my game but they dont work I could seriously use some help, Its telling me it cannot connect to the internet, I cant unlock with the serial number or login credentials. I even tried requesting a manual unlock code but that didnt work, because tell tale hasnt gotten back to me at all yet. Id really like to play my game I paid for, if anyone has had this problem before... What did you do?
2 Comments - Linear Discussion: Classic Style
  • I dont understand why Telltale hasnt done anything about my problem! I ended up RE-BUYING THIS ON WIIWARE!!!! This is driving me insane, if this problem occurs with the rest of my episodes... can even I depend on you guys to assist me with it!?
  • Check your pm's. Also, check your spam and/or junk folders for the support replies.
This discussion has been closed.