User Avatar Image

Swordfight zone glitch

posted by Javi-Wan Kenobi on - last edited - Viewed by 455 users
I experienced a glitch while on the crossroads swordfight zone. I only experienced it once, and thankfully I had a very recent saved game to go back.
After beating the swordfight and talking with Morgan, I exit the upper part by double-clicking on the exit. Then, I had the animation of Guybrush sliding down on the mast, but when I should have control of the game again, the camera was stuck on the upper part, with Morgan. I could see the pointer cross, but no hotspot to use it, and if I used WASD I actually walked (I couldn't see Guybrus, but I could hear his footsteps).
After reloading the saved game, I exited the zone only clicking, and there was no glitch.
Reloading again, I tried again the double-click, and there's again no glitch.
5 Comments - Linear Discussion: Classic Style
  • *sigh* Again, happens to everyone for once. So you got rid of it, then you don't need help. They're working on the issue at the moment.
  • What helps for me (and was already posted on this site) was to move the arrows (you know...that ones that you already use to walk around) down and right multiple times....

    Guybrush is at the top of the stairs and the down and right keys will make him walk down the stairs and the camera will soon follow him and you can resume playing.
  • I had the same error, but it was fixed if I exited to the menu and then resumed game. :confused: Here I just thought it was my computer, not a game glitch.
  • Ya, had the same thing every time. The bug seems to be that new screen isn't loaded after you slide down. I found that if you walk to the next screen by going down and right it carries on fine when the new screen loads.
  • Curious. I have the same problem, but, in the moment Guybrush touch the stairs, after moving for a while, it got fixed ^^!
Add Comment