User Avatar Image

Anyone else having problems launching Mac version?

posted by bradc on - last edited - Viewed by 8.7K users
I've downloaded the first 4 chapters of TMI, but none of them run on my iMac. They bounce in the dock for a couple minutes, then stop and sit there, without the little dot underneath that indicates an app is running. When I click and hold on the icon, I have to force-quit.

I'm on a 2GHz Intel Core Duo iMac with OS X 10.6.2. I ran the first couple chapters of the game in Boot Camp on the same computer, so I assume they should run fine on the Mac side too.

Anyone else having issues like this?
163 Comments - Linear Discussion: Classic Style
  • I downloaded Episode 5 and I can kinda open up the launcher. Sometimes I have to Force Quit, and sometimes the right side of the window loads and I can attempt to unlock the episode. So far I've been unsuccessful in unlocking the episode and I sent a request for a manual unlock.

    I'm running the same setup as you, but a MacBook, not an iMac.
  • I dl-ed the first Episode for Mac and when I click to launch it it just bounces in the dock until it eventually unexpectedly quits.
  • User Avatar Image
    Will BANNED
    Hey guys, so the bad news is that troubleshooting mac problems is an entirely new field for us, so this may take a bit of back and forth. First of all, are you guys running any other programs at the same time? have you tried rebooting and then launching? Are all of your device drivers up to date?

    Can you tell us your graphics cards?
  • User Avatar Image
    Kevin Telltale Staff BANNED
    If your mini is pre March-2009, then it has the Intel GMA 950 with 64MB of integrated memory. That machine will not run the game very well, if at all. Did it run well under boot camp?
  • I was running Mail, iChat, and Safari.
    I have a MacBookPro.
    2.16 ghz intel core duo processor
    1 gb of ram
    Looks like my graphics card is a ATI Radeon x1600.
    My drivers should be up to date as far as I know.
    I have not yet tried restarting.
  • same problem, yes it runs under boot camp but i need to lower the details to
    graphic card is an Intel GMA X3100
  • Won't even launch for me :(


    OS 10.5.8
    2.33 GHz Core 2 Duo
    2 GB RAM
    15" MB Pro
    Radeon X1600

    I have all the latest Software Updates, no other apps running at the time. I double click to launch and get:

    "The application Tales of Monkey Island -
    Chapter 1: Launch of The Creaming Narwhal
    quit unexpectedly.

    Mac OS X and other applications are not affected.

    Click Relaunch to launch the application again. Click
    Report to see more details or send a report to Apple."
  • Sounds like panfriendcharlie and I have the same specific issue. The common denominators between us are OS 10.5.8 and Radeon x1600.
  • I am running a MacBook as well and am having the same issue with the first episode "Screaming Narwhal." However, parts 2-5 are all working fine.

    I have tried re-downloading and reinstalling several times but it has never brought up the launch screen.
  • I'm running 10.5.8 on a MBP 13" (core 2 duo 2.26 GHz, NVIDIA GeForce 9400M, 4 gb DDR3). I can start episodes 3 and 4, the others "quit unexpectedly". Have re-downloaded several times to no avail.
This discussion has been closed.