User Avatar Image


posted by ben_ethus on - last edited - Viewed by 2.4K users
I got my Sam and Max Situation Comedy email, and clicked the link. It went to a page that was entirely white. Nothing else. Just white.

I tried to find my order using the handy 'find my order' page, and it returns nothing. Says no order exists.

Tried sending myself the correct password to verify I got it right, and it says no order exists with my order number...

It may be that I changed my email between my initial order and now. If so, I'm going to do what the dude said in the other thread and PM the fellow with my email swap.

If that doesn't do it, I have no idea what's up.
19 Comments - Linear Discussion: Classic Style
  • I got the same problem. I have not changed my address. And my order number starts with 4.
  • i got a similar message. First, I got the error"We have encountered an internal application error. The error has been logged.
    Contact System Support" When I went to check my password, it said that my order didn't exist
  • i did get the same problem to
  • I'm having the same problem, no email and the system says my order number doesn't exist.

    Order No - 4784332100 made 31/12/06
  • So did I, but I'm guessing it's due to the heavy traffic on the servers, so I'm just gonna wait it out. :P
  • Also ditto! And when I enter a password it says there was an internal error.
  • Pretty much the same problem here, got the order number from my past purchases page, though I can't remember the password for the life of me. I tried to use the Forgot Password option, but when I put in the order number, "The order number was not found." The purchase date was November 11th, if that helps out.

    Just an update, I just got an email with a download link, though the find my order still doesn't work. Ah well, this works too!
  • I also get the system error when putting in my one password. Oddly, if I use another password (i forget exactly which of the two I used), it doesn't crash, but can't find the order. I assume that's the 'wrong' password since it doesn't match the order or some such.

    Glad I'm not the only one having this problem.

    Having said that, I'd prefer to be having no problems, but I know the Telltale folks will work quick to resolve it.
  • I keep wanting to say "ditto," but haven't even received the email, yet. Just getting similar errors from the DigitalRiver store: errors when attempting to log in, and no order number found at the 'Forgot Password' option.
  • Unfortunately, leaving work and will be away from PC. Hopefully things can be sorted out when I get back on later. :)
This discussion has been closed.