User Avatar Image

Savegame troubles (merged threads)

posted by saxysousy on - last edited - Viewed by 12.7K users
How do you save the game if you don't want to play it all at once?

BTW, I LOOOVE it so far. Thank you Telltale for making this game!
168 Comments - Linear Discussion: Classic Style
  • User Avatar Image
    Macfly77 Moderator
    Esc should take you to the main menu where there is a Save/Load option.
    Some Telltale games don't let you save (or access the main menu) until you reach a certain point in the game (The Penal Zone is the one I remember best as I had some "freezing" problems and had to replay the whole beginning several times because I couldn't save), but I'm not sure if "It's About Time" is one of them...
  • well, esc doesn't work.. as I stated.. and I played fairly long before turning it off, even traveled in time once. a couple of hours. how long do I need to play before I can save, lol :D
  • User Avatar Image
    Macfly77 Moderator
    Not sure what the problem is, but after a few hours, you should definitely be able to save! ;)
    If I understand your first post correctly, esc doesn't do anything (not even take you to the main menu?), which is definitely odd (I just tried a new game and esc takes me to the main menu as early as the introduction).
    You should post your problem in the game support forum and maybe add a little bit of info like what computer you're using (PC or Mac) and which version you're playing (Telltale or Steam).
    Good luck!
  • This doesn't make any sense. You need to pos tthis on the tech forum.
  • correct; esc does nothing, no menu or anything. I run a PC, pretty high-end, and formated/reinstalled windows 7 yesterday (this game is the first one installed since I reinstalled windows; went in right after the drivers and Adobe CS). Mainboard, CPU and graphics are all of AMD brand: Radeon 5870, Phenom II X4 and I think 790x is the mb chipset name. DDR2 memory, 8gigs. Lotsa hard drives..

    maybe a mod of some sort could move this to a tech forum?
  • I know this may sound ridiculous but, have you tried pushing it harder?
    Sometimes my keyboard didn't respond quickly enough when I pushed Esc while playing the game. But when I tried pushing it harder it responded, maybe you should keep your finger for at least 1~2 seconds for the game to respond.
  • Milkman08;445771 said:
    I know this may sound ridiculous but, have you tried pushing it harder?
    I'm with Milkman08 on this one. It sounds like it's a hardware problem...

    After playing Gothic 2 (a game in which you walk...a lot...) my "Forward arrow key" stopped responding and I had to get a new keyboard.

    Weirder things have happened. Try borrowing a friend's keyboard and see if it works.
  • There's one key piece of information here, where did you buy it from tmfm?
  • where did I buy what from?
    anyway, esc button works in other applications, no problem. I'll try again later today and see if it works if I push it harder / longer in bttf. sounds weird though, as no other buttons need pushing harder or longer in the game nor in any other application.
    thanks for trying to help though. I realize this isn't a usual problem.

    seems like I found the problem. apparently, running photoshop CS5 in the background disables the esc button in bttf, for no apparent reason at all. I remembered I had it running yesterday when playing too, so I tried closing it. voila! esc works. and starting photoshop again disables it again, etcetera..
    I have no idea why it behaves like this. no big deal, though I do like to just pop into a game for half an hour or two while working. oh well, guess I'll have to do with closing and starting ps in the future :)
    again: thanks to all of you who tried to help.
  • I have just downloaded part 2 and have the same 'no save menu' thing going on. I have a legitimate copy of the game purchased directly from Telltale. Is there any way of fixing this? Would be nice if a mod could answer this for all users with this problem.
Add Comment