User Avatar Image

New patch?! Just started the game again and its downloading something:

posted by Chocolade on - last edited - Viewed by 1.3K users
I quit the game now run again after log in i clicked PLAY NOW and it started downloading something.
Something big.

I dont know if its a patch/fix or the whole game again cuz its big!
Im downloading on 1000KB/s and its not small file.
26 Comments - Linear Discussion: Classic Style
  • And there was an error cuz the game was on the background you should exit it and then choose RETRY.
  • The same thing has happened to me. I had installed BTTF and played for about 20 mins with problem, so saved and quit. When I went to try and play it again, it started downloading again from the 'launcher' - but this new file has messed up my installation and now I can't get BTTF to run. Hmmm - I'll leave it for tonight, and have another go tomorrow. The game is brilliant though, from what I've seen of it.
  • Hmm... Yeah, it is doing the same thing to me too. I let the launcher download the file, but it wouldn't install. I realized that it looks like the game was trying to install itself again. After that, the launcher wouldn't work (none of the graphics showed up, buttons wouldn't work).

    I uninstalled it and I'm preparing to try again. I'll exit out of the launcher before the installation starts. Hopefully this should do the trick.
  • Yep. This is happening for me, too.

    Here's exactly what I did:
    I went to the "My Games" page and downloaded the BTTF installer from there. All 367MB of it. I then installed it. All apparently went ok.

    I ran the game and the launcher asked me to log in (annoyingly). Once I had done that it then started downloading this massive file at 1200 KB/s...!

    Once that was finished downloading it then executed bttf_101_setup.exe from my Documents/ folder... the file is had just downloaded. Yes, that's right, the game attempted to install itself over itself!

    I compared the two bttf_101_setup.exe files (the one I downloaded from and the one the Launcher downloaded) and they were identical...

    File version: 2010.12.22.1055
    Size: 376,816 KB

    Unsurprisingly this creates an error -- The installer can't overwrite BacktotheFuture101.exe -- and makes it impossible to continue.

    What gives??

    What with this and the bugginess of Poker Night at the Inventory, it's really shaking my faith in TellTaleGames. Did their QA dept drop the ball, or has someone decided that they don't care about fixing bugs anymore??

    Also: Talk about shoddy, but BTTFs save files are stored in a folder called "Episode 1" in my Documents/TellTaleGames/ folder. Just as well they haven't done this before or there'd be a conflict with their previous games... way to go.
  • OK there's something very wrong here ... I downloaded BTTF again from the 'My Games' link, installed it and it picked up from where I had left my last game - played the game for another 20 mins without fault. Saved and exited - and I've tried to play it again from the launcher - and it wants to install the game AGAIN - this is a major bug. Telltale please help!
  • Same problem the "update" has ruined my ability to run the game. Play button does nothing now.
  • Well, I reinstalled it the 2nd time without an error, and when I boot up the launcher I can click "Play" without it downloading again, but it won't do anything once I click that button... Hmmm... I'm not really sure what to do now...

    Edit: It might be a good idea to note that under the episode title, it still says "Begin Installation."

    Edit 2: Uninstalled and reinstalled the game again. This time, I was able to run the game. When the launcher booted up, the note under the episode title says something like "Ready, begin the game," or something of that sort. Taking Sally's experiences into mind, I immediately exited the game and reloaded the launcher. Now the note under the title says "Now Available!" and clicking "Play" will begin the download, once again. Pretty weird... At least this sounds like something that can be fixed somehow.
  • That's exactly the same error that I'm getting. There's something wrong with the launcher. Chocolade - I don't know whether this is possible, but would you be able to Edit the title of this thread to alert the Telltale team to look in it please, so that they can amend the launcher?
  • I just posted this in another thread but it might be more appropriate here:

    I had that initially but fixed it by opening the properties for the shortcut (via the right mouse menu) and choosing advanced on shortcut tab and checked the run as administrator box (though really I only did that after manually selecting run as administrator a few times). It should be noted that I'm running Windows 7, and as I don't know what you're using I don't know if this'll help at all.
This discussion has been closed.