User Avatar Image

Stuff to fix in Episode 1 (Possible Spoilers)

posted by prizna on - last edited - Viewed by 9.2K users
Seems people have mentioned problems with the episode all over the place, thought it would be a good idea to get them all in one place so its easier for telltale to find and get fixed for the DVD release, im not talking about the people saying "its to easy" and "its to short" and other stuff like that, im talking about audio problems and graphical problems and stuff like that so if you know of any post them here.


Game Breaking Bugs:
  • It seems it’s possible that the elevator is never activated for the cellar at the soup kitchen, so when you need to do it later. Marty just goes, "This pipe leads to the basement" therefore halting the story and causing one to have to restart the chapter.

Audio Bugs:
  • Characters calling Marty the wrong name, e.g. Player chooses “Harry Callahan” as their name but characters call Marty “Michael”.

  • When Kid Tannen chases you up onto the gazebo, there is a close up of his face and you can see his lips move like he is yelling but no sound. (there is no subtitles either, but he is obviously supposed to be yelling).

  • If you get chased onto the gazebo twice after you get Einstein to attack just after Matches says "look its that crazy mutt again" there is another part where their lips move but there is no sound. (there is no subtitles either, but they are obviously supposed to be speaking).

  • The first time Marty walks up to Kid and Matches before they chase him up onto the gazebo, their lips move but there is no audio.

  • When talking to Edna about letting Marty do the deliveries, she does not have an audio reply, though her lips move.

  • In young Docs lab when making the fuel, Docs father yells "EMMETT" (can tell because of the subtitles) there is no audio.

  • When Emmett gives Marty the subpoena, Marty reads his grandfather's name, his lips move, the subtitles show "Arthur McFly", but there's no sound, only "I got to subpoena my grandpa?" is heard.

  • In the german version at the beginning when Doc is reading his notebook, Doc's voice is done by the dubber of MARTY.

  • Sound effects for background noise continue into next scene. e.g. After Marty first travels into the 30s he hides the time machine behind a sign, when the cutscene goes to Hill Valley in the daytime the night sound effects (insects and such) stay. This also occurred at the end of the game when the end credits rolled, there was still the night scene sound effects.

  • In the German version almost every second sentence stops before the whole sentence is spoken. Without the subtitles the game is unplayable because you often just dont´t know what the characters are saying.

  • Some people have had problems with no audio while Marty is drilling through the jail wall.

  • There are some audio imbalances throughout the episode where one character's voice is noticeably louder than another's or where it's louder than the previous things said by the character (pretty obvious in Doc's Lab at the beginning).

  • When in the DeLorean cicking on the "Time Circuit Display" and clicking on the "Time Circuit Keypad" give the same line of dialogue. (Possibly not a bug)

Graphical Bugs:
  • Double wormhole emitter on the DeLorean when the steam gets the police car off the road in 1931.

  • Often there is a kind of a square in form of thin black lines visible around Marty.

  • When the DeLorean first arrives in 1986 and Marty is inside, if you click on the time circuits, after the line of dialogue, Marty will kind of "jump" back into his seat.

  • When the Delorean first appears and the camera does a slow pan down the car, there is a sort-of halo around its edge that smoke effects don't work in.

  • During a cut scene, Emmett wasn't walking but sort of hovering in his set path from the courthouse to the lawyers' building.

  • The back wall of Emmett's lab disappears after finishing the experiment.

  • After you finish the alcohol fuel puzzle, Emmett starts cranking the generator but, in a moment, the handle stays still while Emmett still moves (his hand goes through) and the handle continues moving when his hand reaches it again.

  • The brick texture on the jail is upside-down (look at the shadows)

  • After doing the making rocket fuel puzzle for a while the bellows stay pushed down.

  • Someone had a problem with Young Doc completely disappearing for a brief moment during a conversation with him in the town centre.

  • In the first sequence, after Marty says "out of a DeLorean?", his head jumps to another position.

Language Bugs:
  • Upon downloading the english version, German gamers still get German subtitles and text (if they don't fiddle with their system language). There absolutely MUST be an option to change that in-game.

Launching Bugs:
  • Double download problem (download starting again after clicking play) I know there is a work around (run as administrator) but would like a proper fix.

  • The launcher doesn’t seem to load (stays black) for some people with Windows 7.

  • If the application is renamed on Mac, the launcher just quits when "Play" is clicked. If the original name, (BackToTheFuture101) is used, it works fine, but if changed to a prefered name eg “1 - It's About Time..." it just quits when play is clicked.
  • When Edna introduces herself in 1931, she says she writes for the Hill Valley Herald, but in 1986, she says she wrote for the Hill Valley Telegraph. Doc reads off Edna's byline in the Hill Valley Telegraph as well.

  • It's possible to ask Young Emmett in the town square where Arthur is even after you've found him. Emmett answers that he doesn't know, while he obviously should.

  • Marty parks the DeLorean behind the "Car of the Future" billboard when he arrives, but then, when Doc and Marty get to the DeLorean again, there's a fence going along the road which wasnt there when Marty parked it.
Spelling Mistakes:
  • In the Prologue (Marty's Dream) "square" is spelt as "sqaure".

  • Before Einstein attacks young Edna she says "etiquette", but it's subtitled as "ettiqutte".

  • When you talk with Doc and ask him where he's been all this time, “Unpredictable” is spelled as “Unpredicatble”.

  • When you ask Doc about Edna for the first time, he says they never "socialized" much, but it's spelled "soicalized" in the subtitles.

  • When talking to Doc in jail “Dimensional” is spelt “Dimenionsal”.

  • When talking to Doc about Barrels, “Barrels” is spelt “Barrles”.

  • During young Docs experiment (getting the alcohol fuel for the rocket drill) one of the times young Docs father calls him the subs say "Emmet" instead of "Emmett".

  • In the subtitles Einstein's nickname is spelt both "Einy" and "Einie" eg In the opening cutscene it is spelt "Einy", but when you are in 1931 and click on Einstein the subtitles show Marty call him "Einie".
  • Please allow an option to remove the buttons at the top of the screen (Goal, Hint etc) to allow for more screen space.

  • Please make "hints off" actually mean "hints off", even in the first scenes, when Twin Pines Mall and Doc's Lab's interior are literally obstructed by these hints most of the time.

  • In the German Version, When talking to Cueball about chilli powder, salt etc, he mentions the 2nd World War, he shouldn't know about the 2nd World War since it had not occured yet in 1931.

  • The 6 & 9 digits on the DeLorean's time circuits are displayed incorrectly (in the movie the 6 doesn't have the upper horizontal line and the 9 doesn't have the lower horizontal line) here is a comparison picture

  • When using the tape recorder on Artie to get him to come downstairs Marty and Emmett are under the balcony, then Marty walks out from under it, then in the following cutscene Marty and Emmett are seen walking under the balcony as if they are coming from the sidewalk.

  • If you choose continue from the main menu, in the animation of the DeLorean driving off, the digital speedometer doesn't work (it doesn't show the numbers changing up to 88)

  • When Marty and Doc get out of the paddywagon and Kid is about to crash into the manure truck, he turns the wheel left, but the paddywagon turns right and crashes on its left side.

  • Shaky Tires of the Delorean, right after Marty jumped back to 1931 you can see them.

  • The ClockTower doesn't have gargoyles and the ledge seems too wide (Doc could walk on it without fear of falling).

  • Marty should be more surprised about seeing the DeLorean again after it got destroyed (add a line of dialogue).

  • George and Biff should leave Doc's Lab before the DeLorean shows up or at least act surprised by the noise of the DeLorean appearing.

  • If right click is already held down when audio starts it will skip audio, for example, if using the right click to run up to Kid Tannen and Matches (at the point where they chase you) since it enters the dialogue automatically if right click is still held down when the dialogue starts it wll skip the dialogue.

  • The DeLoreans cooling vents should not steam.

  • Moving re-entry point (The three sonic booms move with both 1931 cars instead of happening in the same place the DeLorean disappeared)

  • Just one flash on the 1931 re-entry: We only see the last flash of light as the DeLorean reappears. In the movie (first re-entry, as the developers have said that they're following the effects from Einstein's 1-minute trip), with each boom and faint DeLorean image, there's a subsequent flash; which is not present in-game until the last sonic boom.

  • DeLorean's wheel-drive: All 4 tires spin (in front of Doc's lab) even when only the rear ones should spin/burn.

  • The scroll-down button in dialogue options is rather small, at least compared to the overwhelmingly big "clocktower dialogue line pointer". This does lead to confusion

  • You can still click on the barrels of bootleg alcohol when they are already dropped. Good thing Cue Ball doesn't look at the now leaning shelf with no barrels when you talk about them.

  • The preview at the end of the game says episode 2 will be released in February 2010.
215 Comments - Linear Discussion: Classic Style
  • When you go into the Mrs Strickland's house in the presente,if you try to leave to to to the videostore she said something but it doesn't appear in subtitles.
  • anyone else having this little graphical glitch in 1931? when you walk around the courthouse place, theres pretty often a kind of a square in form of thin black lines visible around marty.

    tried to turn of aa, doesnt help. haven't tried to reduce the graphic quality (and i dont want to)
  • Another glitch: Strickland calls me Corleone even though I told her that my name is Harry Callahan.
    Well, at least Marty told Emmett that his name is Callahan. :D EDIT: Now he called me Michael, wth.
    I wanna be Harry Callahan! :(
    Cyphox wrote: »
    anyone else having this little graphical glitch in 1931? when you walk around the courthouse place, theres pretty often a kind of a square in form of thin black lines visible around marty.

    tried to turn of aa, doesnt help. haven't tried to reduce the graphic quality (and i dont want to)

    Same here, I guess.
    There were also some graphical glitches in the introduction video, where you see the scene from BTTF I through Marty's camera.
  • In the soup kitchen, it seems as if Marty talks about the spice rack in DOC's voice at some point. Do I have a problem with my ears or did anyone else notice that?
  • Just a quick one (Bit of a rookie mistake actually), but in the credits it claims that the next episode is due out in February 2010. Probably just due to them wanting to get the game out on time. Unless of course it's some sort of time travel joke.
  • The double download problem (download starting again after clicking play) I know there is a work around (run as administrator) but would like a propper fix.
  • I had a brief but recurring lips-moving-without-audio glitch from Kid during the bit where Marty climbs to escape him.
  • prizna wrote: »
    The double download problem (download starting again after clicking play) I know there is a work around (run as administrator) but would like a propper fix.

    install the game in a different directory, like c:\games\whatever

    or disable user account control

    or... i dont know...
  • I didnt install it in the default, its in C:user\games
  • prizna wrote: »
    I didnt install it in the default, its in C:user\games

    you mean c:\users\

    not quite sure if its protected the same way, but imho its a necessary system directory too, just as program files is.

    try c:\games\bttf or whatever you wanna call this directory
Add Comment