User Avatar Image

Poker Night at the Inventory and Puzzle Agent Start-Up Issue

posted by ElTipejoLoco on - last edited - Viewed by 534 users
Hello everyone. I'm in a bit of a bind, trying to determine what is triggering the following error:
The application failed to initialize properly (0xc0150002). Click on OK to terminate the application.
This error occurs for both Poker Night at the Inventory and Puzzle Agent. I saw a couple of threads referencing this issue previously, and went ahead and did what was asked of the individuals who were experiencing problems and attached a few files showing what dxdiag and dependency walker/ had to say about my system and the executables in question.

It appears I'm missing either one or several .DLL files from my installations, but I wanted to confirm if that was the issue before I went about trying to install one or more files that may or may not solve/cause them.

Thanks in advance!
5 Comments - Linear Discussion: Classic Style
  • Installing Visual Studio C++ Express 2010 made the game say something about it trying to call a runtime library improperly upon start-up... and then, well, brought me to the sign-in-to-play-launcher.

    I didn't try it out because of the error, and decided to go ahead and download the 2008 redistributable files and try to run Poker Night again. It showed the error again anyway, but I'm assuming it might need a restart.
    Runtime Error!

    Program C:\Program Files\TellTale Games\...

    An application has made an attempt to load the C runtime library incorrectly.
    Please contract the application's support team for more information.
    This time I tried to actually run Poker Night at the Inventory instead of backing out, before I restarted. Started out in windowed mode, then it loaded up the TellTale Games logo, then went to a black screen for a while, and then popped up the title screen (I guess), uneventfully. I don't know if anything was missing between.

    Tinkered with the settings, uncensoring language, adding subtitles, changing resolution to Full Screen 1360 x 768, etc. etc.

    Aside from being slow when going down the lift and the initial error, the game runs, what I'm going to assume is perfectly-ish. My video card occasionally makes polygons randomly jut out in random directions, but I'm not sure why.

    Now, trying to run Puzzle Agent results in the same Runtime Error upon start-up. The game runs as well, however, and as far as I can tell- without the slowdown I noticed in Poker Night at the Inventory. Well, actually, with a tiny little bit of it during Nelson's scream during the intro.

    Since I'm running the games on a different computer than the one I'm posting this message with, I'm going to make a new post to attach the newer dxdiag and dependency walker transcripts.

    Thanks for the help, though- at least the games are running now!
  • User Avatar Image
    DjNDB Moderator
    ElTipejoLoco;431734 said:
    Installing Visual Studio C++ Express 2010 made the game say something about it trying to call a runtime library improperly upon start-up...
    I get the same error message, at least with poker night, as do some others. Besides that the game runs fine. I don't know if it will be fixed at some point.
  • Here's the diagnostic files from DxDiag and dependency walker/ now that the games are running- run-time error non-withstanding. Hopefully it helps someone later on, employee or player alike.

    'course, I'm subscribed to the thread, so if anybody pops in to say "I/We fixed it, and here's how", I'll get notified. Even if it's just "maybe turn down the graphics quality for Poker Night and see if that improves its frame rate".

    Thanks again! Happy gaming.
  • i get a pop up that says there was a runtime erroe when i try to play poker night at the inventory
This discussion has been closed.