User Avatar Image

Ep4 crash (formerly "It's getting worse")

posted by dr_debil on - last edited - Viewed by 3.7K users
seems like the programmers are making progress... :D in episode 4 i can't even see the intro. it crashes right after pushing the launch button...

episode 1 works without any problems... 2,3,4 don't. why the hell did you modify the engine???

THIS SUCKS!!!:mad:
41 Comments - Linear Discussion: Classic Style
  • Hi,

    I split this into a new thread because it's not clear to me if this is the same problem as in the thread you originally posted it in or not. It can be really hard for us to help when people post about different problems in the same thread. ;)

    A few questions for you:

    1) What EXACTLY happens when you press the Launch button? Does it just crash to desktop? Do you see an error message? (If so, what does it say?) When you press ctrl-alt-del and look at the processes running, is Sam & Max one of them?

    2) What are your system specs?

    3) What problems did you have with episodes 2 and 3? Memory violation errors? Random crashes?

  • wow extremely fast answer. i'm really impressed. :)

    the error messages i get are the access violation errors. Error:Access violation at 0x00650505 (tried to read from 0x1A33D786),program terminated... in case of episode 4.

    In episode 2 i got this error after playing some time. after getting it, i couldn't start the game anymore without getting the error except when i was deleting the savegames.

    In episode 3 the error occurs right after the intro.

    In episode 4 right after pressing the launch button.

    Hardware: Athlon Venice 3000+, NVidia Geforce 6800 (AGP), 1024MB DDR, ASUS A8V Mainboard, Soundblaster Audigy.

    I tried to run the games under Windows XP SP2 and Windows 2000 SP4
    No success! Only episode 1 is running...
  • Hey guess back :D

    ...yeh its occured again, doh!! Im beginning to think its my machine so im just gonna go and invade my brothers house this time round and enjoy it, crash free, instead of having to restart every few minutes.
  • dr_debil - when exactly did you get the error? Had you pressed the LAUNCH GAME button, or did it crash on its own while the "retrieving key" message was visible?

    Sorry if it seems nitpicky, but a few of us here just experienced an issue with a different game that may or may not be related.

    EDIT: Just noticed you said "launch button" above, so I think you answered my question already. :o
    Im beginning to think its my machine so im just gonna go and invade my brothers house this time round and enjoy it, crash free, instead of having to restart every few minutes.
    Well it's definitely not JUST your machine, but if you can play it on your brother's without the crashes, that's better than nothing.

    This time, when did you get the error message? It's always been a recurring, throughout the game thing for you, right?

    We are still doing our best to get to the bottom of this, guys!
  • Yeh its still recurring throughout the entire game in this episode as well by the looks of things. Thanks for the quick response as probably seen me coming right? :p
  • Hey dr_debil - can you please run a DXDiag report and send it to [email][/email]? Mention this thread so we'll know who you are. Thanks.
  • I'm getting this problem as well with episode 4. As soon as I click Launch Game, I get "Error: Access violation at 0x007500AC (tried to write to 0x1DF9EDC5), program terminated." Compatibility modes do not help.

    Episodes 1 and 3 have no problems. (I haven't reinstalled 2 on this machine yet.)
  • Thanks, as always we're looking into it.

    Sgt. Chimp, if you could send over your DxDiag too, that'd be great. Thank you.
  • The laucher starts normally, but after I click "launch game" there's an error dialog about an access violation.

    For Ep2, at 0x74FFFF (read 0xCF725A35 (not even in user mode)). There are two instances of "Sam and Max...exe"; the child process is the one that's crashing. A stack trace of the main thread (the one that owns the error window) contains:
    Sam and Max - Situation Comedy.exe+0x34ffff
    Sam and Max - Situation Comedy.exe+0x35160a
    Sam and Max - Situation Comedy.exe+0x35689e
    Sam and Max - Situation Comedy.exe+0x3470b9
    Sam and Max - Situation Comedy.exe+0x347723
    Sam and Max - Situation Comedy.exe+0x107db9
    Sam and Max - Situation Comedy.exe+0x10b7b2

    A small window with a white background is visible beneath the error box.

    For Ep4, at 0x7500B4 (read 0x6A817717). As before, there are two S&M processes, with the child crashing. A stack trace of the main thread:
    Sam and Max - Abe Lincoln Must Die.exe+0x3500b4
    Sam and Max - Abe Lincoln Must Die.exe+0x119399

    In this case, it created no windows besides the error dialog.

    Episodes 1 & 3 run fine (well, except for excessive memory usage).

    This is on an Athlon 2800+, Asus A7N8X-X (nForce 2 based), 1GB of memory, WS2003 SP1, a GeForce 3 Ti 200 with ForceWare 93.71 ( internally). I've tried deleting prefs.prop to no avail. I can send dxdiag info if you want, and can use a debugger FWIW.
  • Heeeeyyyyy!

    I just reinstalled S&M episode 2 and got a similar problem to Cone of Tragety [sic].

    Error: Access violation at 0x00750002 (tried to read from 0xFFFFFFBB), program terminated. If I attach a debugger, the latter address is 0x0000003F.

    Not only that, but I've got several system specs in common. AMD CPU, nForce4-derived motherboard (Shuttle, not Asus), ForceWare 93.71, and Server 2003 SP1.
This discussion has been closed.