Can't Launch Either Episode of Back to the Future on Mac

edited February 2011 in Game Support
I have a Mac Pro Dual-Core with 6 GB of RAM running OS 10.6.6. I downloaded Episode 102, Get Tannen!, last night and could not launch it. Tried again today without success. I get the Episode Launch Screen, select the game, click the Play button and...nothing. The screen quits without any error message.

I had the same problem with Episode 101 at first but it then was able to launch it after re-downloading. Now that episode does not launch either!

I have re-downloaded Episode 102 4 times, have signed out and back into the site, have deleted the Application Support prefs.prop and Preference plist files for both games and still can't launch either episode.

Any help would be appreciated.

Update with Solution!!!
I finally got both games to play, with no real help from Telltale Games.

This was the issue: The launcher gets confused if you have moved the game application file (Mac) from its original location in the Applications folder. I have a subfolder for games in my Applications folder and had placed both games in a BTTF folder inside my game folder inside the Applications folder. Once I moved both games back to the Applications folder, they worked. Not sure this applies to all of the problems others have reported but this worked for me.

So...on a Mac, make sure that you install all of the BTTF games at the highest level of the Applications folder and not inside any additional folders within it.

Telltale Games, your lack of response regarding support for these problems is really unacceptable.


  • edited February 2011
    I have the same thing but mine won't let me get on.It says it quit unexpectedly. Is there more information that there not telling us?
This discussion has been closed.