User Avatar Image

Can't proceed to checkout

posted by Sorsha on - last edited - Viewed by 2.1K users
Hi there

I am hoping you can help me. I am trying to buy Sam & Max Episode 1 and I can't get to the checkout. I can put the game in my cart, but when I hit the button to proceed to checkout, it says it is loading the page but then it just stops and won't go any further. I have tried this on two computers now with the same problem.

I have also downloaded the demo and when I hit the button to buy the game in the first screen, it just comes up with a blank window.

Please help, I really want to buy this game!

17 Comments - Linear Discussion: Classic Style
  • Hey - likewise for me - I'm trying to buy episode 4 but the site locks up when I try to go to the checkout.
    So, Guys, I'd really like to give you money but your download system wont let me.
    I had no problems with eps 1 thru 3 but it just wont let me buy ep 4.

    Any help would be appreciated (I figure some response is called for in the least cos I'm trying to give you money :P).
  • Hi guys,

    Is this problem still occurring? I've tested it and am not having any trouble proceeding to checkout. It's possible that a temporary server problem prevented it (that's what it sounds like), so if you could please give it another try and let me know if it works this time, that would be helpful.

    If you're still unable to check out, please let us know what browser you're using, how you connect to the internet (including your ISP), and what security / antivirus / firewall software you have. Thanks.
  • I've also noticed a problem where some antivirus apps or internet security apps get a little overaggressive with third party cookies and don't like the fact that when our server hands you off to, immediately plants a cookie. I had an idea about how to avoid that, but it's not super high on my list since it's not a widespread problem (and is pretty normal web behavior anyway). You might try disabling your internet security software and give it another shot. ZoneAlarm and Norton Internet Security are some known culprits where certain configurations cause the problem.
  • Ok I've tried it again and yes I am still having the same problem.

    I am using Internet Explorer and my ISP is Internode Australia.

    I am not currently running any anti-virus or internet security (bad of me I know, I am looking for a new one at the moment)

    I have turned off the windows firewall, pop-up blocker, turned all the security settings down and still no luck. The only other thing I can think of is that I think my router has an inbuilt firewall, but I have never had any trouble before with that preventing cookies or anything.
  • :(

    Since you're trying to buy episode 1, which is also available as a try-before-you-buy demo, I suggest downloading it here and purchasing through that. My hope is that whatever is causing the problem in the store isn't present in the tbyb version. It's not a good long-term solution because there are certain things that can't be purchased through the demo, but it would at least allow you to buy and enjoy the game while we work with DR to figure out what's going on here.
  • I'm afraid I have already tried purchasing it through the demo, that didn't work either.

    But the good news is, I have found a way around the problem for now. I tried purchasing from work and it all went through fine. Which is mystifying, because work would have a whole lot more security, firewalls etc than home. So I have no idea why it is ok at work but not at home.

    Anyway, at least I have finally bought it, yay! Just have to hope it all activates ok at home.
  • I'm afraid I have already tried purchasing it through the demo, that didn't work either.
    Oops, you said that in your first post, guess I missed it. Sorry.

    I'm glad buying it at work was successful. There must be something about your browser setup that the site didn't like (or vice versa).

    Did you end up buying it through the online store or the demo version? If it was the store, just go to this page and use your order number and the password you created during checkout to look up the order. Then you can download a preactivated version straight to your home machine. If you bought through the demo version, you can still look up the order but you won't be able to download from that page. Instead, just download the demo from our website, click "I've already purchased this" on the first screen, and enter your order number and password. (This activation method only works if you bought through the demo originally.)
  • I bought it through the online store, so I will download the preactivated version when I get home. I just hope the problem I've been having doesn't block me from doing that as well!

    I'm glad you told me how to do it though, otherwise I would have been trying to enter the order number on the demo version, I didn't realise that only worked if you purchased through the demo.

    Thanks for all your help Emily, I'll let you know if I have any problems getting the activated version.
  • Hi,

    I'm trying to buy season 1 of Sam & Max, but after I press "Submit Order" button from the order summary page I always got a page with this message:
    "We are unable to process your order. Please verify your information and try again."
    Try it a couple of times.. disabling anti-virus and spyware softwares.. no luck.
    Oh, and the page has no links or buttons to click! Just Telltale logo, a "Checkout" text and that message. An error on the server?

    Help please.
  • Is there any chance you're entering the wrong billing information (i.e. it doesn't match what the bank has on file)? That's often what causes this problem.

    I'll get in touch with Digital River and try to get more information for you.
This discussion has been closed.