User Avatar Image

[BTTF] How do I play the First Episode for Free?

posted by Euphonik on - last edited - Viewed by 1.7K users
Hi i downloaded episode 1 and i cant unlock it offline where can i get a code?
39 Comments - Linear Discussion: Classic Style
  • Euphonik I got the same problem with that too because because all the signs were blank as well when I downloaded a free episode of BTTF episode#1 in fact I the people who downloaded might have the same problem as well? I think one of us should report this to IGN admittedly!
  • I also have this problem, and have Emailed support. I'll post here if I get a response.
  • hi, i've just downloaded BTTF EP1 for free. i have registered with telltale games but the game doesn't recognise my username /password.

    any help would be greatly appreciated! :confused:
  • gerry74;505852 said:
    hi, i've just downloaded BTTF EP1 for free. i have registered with telltale games but the game doesn't recognise my username /password.

    any help would be greatly appreciated! :confused:
    Where id you download the game from?
  • got it at fileplanet - is it not legit?
  • Just downloaded free BTTF ep1 at Telltale website. Already registed at Telltale site & logged in with id/pw. Game login page won't accept id/pw. Please help.
  • Hi,
    I just downloaded the free episode I from TellTaleGames, I registered on the site (this is difficult ! not easy to find where and how). However when trying to login the game, it says:
    "Sorry, but it does not look like you own Back to The Future..."
    How do I get to try the promised Episode I ?
    Thanks,
    Tal
  • yea Im having the same problems. Uninstalled the fileplanet version I had and redownloaded from telltale and also tried running in admin mode and still same problem as youve said.

    Im not sure if there is a way to add it to your games first. Havent found anything.:mad:
  • it accepted mine however it doesnt load because it says I didnt buy the game.
  • Same here. Spent a few hours trying and trying to log in, browsing the forums, trying the fixes for when this happened to users in early April.

    Has something changed with this to cause it to happen again? I got bored. I'll try again in a few weeks.
This discussion has been closed.