User Avatar Image

Abe Lincoln slow beyond anything playable

posted by AndromedaNoShun on - last edited - Viewed by 598 users
While I encoutered some frame rate problems in the other games (especially the car chase in "the mole..." which took me a solid 10 minutes for a passage that's supposed to take about 10 seconds) abe lincoln just becomes unplayable as soon as I enter the white house... dialogue is sluggish, everything slows down almost to an halt...

I dont think the games are quite as optimized as they should be... It's not like they showed particular technical prowess...

Anyway, I dont know what to do... Except wait for a new pc :s

amd athlon 2 ghz
ati radeon 9000
512 mo ram
5 Comments - Linear Discussion: Classic Style
  • Are you playing Telltale's version or the version on GameTap?

    Do you have other programs running in the background while you play? What virus protection software / firewall do you have, and are they trying to check the game while it's running?
  • I use telltale's version, I tried with no programs running in the background (improved, but still not quite playable), I use avast! antivirus and outpost firewall ^^ and as far as I know, they dont meddle with the game while I'm playing ;)
  • Hmm... what settings are you using? Have you tried turning the graphics settings down to low and the resolution to 800x600?

    On the chance it's a problem with your computer, have you run a virus scan and defragged your hard drive lately?
  • I have the same problem, and I have to agree with the topic starter. I can play anything from FPS games to World of Warcraft with no problems at decent framerates, but these Sam & Max games get sooo jerky in certain places. Where?

    As soon as I enter the White House and the president starts talking. Even after the sequence, walking around is impossible due to the single digit framerate I get.

    Walking from the office to Bosco's, although this is fixed by playing in 800x600with low quality graphics. Seriously, with a game with as many 3D objects as this, it's unbelievable how poorly it runs.

    And of course, the car sequences.

    I have a P4 2.66 Ghz laptop, with 1 GB of RAM and a Radeon 9000 Mobility in it. As said before, I can run games with way more graphic complexity at higher resolutions and higher framerates than Sam & Max with no problems whatsoever. Just now after trying the 'Enter the White House' sequence again, my laptop just gave up and shut down. This really deserve to be fixed.

    As said before, this is all at 800x600 in low quality. I used to have the Omega drivers before trying to play today, and have now switched to the latest Ati drivers which give exactly the same results.

    Hope you folks are working this Saturday :D
  • elrapido, sending me a threatening PM because I was not able to magically conjure up a solution to your technical problem on Easter weekend is not a good way to get our attention.

    We have been very honest about the fact that we aren't entirely sure what's causing this, and that we have not been fully able to test it and figure it out due to Season 1's production schedule. We've also made it clear that anyone who doesn't want to wait for us to figure out the problem can easily get their money back, all you have to do is ask. It's the best we can do right now, and frankly, it's better support than you'd get from most of the game companies out there. So don't tell me how to do my job, thanks.

    AndromedaNoShun, thank you for letting us know that you're having this problem even though the memory leak was supposed to have been resolved. We'll continue to investigate.
This discussion has been closed.