User Avatar Image

Can't Authenticate/Activate My Games (Mac)

posted by Nintendork on - last edited - Viewed by 511 users
I felt the need to create another thread, because the last one I had got taken over by people complaining about the Walking Dead getting delayed.

I recently bought the Walking Dead preorder/Almost Everything combo. I have downloaded and installed many of the games. But whenever I try to launch them, all I get is a page with background art, and a bunch of blank buttons and text fields. Since the text fields won't accept any input, I am unable to login and authorize my games.

I am not the 1st Mac user to experience this, here are some of the threads I've found discussing the same problem, or a very similar one. None of the threads I've read contain any effective answer from a Telltale employee, most of them don't even have a single response from a Telltale employee.

Here's one.


And Another.

It upsets me greatly that this is a problem that has existed for a few years and has not been officially addressed by Telltale.

In addition to my recent forum posts, I also sent in a handful of emails to the support email address. I have received 1 automated response, and one personal response advising me to try something I had already tried.

I understand that Telltale is having some big server issues, and are probably using all their resources to get those fixed, but this is a problem that appears to have been around since 2010, and should have been addressed by now.

I really want to play the games I bought. I request that this thread get acknowledged by a Telltale employee, and that I am given the solution to my problem, or, if no solution currently exists, an indication that a solution is being worked out.

Thank you, and please respond soon.

-Tim D

[Some more info on my situation:

Issue number I was given in the auto-response email: [issue-58120]

My computer specs:

OS X 10.7.3
2.7 GHz Intel Core i7
4 GB Memory
AMD Radeon HD 6630 256mb

Some of the things I've tried:
- "Turn off firewall/antivirus" (My firewall has been off the whole time, I don't have any anti virus programs)
- "Turn wifi off, try offline activation" (Problem persists, text fields remain empty, buttons stay blank)
- "Run the game from the Terminal" (Did nothing)
- "Reinstall/Redownload" (First thing I did, have tried it many times since)
- "Cry" (Almost...)
- "Change permissions/Try as Admin/convert file in disk utility" (None of that worked)
- "Download them from a different browser." (Switched browsers from Safari to Firefox, problem persists)
- "Rename the game files" (Enter in the file names by hand, but it didn't help. They were correct when I downloaded them, anyway.)

And pretty much everything else mentioned in the older threads I linked to. ]
6 Comments - Linear Discussion: Classic Style
  • Hi,

    I've responded to your email at least twice, including this afternoon. Have you checked your spam folder?

    That's typically caused by our launcher not being able to connect to our servers. Have you tried renaming the files, as outlined in the third thread you linked? Also, what browser are you using when you download the installers from our site?

  • Hi Mike,
    I've responded to your email at least twice, including this afternoon. Have you checked your spam folder?
    As of right now, I have only received 1 email from you. It was the one you sent yesterday regarding whether or not I had a firewall turned on, or anti virus programs (I don't). My spam folder doesn't have any emails from you either. I even added [email][/email] to my email address book.
    That's typically caused by our launcher not being able to connect to our servers. Have you tried renaming the files, as outlined in the third thread you linked?
    Yes I have, I typed it in by hand, but the file name was accurate when I first downloaded it, so I don't think that that is the issue. I even tried renaming it to the specific episode name (i.e. BackToTheFuture101 to It's About Time).
    Also, what browser are you using when you download the installers from our site?
    I have been using Safari, but just started trying it out with Firefox. So far I've downloaded the first episode of Strong Bad and Hector on Firefox, but the problem persists.

    Thanks for getting back to me. I've already spent somewhere between 5 and 7 hours tinkering and trying different ways of getting these games to run. I hope we can figure this out.

  • I still can't play the games from the "Almost Everything Pack".

    On the bright side, I downloaded The Walking Dead from the website and it worked right away. No problems what so ever. It's a little weird, though, because I was never prompted to login to my Telltale account, or authorize the game in any way.

    Still in desperate need of answers, I really wanna play my other games! Please get back to me!
  • I'm running your issue past our QA guys here. I appreciate your patience, and apologize for the frustration.
  • Thanks Mike, I really appreciate it!
  • Since my last post on this thread, I didn't receive any messages, email or forum post, from Telltale, until today. This is the message I received via email today:
    Hello there Tim,

    My apologies for the delayed response. Here are the minimum specs needed to play The Walking Dead:

    OS: Snow Leopard (10.6.X)
    Processor: 2.3 Ghz Intel
    Memory: 4 GB RAM
    Hard Disk Space: 2 GB Space Free
    Video Card: 512 MB NVidia or ATI graphics card
    Additional: Not recommended for Intel integrated graphics or Mac Minis or early-generation MacBooks

    It looks as though your laptop does not meet those requirements though. Please be sure to check the other system requirements needed to play the other games, as some require more space on the graphics card, while others do not.

    This was my reply:

    That answer is patently untrue. I have successfully been able to play The Walking Dead on my computer without issue. I have been unable to play the rest of the games that come with the "Almost Everything Pack" (Sam & Max Season 2 & 3, Back to the Future, Jurassic Park, etc). Given that I can play The Walking Dead just fine, this is clearly not an issue with my system specs.

    As I've stated before, the problem I have is that the Telltale login screen for these games doesn't load properly (the icons are blank, and the text fields don't accept any input), thus making it impossible to authorize and play these games. Based on the Telltale forum posts I've seen: this problem is not limited to me, it has existed for some time, and has not been addressed by your company. Here are a few of those forum posts:

    I have been incredibly patient with you guys, because I really want to support your games. The only reason I haven't contacted your offices by telephone is because I was given the impression that this problem was being worked on, and that some kind of fix (or at least a reason for why this happens) would be found. Your email leads me to believe that the actual issue I am having hasn't been looked into at all.

    I have tried every course of action I can think of to get help from you guys, yet I haven't even been given an accurate reason for my problem, let alone a fix for it. I don't know what you expect me to do. What would you do if you were in my situation?

    Please respond soon,

    The issue I'm having has still not been addressed.
This discussion has been closed.