User Avatar Image

Sam and Max: Culture Shock demo crash on startup

posted by justjackman on - last edited - Viewed by 619 users
Hi, when I run the demo, it gets to the 'Telltale Games' title screen then my pc crashes with no error message, the screen just goes into standby mode and I have to restart it.

My pc specs are: AMD 64 3400+, 512mb RAM, Nvidia 6800LE with driver v93.71, Nforce Audio with driver 4.62.

I intend to buy the season after if I can get the demo working, the original Sam and Max rocked when I was a kid... I've tried a few things suggested on the forum, such as turning off the sound hardware acceleration in DirectX and changing to an older Nvidia driver without any success.

Any suggestions would be much appreciated, cheers, Chris.
6 Comments - Linear Discussion: Classic Style
  • hi!
    i just bought s&m episode I (shouldn't have done it!) and get a complete crash when trying to start it (blue screen for a part of a second and then reboot) [see thread in support forum i started!]. if you have had any success i would be glad to know how you did it!
    until then i would advise you not to buy the game, because it may be a waste of money.
  • Dude u might wanna check out this post, I noticed it when I was looking for an answer and its specifically for users with geforce 440 go chips.

    http://www.telltalegames.com/forums/showthread.php?t=1205&highlight=nvidia

    In that thread, near the bottom of the first page there is a link given by 'mfavre' for new drivers:

    "Just get the driver from http://www.ngohq.com/home.php?page=F...me &dwn_id=21"

    That might help you...
  • That's a good tip there, Tapalai. Go check it out. :)
  • Does anyone know if the Nvidia 6800LE has cause any issuses with sam and max?
  • I don't know of any specific problems with this card (actually IIRC our web developer Doug has the same card at home and is using the same drivers as you). But coincidentally I'm working with someone right now who has the same card and is also getting a crash at the beginning of Culture Shock. Maybe the problem is a combination of the card and something else on the machine?

    Could you try one of the later episodes and see if the same problem happens? Try episode 4, 5, or 6, since those were all build with the most recent version of the activation software (episodes 1-3 use an earlier version that could be contributing to this problem).
  • Hi Emily, thanks for your reply, you rock! I tried episode 4 and the same thing happened. What should I do next? I cant think what else I can tell you to help
This discussion has been closed.