Help! Loading?

I bought the Law & Order game when it first came out. I am running it on a Mac. When I would play the game I was able to download the episodes, play through, etc.

I recently went back to the game to play through some of the episodes again (and finish my save game on the last case). However, when I run the program, it'll start up and then the "Checking Episode States" window will pop up like it did before. However, when it pops up, it just sits there seemingly doing nothing and because you can't click on anything until that window goes away, I'm basically locked out of the game. I've had to force quit (the Mac version of Ctrl + Alt+ Delete) the program in order to get out of it. I've tried reinstalling, restarting my computer and even redownloading the installer and reinstalling the program.

Anyone else have this problem or maybe a solution? I also don't know if this has anything to do with it or if it was like this before, but I bought The Walking Dead game and have Stream on my computer. Any help would be appreciated. It s a great game and I'd like to be able to play it again.


  • edited May 2012
    I have the same problem on my PC. There is a thread over on the support section with people having the same issue. Hopefully Telltale realizes that this is not an isolated issue and have a solution for it soon.
Sign in to comment in this discussion.