User Avatar Image

Walking Dead: Episode 2 doesn't work (mac)

posted by iSexualManChocolate on - last edited - Viewed by 394 users
Hey, so I bought the season pre-order and got episode 1 just fine.
But it doesn't let me play episode 2... I get this black screen that just stays like that. I have the episode installed and everything but it doesn't work.
Could you guys help me out, because this looks like a big waste of money right now...
:mad:
2 Comments - Linear Discussion: Classic Style
  • Did you buy the Steam version or the version directly from the Telltale site?
    Most Mac users here aren't even able to install episode 2, let alone play it.
    I haven't tried the Steam version myself, but it seems most Mac users aren't able to start episode 2.
    There are already a couple of threads about these subjects, check 'em out:

    http://www.telltalegames.com/forums/showthread.php?t=30725
    http://www.telltalegames.com/forums/showthread.php?t=31093
    http://www.telltalegames.com/forums/showthread.php?t=30804

    etc....

    Good luck. I'm trying to stay away from spoilers, because I haven't been able to play episode 2 either. It seems we're gonna have to wait some more :(
  • Hi there,

    I had the same problem (steam too), and tried re-installing, changing options, deleting my saves and so on, but the only thing which actually worked was to back up my OS to Snow Leopard. I was on Lion and only episode 1 worked, but after a disk formatting that i had planned to do since a while, the problem was fixed.

    I guess this is an extrem solution, but i bet the game is stable on Snow Leopard and not on Lion (for the moment ?).

    Hope it could help. Sorry for my bad english and i wish you courage, this game is great despite those incidents. Cheers !
This discussion has been closed.