Telltale Autumn Sale

Help! Broken game!!

edited January 2013 in Jurassic Park
I'm hoping someone can help me.

I've just bought this game, and after downloading it and installing it, when I go to play it, it opens up the loading screen with the Logo, and then just keeps saying "Loading....". I thought maybe it simply takes a while to load - but 40minutes?! I deleted it, then reinstalled it, and got exactly the same thing. It simply won't go past the loading screen!

I have a Gaming computer, fully kitted for this type of game. I've played Telltales Back to the Future Series, Hector and Walking Dead on this computer, without any problems, so highly doubt it's something to do with my computer. I'm now downloading it again just to be sure, but if that doesn't work, I'm at a loss! I'm a dedicated Telltale customer and have never had a problem before, but this is very frustrating.

Can anyone help? Anyone!?

Thanks in Advance,

Ryan
darkslay109b@tesco.net

Comments

  • edited August 2012
    Well that is a problem! I have no idea what the problem is. What operating system are you using?
  • edited January 2013
    Having problems downloading the free Jurassic Park Episode 1.Can someone please tell me step by step what I am suppose to do?
  • edited January 2013
    I would like to help you with that joshluke but I don' have the info to help you. Sorry! The weird thing is that the main person that has this problem hasn't posted in a while. Weird! Didn't even answer my question.

    Can any of the forum moderator help joshluke, i'm stumped on his question.
  • edited January 2013
    What operating system are you using and please check the directx version if you are on windows
Sign in to comment in this discussion.