User Avatar Image

Won't detect my DVD

posted by mongo on - last edited - Viewed by 1.9K users
I purchased Season one a few months ago, but because of things going on, I took a break from gaming. I moved out of where I was living and had broadband. I'm now stuck on dialup and more or less game-less.

But then the Season one DVD showed up and I was overjoyed, because I'd forgotten I'd even ordered it. I installed it and jumped back to where I was in the story, Episode 4. But it won't detect the disc!

No matter what I try, it just doesn't read the DVD. I get a popup error telling me the disc is not inserted and it absolutely is. It's driving me up the wall. I've tried to search the forum but it's painfully slow on dialup and haven't found anything yet. Does anyone have any ideas?
20 Comments - Linear Discussion: Classic Style
  • Does the disc work if you put it into a regular DVD player?

    Also, this is probably a dumb question, but your computer does have a DVD-ROM drive, right?
  • Yes. I can watch all the bonus content, although the videos do stutter a bit.

    It installed the games fine, and I actually played some of episode 3 from this install, because I wanted to be refreshed. It was having problems with that one too, it would work half the time. But now I literally can't play any of them at all.

    EDIT: And yes, it is a dvd drive. :p

    EDIT 2: If there's any doubt about the validity of my copy here ya go!

    image
  • UPDATE: Seem to have fixed the problem. If anyone has this problem, what I did is simple.

    I went into device manager, and opened the settings for IDE ATA/ATAPI controllers, and I changed the transfer mode. Works for now, at least.
  • I'm glad you got it working, and thanks for telling us what you did! Someone wrote in to support with the exact same problem today, so I will suggest this and see if it fixes it for that person.
  • User Avatar Image
    jmm
    So what it is now? PIO, DMA?
  • This solution won't help many people since it involves using a separate computer running linux.

    I bought the retail package and the game disk would show no files. The bonus disk, however, did work.

    I tried changing my devices over to PIO from DMA and that did not work. I am using a Plextor PX-740A drive.

    I took the disk over to my linux machine and behold, there was the data. I used the linux box to copy the disk onto a CD-R. I took the CD-R back to the computer and it installed like a champ.

    Hopefully this will help someone out there. This is the first time I have ever had a commercial disk do this. Very odd.
  • Brimrand;37835 said:
    I am using a Plextor PX-740A drive.
    I have the exact same drive as this, and I have the exact same problem. No files show up.

    I put the CD in another Windows PC and mapped the drive, and the installation just completed.

    Hopefully the game plays. If not, I'll be right back. If it works, I'm playing S&M, probably at this very moment. :D
  • Nope, no good. Can't start the game without the CD in the drive. Ripping the ISO now on my Linux box like Brimrand did. Hopefully that'll do it.
  • There have been a few reports of apparently blank discs coming with the Adventure Company version. (Note that I don't think this is the exact same problem that was originally described in this thread with our DVD, because the symptoms aren't quite the same -- an error saying the disc isn't inserted vs. a disc that appears to be blank.) TAC is looking into the problem right now. I will send them a link to this thread.
  • Alright, well, ripping the CD on Linux is not an option. There's the copy protection in the way of that. I wonder how Brimrand made out seeing that you can't start an episode without the CD in the drive?

    Anyway, what I had to do was install the game through the other PC's remotely mapped drive. But you can't start the game without the CD in a real drive on your PC. I happen to have an old external USB CD-drive that I plugged in, and was able to start the game now.

    Something you support guys should note here. The CD in the external drive is misbehaving as well. I can see files, but Autorun didn't happen. So it really was necessary for me to install the game through another PC because I get a "Corruption" error during installation otherwise. I think it's something about the PC itself, and not the drives.

    Anyway I can play, so I'm off.

    I fear you guys are about to get hit with a lot of these problems real soon now. Sorry about that!
This discussion has been closed.