[TWD] Saves vanished, reappeared, but now "Episode 3 is coming out!"

Right, the update completely lost me my save games as it did lots of other people. The game wouldnt even start but I fixed that by putting the game into compatibility mode, only to find upon launch that all my save games were gone. After a lot of tinkering around I managed to get my episode 2 save file back by copying all my save files, deleting them, then pasting them back into the folder. I then started episode 2 with random choices for episode 1, but it ported be back to the final scene of episode 2 with my save-game choices intact.

However, my joy of finally getting my saves back was tempered somewhat. After the credits had rolled I tried to continue and start episode 3, however, when I open my save it takes me to the episode list and episode 3 cannot be accessed, it just says "coming soon" just as it did before the update.

Can anyone help? I was so looking forward to playing episode 3, all this nonsense with the game not working, then the inaccessability of my save files THEN this bug is making me very frustrated.


SCRATCH THAT, upon verifying game cache and restarting the game, now my saves have vanished again. Still got the files, can ANYONE help me retrieve my save? I simply do not have the patience to play the entire game through again.


  • edited August 2012
    Similar problem reporting in. More specific details to follow, to help TTG sort it out:

    After the Ep. 2 credits rolled it told me Episode 3 was "Coming Soon."

    Exiting and restarting the game, the episode status was confirmed "Installed." The save game said "Episode 1" but upon playing it, I was taken to the final scene of Episode 2 (all choices intact.) After the credits rolled, again, "Coming Soon."

    Copied the save game to Slot 2 upon restarting. Both read "Episode 1" but both take me to the final scene of Episode 2. After credits, "Coming Soon" and BOTH save slots now read "Episode 2" and the last time I autosaved. All MAJOR choices appear intact but there's now one minor change. Whereas before, the camcorder saved my response to Clementine about her hat, "Sure." Now it acts as if I didn't respond at all and Clementine asks about her hat, then says "Lee..." in an annoyed tone.

    I tried exiting and restarting Steam, no difference. I tried validating the game's cache files, also no difference.

    Please help.
  • edited August 2012
    Telltale seem to be ignoring the issue thus far, guess they are too busy on pumping out another out episode that'll no doubt wipe our saves again xP
This discussion has been closed.