User Avatar Image

Walking Dead iOS Ep2 downloads, doesn't install

posted by nalex66 on - last edited - Viewed by 11.5K users
I'm trying to install Ep2 of Walking Dead on my iPad 2. I've had several attempts to download that fail partway through with the "Connection lost" message and force me to start over.

More troublesome, I've reached 100% downloaded three times now, and after it hits 100%, I get the same error message (Connection lost while downloading data. Please ensure that you have a working internet connection and re-attempt the download.) and the episode doesn't install, and the entire download is lost.

I've tried resetting my device with a full power-down, but I still get the same error after fully downloading the episode. Is there anything else I can try besides uninstalling the game and losing my episode 1 save?

I've noticed that in Settings/General/Usage on my iPad, the Documents and Data for the game is around 508 MB, while the game itself is 360 MB. I'm assuming this is largely the downloaded data, as I wouldn't expect my single saved game to be larger than the game itself. This data size varies after each failed download attempt. Is there a way to delete the data without uninstalling the game?

I'm currently trying on my iPhone 4S to see if I get the same issue. I've installed the game, and am currently downloading episode 2 (very slowly), and so far the download has failed twice. after a fresh install of the game, the Doc and Data size was 8 KB. Now, after failing at 11% downloaded, I have 71.6 MB of data associated with the game.

This is getting very frustrating, and I'm worried I'm filling up my devices with garbage data that won't go away.

For a company that deals primarily in downloadable games, I'm shocked at how poorly this game handles its downloads. I don't think I've used another product that had to restart rather than resume a download since the 90's!

Update: 3rd failed download on iPhone, now showing 32 MB of data for the game. At least the download seems to be overwriting itself rather than accumulating more and more data.
30 Comments - Linear Discussion: Classic Style
  • Can't download either, get same message.

    No resume for downloads really!?!? Is this Internet explorer 6 or something!!!

    iPad 3 and rock solid 50mb broadband but still failing :confused:
  • My copy is doing the same thing except its charged me for the pack and then it charged me again for the first episode. I saw the charges on my bank account today.
    If I try to download it keeps saying connection lost and doesn't pass 0% download. It got to 2% download on one instance and then stopped.

    server overload maybe. But can a op please refund at least the second charge. I can wait for the other problem to be fixed for a bit.
  • Same, it's frustrating as I was planning on downloading it tonight and playing it tomorrow (ep 1 and 2) but I guess that's not happening. If this keeps up for a few more days I'm going to request a refund on the whole thing.
  • Actually, now that I think about it, would it be possible to just request a refund for the whole thing? This whole debacle has kinda annoyed me to the point where I don't think it's actually worth the cash. I'd rather spend $20 on something worthwhile and working.
  • User Avatar Image
    MattP Telltale Staff
    We are aware of this issue, and currently investigating a potential solution. I do apologize for the inconvenience.
  • Hi,

    I have a similar situation, but with Ep3 in PC.
    "Connection lost" message every time I try to dowload the episode :S

    I hope this can be solved somehow.
  • User Avatar Image
    MattP Telltale Staff
    Hi maarnas,

    Please restart your PC, then make sure you are logged in to your telltale account and have a strong internet connection before attempting the download again.
  • I've been trying to download episode 2 for the past 3 days now! I want to play it so bad but every singe time i get the message saying the connection failed and i should check my internet connection and re attempt. I have full internet connection, i'm logged in and I've constantly tried restarting the computer but NOTHING has worked! I even went so far as deleting my progress from episode 1. The downloading gets to 58% then the message pops up. Then when i re download it goes back 10 notches. So it's basically going in a never ending circle. I would really love to know how to fix this because i paid my money on it and i would like to actually play the game!
  • 9-22-12, I've been getting the same error as these guys, trying to download the PC version. I have seen the download complete to 100%. and still i get this stupid message. Finished the download 2 times already and only get an internet explorer link to show for it. The link does absolutely nothing as well!

    Im using all my internet to try and get this at a 3 Hr 15min wait per download.
  • User Avatar Image
    MattP Telltale Staff
    Hi ushkadush,

    The issue you are experiencing does not appear to be related to the original topic. Can you please provide more information on what you are experiencing? Are you trying to download the installation file or in the game trying to download an episode? You mention an internet explorer link, can you provide more details on this? Thank you.
This discussion has been closed.