User Avatar Image

Walking Dead iOS Ep2 downloads, doesn't install

posted by nalex66 on - last edited - Viewed by 11.4K users
I'm trying to install Ep2 of Walking Dead on my iPad 2. I've had several attempts to download that fail partway through with the "Connection lost" message and force me to start over.

More troublesome, I've reached 100% downloaded three times now, and after it hits 100%, I get the same error message (Connection lost while downloading data. Please ensure that you have a working internet connection and re-attempt the download.) and the episode doesn't install, and the entire download is lost.

I've tried resetting my device with a full power-down, but I still get the same error after fully downloading the episode. Is there anything else I can try besides uninstalling the game and losing my episode 1 save?

I've noticed that in Settings/General/Usage on my iPad, the Documents and Data for the game is around 508 MB, while the game itself is 360 MB. I'm assuming this is largely the downloaded data, as I wouldn't expect my single saved game to be larger than the game itself. This data size varies after each failed download attempt. Is there a way to delete the data without uninstalling the game?

I'm currently trying on my iPhone 4S to see if I get the same issue. I've installed the game, and am currently downloading episode 2 (very slowly), and so far the download has failed twice. after a fresh install of the game, the Doc and Data size was 8 KB. Now, after failing at 11% downloaded, I have 71.6 MB of data associated with the game.

This is getting very frustrating, and I'm worried I'm filling up my devices with garbage data that won't go away.

For a company that deals primarily in downloadable games, I'm shocked at how poorly this game handles its downloads. I don't think I've used another product that had to restart rather than resume a download since the 90's!

Update: 3rd failed download on iPhone, now showing 32 MB of data for the game. At least the download seems to be overwriting itself rather than accumulating more and more data.
30 Comments - Linear Discussion: Classic Style
  • "Connection lost while....." I've restarted my computer several times as well as checking my internet. I keep getting this message and it is very frustrating. Please help.
  • User Avatar Image
    MattP Telltale Staff
    I do apologize for this problem. We are aware that a small number of players are experiencing this issue, and we are currently investigating a solution. Please ensure you have a strong internet connection and are logged into your Telltale account before attempting the download again. Also, you can try connecting to another network.
  • I have te same problem (on PC)

    I started downloading Episode 2, I had 2% and I decided to switch off my computer (I had no time to download).
    Next day I wanted start again and I got info


    internet connection is OK. What to do now?
  • I can't download Ep 3 for iPad. It downloads just fine on iPhone. When I try on iPad, the "purchasing" icon just keeps spinning.

    I deleted the game and re-installed it, but that did nothing but erase my purchase of episode 2! When I try to restore my game, again, the "restoring purchase" icon keeps spinning and spinning.... help!
  • User Avatar Image
    MattP Telltale Staff
    Try shutting down the application and refreshing your wifi connection. Also make sure you are logged into your iTunes account before launching the application. If you are still not getting a good connection, try connecting to another available network.
  • Same issue for me, but I can't get past 0.00% after clicking GET. Everything else is connected and downloads fine. iPad downloads other apps and music etc no problem.

    I have restarted everything several times.

    Please let me know how to fix this so I can use the money I gave you months ago.
  • I had the same problem being stuck at 0 percent on an iPad 3 when downloading episode 2.

    Closing the app (so it isnt even running in the background) and restarting it fixed the problem.
  • Hi Mattp

    I'm having the original posters issue. I have an iPhone 4s with solid wifi connection. I have purchased all episodes but have not been able to successfully download any of them. I have tried at least a dozen times, different episodes, while plugged in with no avail. My connection is not the issue, I have full wifi strength and never had any issues with the connection on any of the devices that use the wifi.

    It has been 4 months since the original post, do you have any resolution yet? I loved the first episode and purchased all episodes as soon as I could. Now I'm not able to play the content I've paid for. How can I fix this situation?
  • User Avatar Image
    MattP Telltale Staff
    Try shutting down the application and then turn off your device. Wait a few minutes for the cache to clear, then restart your device. Also make sure you are logged into your iTunes account before launching the application and attempting the download again. If you are still not getting a good connection, try refreshing your wifi connection or connecting to another available network.
  • I have the same problem as maarnas but on the ipod, 0.00% and nothing more.
    My ipod is only on 4.3.3 (can't update) but that is all I could come up with. :(
    I've looked all over the "Interwebs (reference) and this is the only usefull site.
This discussion has been closed.