TWD: Ep. 3 on Steam wont start.

After the episode 3 was released I am unable to start the game. When I run the EXE file from its root directory or just click the steam shortcut the the mouse icon changes to show the process beeing initiated and it does show up in process list for a short while but then dissapears and nothing else happens. No error message no game window starts. Nothing.

Changing the compatibility mode of the exe file in the root directory allows me to start the game but then all my save games are gone.

Im running windows 7 ultimat 64 bit version.

I know alot of people have this issue, but I am wondering if anybody has any official info on this ? All anybody have heard are rumors.


  • edited September 2012
    I am haveing the issue also..iv verified the game cache and its 100% i dont know what else to do?
  • edited September 2012
    Almost the same here.
    I can start the game, but in the Episode menu it's reads "not installed", but it is.

    Running on Xp3 with Dirext X 9.0C
    First two episodes worked well.
    Comp.mode doesn't fix this.

    Hopes this helps in solving the issue.
    Like the game very much!
  • edited September 2012
    Don't what happened. But it works now.
    Maybe a restart after checking my directx settings and cache as mentioned at http://https://support.steampowered....8001-ESBN-3102
This discussion has been closed.