User Avatar Image

TWD: Episode 4 won't download!!

posted by chaz99 on - last edited - Viewed by 7K users
I keep getting the "connection lost" message. There is NOTHING WRONG WITH MY INTERNET CONNECTION!!

Fix this, TT!!
80 Comments - Linear Discussion: Classic Style
  • TT FIX THIS !!!
    Goddamn that's no way to treat your customers :mad:

    I'm thinking about downloading it illegal that way i'm sure it works !
  • still cant download episode 4,some crap about internet connection.I just wasted my money
  • I got the same problems. Have been trying to download episode 4, but keep getting the no internet connection message. I've been getting the same with alle the other episodes, but at least the would dowload 60-80%, and then jump back 20 or so %, but then quickly download. Then i started a new save file, just to play The game again, and played to i got to the end of Hershels farm segment of Episode 1. When i played that save file again. The game just started over from The Beginning. And now i the game say's i don't have an account for the game.

    I only bought the game about a week ago, so i haven't had the problems with delays and such, and i really like the game. But this is really getting on my nerves. Problems are fair enough, but that they tell us nothing about what is going on, is unacceptable.
  • Still not working tonight
  • I am also unable to download Episode 4 due to the connection error issue. Very disappointed in the lack of feedback from Telltale on the problem.
  • just tried and could finally download Ep 4, maybe TT fixed the bug.
  • Doesn't work here either. Telltale, what are you doing?
  • I'm sorry for the frustration many of you are feeling because of this issue. I've been playing TT games for a little while now and I can tell you that this is just par for the course with these guys.

    After a while you just get used to it. It sucks because they're games are so enjoyable. I know everytime that something, somewhere is going to go wrong and I'll to do some weirdo download from somewhere else, edit my registry, hexedit a save file or something equally scary - just to play the game.

    The funny thing is, complaining about it in the forums to them, is the epitome of uselessness. So, I'm going back to my beer and attempting again to download the files manually.
  • i played the game on Xbox and when lee got bit i wanted to change it so i went to the dashboard and it reset the hole campaign and i don't what to do it again and i tried going to my storage and move it and see if i could do anything there and i tried deleting the episode 1 that it pot me back to nothing worked so i em on here to ask the people how made the game to see if they could do anything about my situation so i would be glad if that could happen because that completely rewind the game for me and i liked the game but this has rewind it for me unless confused there is a way to fix this if anyone wants to get back to me message me on Xbox for Repper6000.
  • There is another post floating around that claims to fix the problem. The subject is "TWD: Inofficial workaround for instant "connection lost" issues" and the fix uses a couple of json files. When I download the zip file containing them, I get 2 empty files. :-/

    Maybe it works, maybe it doesn't. I can't try it.

    I did try debugging the download using Network Monitor:

    Client says Hello to the Server,
    Server says Hello to Client,
    Client initiates a key exchange,
    Server issues a Cipher Change Spec,
    Client sends SSL application data,
    Server sends SSL application data,
    the Server throws an Encrypted Alert for what looks like a Decryption Failure (HEX 15),
    the Client throws an Encrypted Alert,
    the TLS connection is terminated and frustration ensues.

    The Decryption Failure Alert is a BAD thing: "Decryption of a TLSCiphertext record is decrypted in an invalid way: either it was not an even multiple of the block length or its padding values, when checked, were not correct. This message is always fatal."

    What's the deal? Bad keys? Broken encryption/decryption algorithms? Incompatibility with the version of TLS on the Client side? (This is using a Windows XP SP3 machine.)

    Come on TellTale... a little help here???
This discussion has been closed.