User Avatar Image

FIX: Save Game Problems

posted by DarkSoroush on - last edited - Viewed by 34.5K users
Hi there,

At last I found the problem of the game. (Once again, shame telltale! I was one of your fans)

The problem of game is position of stat file (as lot of people mentioned before in different threads.) Not just changing in place of stat file but also having two different place to save stats at same time.

Lot of people found that there is a "prefs.prop" in "Pack\default" directory at game installation directory. Some others found one in "steamapps". Some people found that there is one in "Documents\Telltale Games\The Walking Dead" (Where it should be actually) and some even found same folder and files in "Public Documents\Telltale Games\The Walking Dead".

I am going to speak about my version of game now (Steam Version Updated with all four episodes),

It seems that in my computer, game use two "prefs.prop" file. One on "Pack\default" and one in "Documents\Telltale Games\The Walking Dead" next to save games.
We must know that the game don't use save games as a way to find out where we are in game. Saving slots and even stats are in "prefs.prop" not in save-games.
So all of our problems such as not knowing save games and not moving decisions between episodes,etc are problems of "prefs.prop" file, not save games.

The problem of game is that it save and read "prefs.prop" in different locations (In my case two place. And i think it must be same for most of peoples). So when it saves "prefs.prop" to one place and later want to read it from another place it read older one. or even worse, if cant read other one because there isn't one (In some particular situations it will make game to show black screen. Otherwise it will create missing file or try other one.).

Here is what game do:
"Documents\Telltale Games\The Walking Dead"
Update when: Saving game (checkpoints)
Read when: Moving decisions to new episode
In other word: Read and write by in-game code

Update when: Opening game menu + Ending an episode + Saving options + Closing game
Read when: by menu, from when you open your game to when want to select your save slot and so on until opening of actual game
In other word: Read and write by game menu
If not available: If file was not already there, then it will use "Documents\Telltale Games\The Walking Dead" one. But when game create it for first time then game will use it as first option. This is why we don't have any problem until end of episode one.
What to do in different situations:
According to above description we can guess what to do when a problem occurred. Check below:

S1: No save slot shown (all empty).
A: It happen when you update your game. It seems that it is because of removing "prefs.prop" file from "Pack\default" by setup process. So what you need to do is to copy "prefs.prop" from "Documents\Telltale Games\The Walking Dead" to "Pack\default".

S2: Save slot seems outdated but works.
A: It is outdated because your process in game saved in "Documents\Telltale Games\The Walking Dead" version of "prefs.prop" but menu read it from "Pack\default" (which is saved at ending of your last episode), and of course it works even with that situation because when you click continue it will try to read "prefs.prop" from "Documents\Telltale Games\The Walking Dead". So what you should to do is to copy "prefs.prop" from "Documents\Telltale Games\The Walking Dead" to "Pack\default" folder.

S3: I started new episode before closing game but now it is not available in menu and i cant select to continue!!
A: situation is same as above problem but in other order. You must do same thing. Copy "prefs.prop" from "Documents\Telltale Games\The Walking Dead" to "Pack\default" folder.

S4: Ok I am done with this episode but my decisions wont move to new episode!
A: This is different situation. As i said when you end an episode it will update "prefs.prop" file in "Pack\default", but when it want to read your decisions it read "prefs.prop" file in "Documents\Telltale Games\The Walking Dead". So solution is to copy "prefs.prop" from "Pack\default" to "Documents\Telltale Games\The Walking Dead".

In other word:
Keep "prefs.prop" files sync. When you see a problem with your save-games, try to check and see if they are all sync. Always copy BIGGER file to other locations. Latest file sometimes has more recent modification date and always must be slightly larger in size too. Just copy and replace smaller versions of "prefs.prop".

Not always this folders:
I know that some times stat file may go to "Public Documents" or "steamapps" folder. This is not a big deal. Just sync them no matter where they are. Always replace old ones with new one and you are done.

All information posted here is correct for MAC too but folders are diffrent. You must check this two folder: (Replace YOURNAME with your username.)

/Users/YOURNAME/Library/Application Support/Telltale Games/TheWalkingDead/prefs.prop

/Users/YOURNAME/Library/Application Support/Steam/SteamApps/common/the walking dead/

If you use NTFS as filesystem format for your hard partitions then you can run this line of commends in CMD:

Note: If you didn't installed steam in same drive as windows you must change "%PROGRAMFILES%" to "YOURSTEAMDRIVE:\Program Files" and "%PROGRAMFILES(x86)%" to "YOURSTEAMDRIVE:\Program Files (x86)" in below commends.
Note 2: You better take a backup from your save-games at Public Documents and "prefs.prop" at both steamapps folder and Pack\default folder.
Note 3: This commends will not solve your old problems (they may solve but there is no guarantee. Use it when you solved all your problems and everything is correct. Then it can prevent any other problem.) But if you use them correctly they sure prevent any problem in future.

1. FIX your game using older parts. DONT USE THIS PART IF YOU HAVE ANY PROBLEM YET.
2. Go to "%PROGRAMFILES%\Steam\steamapps\common\the walking dead\Pack\default" and remove "prefs.prop" if any.
3. Go to "%PROGRAMFILES%\Steam\steamapps" and remove "prefs.prop" if any.
4. Go to "%public%\Documents" and create "Telltale Games" directory if there wasn't any. If it was there, Then empty it. (Move contents to someplace safe)
4. Go to "%UserProfile%\Documents\Telltale Games\" and move "GameData" to someplace safe if there was any.
5. Now press WinKey+R and type CMD.
6. Use below commends and type them in CMD window.

Win Vista/7/8 32 Bit:
mklink "%PROGRAMFILES%\Steam\steamapps\common\the walking dead\Pack\default\prefs.prop" "%UserProfile%\Documents\Telltale Games\The Walking Dead\prefs.prop"

mklink "%PROGRAMFILES%\Steam\steamapps\prefs.prop" "%UserProfile%\Documents\Telltale Games\The Walking Dead\prefs.prop"

mklink /D "%public%\Documents\Telltale Games\the walking dead" "%UserProfile%\Documents\Telltale Games\The Walking Dead"

mklink /D "%public%\Documents\Telltale Games\GameData" "%UserProfile%\Documents\Telltale Games\The Walking Dead"

mklink /D "%UserProfile%\Documents\Telltale Games\GameData" "%UserProfile%\Documents\Telltale Games\The Walking Dead"
Win Vista/7/8 64 Bit:
mklink "%PROGRAMFILES(X86)%\Steam\steamapps\common\the walking dead\Pack\default\prefs.prop" "%UserProfile%\Documents\Telltale Games\The Walking Dead\prefs.prop"

mklink "%PROGRAMFILES(X86)%\Steam\steamapps\prefs.prop" "%UserProfile%\Documents\Telltale Games\The Walking Dead\prefs.prop"

mklink /D "%public%\Documents\Telltale Games\the walking dead" "%UserProfile%\Documents\Telltale Games\The Walking Dead"

mklink /D "%public%\Documents\Telltale Games\GameData" "%UserProfile%\Documents\Telltale Games\The Walking Dead"

mklink /D "%UserProfile%\Documents\Telltale Games\GameData" "%UserProfile%\Documents\Telltale Games\The Walking Dead"
This will solve your problem. You don't need to do any thing. Just play and Windows will force game to save pref.prop in same place always.

Tell me about any miss-information or new investigation results. :D
Hope this one solve your saving problems.

P.S: It seems that "corrupt file", "black screen" and other problems are not related to location of "prefs.prop" but to validation (and integrity) of data saved in it and save-games. I don't know how to fix them but always try to keep a copy from your save game via ingame menu (Play on slot 1 for example and copy to slot 2 after finishing an episode each time). I can confirm that a problem in one slot wont effect other slots until whole "prefs.prop" become corrupt which is unlikely.

P.S2: You better keep a backup of "prefs.prop" every time you change it.
65 Comments - Linear Discussion: Classic Style
  • Had a problem with the wrong decisions carrying over from Ep.1 to Ep.2. This solution worked for me.
  • I have a slimier problem.

    I was able to play episode 5 fine, but when my brother started playing on a new file he got to the end of episode 1, and couldn't carry his decisions over.

    I seem to have 1 prefs.prop file inside my documents folder, but not in the game folder itself, and copping it doesn't seem to work.

    Could this be caused by having multiple save files?

    Edit: never mind, turned out the decisions were remembered, but for some reason the game didn't think it was. Just continuing worked fine
  • EDIT: Never mind.
  • I just had one of the problems you lined out while moving from Win7 to Win8. All I did was copy the save game files from My Documents and when I loaded up the game it showed that I had a save but it wasn't loading any of my save data. I copied over the prefs.prop file from the My Doc files into my Steam directory and not only did it work but I can now see my stats from the last two episodes that didn't actually have questions associated with them.

    Of course your fix worked but before then I couldn't even get the game to start on Win8. Apparently you need a .dll placed into the install directory if you're using a controller. worked to fix that (or pointed me in the right direction).

    This game is a total mess. Luckily it's good enough to bother but Telltale really needs to clean up their act on the PC.
  • i just bought the game from steam finished the 1st one watched the credits i go the my save slot press play now....
    on the 1st episode it says continue
    so i press continue it then takes me to the second episode where it says play i click play and it says generate story decisions for skipped episodes i have not skipped any episodes so i press no so i got back to episode one it still says continue i click it it takes me to episode 2 and the same thing happens when i click play it asks me to generate decisions for skipped episodes is this meant to happen ?
    if its not i only have one pref file and thats in my documents/TellTale/TWD no idea what to do
  • This did not work for me. The Sizemore fix didn't work for me either.
  • This worked for me. Such a noob mistake on telltale's part. (sorry, it's true... you should have caught this in your first play test, and now that it's clear on the forums what the problem is, a fix needs to be put out ASAP.)

    I'm guessing in episode 4 or 5 somewhere you did a "fix" to store the saved data inside the proper folder but forgot to catch a few references in the code that still point to the old file.

    So... my problem and how it was fixed (for posterity)

    1. play game through end of episode 4, start ep5 for a few chapters.
    2. exit game (11-23-2012)
    3. load game up and saved game menu says it's from 10-20-2012.
    4. load saved game up and i'm still in chapter 4.

    1. Made backup of following directories:
    - D:\Games\Steam\steamapps\common\the walking dead\Pack\default
    - C:\Users\USERNAME\Documents\Telltale Games\The Walking Dead
    2. Overwrote C:\Users\USERNAME\Documents\Telltale Games\The Walking Dead\prefs.prop with D:\Games\Steam\steamapps\common\the walking dead\Pack\default\prefs.prop
    3. Load game
    4. menu properly shows saved game from 11-23-2012

    5. for good measure I deleted D:\Games\Steam\steamapps\common\the walking dead\Pack\default\prefs.prop to avoid confusion in the future about which file contains the real save information.
    6. loaded game up again and saved game is still correct one.

    Someone please sticky the OP's thread.

    My proposed solution for telltale based on what I think the problem is:

    1. Write some code to search the known directories that could have the prefs.prop file in it
    2. Find the one that is farthest in the game
    3. Copy it(overwrite) to the proper directory
    4. Delete any other versions.
  • iramiz;726747 said:
    Good FAQ, but I guess have no use for me now. I completed 4 episodes, and after today's update I found out that game see no saves. I mean - I was surprised that resolution changed, make it normal again, start the game and...
    Ok, I made savegame folder backup. Found this topic, copy pref-file to game/pack/default but still nothing. And I guess I know why. When I open game first time game changed pref file. And now pref-file have last change date is today (and very possible that this is "clean" file now). So, looks like I lost my saves:( No, there are 64 save files, but this didn't look useful now.
    Afraid, I didn't have desire to replay game again, at least for now. Burn out, I guess.
    I dunno, maybe there are some sort of savegame editor for TWD?
    Having a very similar issue. I lot all my previous save files due to a HD meltdown (I know, I know... back up my files. I do now). So, today I started a new playthrough and played the first 4 episodes... Zero issues. Ep.4 credits end, the game goes back to the main menu... I go to start Ep.5 and then the game crashes to a black screen... I wait and wait... nothing happens... I end up ctrl-alt-del'ing back to desktop. When I restart the game it goes to windowed mode, makes me reset the resolution... but now all my saves are gone!?!?

    I tried to follow your advice... BUT my pref.prop is in the right place, I think, C:\Users\______\Documents\Telltale Games\The Walking Dead, and nowhere else. It doesn't matter if I copy it to "game/pack/default"... nothing works!?

    This is a great game... and it's been issue free for me until today... but now I'm pretty f'n annoyed. WTF!?
  • So, I managed to resurrect one of my old saves using Sizemore's timestamp fix ONLY to discover there is an issue with Ep.5 accurately recognizing my choices, anyways... SO VERY DISAPPOINTED !
  • Ok, I don't have Episode 5 yet,

    But you can check how game works, Follow this post,

    Download Process Monitor

    Open it. Disable Registry, Network and Process Monitor from toolbar, let only File monitor active.
    Open Filter Menu (CTRL+L) and add this two filter:
    Process Name Begins With WalkingDead Include
    Path contains pref Include

    And click Ok. Open game and see what files game try to read from what locations. It will show you even if there is no file there.
This discussion has been closed.