User Avatar Image

Storage device lost.please help

posted by mac121 on - last edited - Viewed by 490 users
im getting really really get peeed off now.keep getting storage device lost after nearly every screen that loads. Is anyone else having the same problem? Does anyone know how to get past this?
I can't even finish the 1st episode at the moment.please I'm getting desperate to play this after paying for it or will prob just give up on it.
5 Comments - Linear Discussion: Classic Style
  • I've started to encounter this issue with episode 5,, when Lee is close to where he needs to be.

    Any solution to this problem. This thread was the first hit on Google.
  • same here no idea. cant finish the game here and getting no help from telltale
  • I decided to start a new game from scratch and moments after a reanimation in Episode 2 the same Storage Device Lost error popped up and I was kicked out of the game.

    The issues with this game seem to be getting worse with each episode released.

    Previously the only issue I had was the game losing the brightness setting. Then episode 4 wiped my progress and randomised choices on another occasion. Now episode 5 has introduced this "Save Device Lost" error.

    The story is fantastic in this game but it becomes harder and harder to recommend it to others with all these errors. I hope that they get them fixed for the physical release.
  • User Avatar Image
    MattP Telltale Staff
    Can you provide me with more information on your console? How old is the xbox and the hard drive you are using? Do you have a memory unit or flash drive connected as well? If so, which are you using to store your saves? Are any other devices plugged into the USB ports?
  • Forgive the double post but I think it is worth repeating.

    I can provide you with all the information I am able. Please forgive me for being remiss in doing so before.

    I have an Xbox 360 Elite bought in early 2008, according to Wikipedia that would make it an Opus motherboard. I am using the 120gb hard-drive that came with the console.

    I have run the game with a USB stick configured for 360 storage connected to the console (my friends bring their profiles to my house in this manner) and tried running it without any storage but the hard drive connected. The error occurs at the same points no matter if a USB is connected or not.

    My save is stored on the 120gb hard drive. In an attempt to problem solve I have moved my profile, the game and the save to a USB stick, removed the hard drive and attempted to play the game from there. The error occurs at the same point.

    The only other device that remains connected to the console is the Xbox 360 HD-DVD drive. I have however disconnected that from the console and tried to play the game but issue persists anyway.

    Note that another profile on my console has been able to play the game through to completion without this "Storage Device Lost" error.
This discussion has been closed.