User Avatar Image

Completed Episode 3. It vanished, then returned!

posted by cutrock on - last edited - Viewed by 233 users
This is very strange. I had completed Episode 3, so I downloaded Episode 4, and had a very hard time doing so. The site kept claiming that I was disconnected, but I know I had a solid internet connection. It took about three hours of attempts to finally get the episode downloaded.

Later, I went to play the new Episode 4, and noticed that Episode 3 was GONE! The game wanted me to download it again! It was listed as "Purchased" and ready for download. I didn't want to have to do this all over again, redownload and play again. I tried all kinds of reboots and even gave up and tried to download Episode 3 again, but the site wouldn't let me. It kept giving the same erroneous message that my internet was disconnected.

The next day, I decided to try again a few more times. Eventually, I turned off my Bluetooth to my iPad. Then I rebooted. Lo and behold, Episode 3 had returned, but I had lost about 75% of my game play! I also no longer have external only works through the headphones. Previously, the audio would play through my iPad speakers. Yes, I did troubleshoot it to make sure no "mute" settings were somehow enabled. My music still plays through the speakers just fine. It's some sort of game glitch. This is unsettling and unfortunate, but I guess I'll just replay it *with headphones* before I move on to Episode 4 so that my choices will properly affect my game play. I'm just documenting this incident for TellTale and other users to be aware of it...Maybe Telltale knows what the issue is???
2 Comments - Linear Discussion: Classic Style
  • User Avatar Image
    MattP Telltale Staff
    Thank you for notifying us. We are looking into this issue, but I do have a few questions. Do you have multiple iTunes accounts that you log into? Were you logged into the account you used to purchase the game when you started the game to find part of your save missing? Did you close down the game app before restarting your device?
  • Yes, I do have a second iTunes account, but I don't use it. I was logged into the iTunes account I used when I purchased the game. (I had written in previously about how I downloaded TWD from the wrong acct and wanted to know how to transfer it to my new acct. I ended up purchasing TWD again so I could re-download it via the correct account. I never change my account settings on my iPad.)

    Yes, I did close down the game before restarting my iPad, too.
This discussion has been closed.