Ep. 2 glitch, help, please.

I'm fairly early in the episode and trying to pick up where I left off. Every time I chose continue, it takes me to the 'Rewinding will delete any progress...' message. i get the Yes/No choice, but no actual way to choose either. When i hit select, the only real option, it freezes. This happened with my previous save point and a simple exit and re-enter of the game worked. But I've tried that 4 times now and it's definition of insanity time.

If it matters, I'm only using one save slot currently. Really frustrating as I don't want to start over at this point, especially with no confidence this won't happen again. I'd appreciate help.


  • MattPMattP ModeratorFormer Telltale Staff
    edited November 2012
    Please make sure you are logged into your profile and connected to Xbox live when you start the game. This will ensure you are prompted to download the Title Update. Confirm and download this update, and then restart your game.
  • edited November 2012
    I'm having the same issue after trying to continue mid episode 2. I should be all up to date on the game as well (I think I got a title update when I first started ep 1). Suggestions?
  • edited November 2012
    I had to work the solution out myself. copy your save to slot number 3 and it should work fine ;]
  • edited November 2012
    if it dont then restart ep 1 on slot 3 it worked for me and 3 other friends xD
This discussion has been closed.