User Avatar Image

Grim Fandango: Hopelessly stuck

posted by TrogLlama on - last edited - Viewed by 7.3K users
The Telltale forums really aren't the place to discuss this, but I'm not a member of any other forum, so there you go.
Also, please note that this isn't a puzzle solution (I don't think), but quite possibly a glitch that'll set me back quite a bit due to not saving.
Anyway, in year 3 at the edge of the world I'm underwater at the conveyor belt. I set it to go in reverse, towards where Glottis is, and now I need to get back. However, if I go forwards I end up back on the conveyor belt and can't get off so I have to go back to where I was, and if I go backwards I leave as soon as the area loads (this is without any user interaction).
Can I get out of this or do I have to reload?
20 Comments - Linear Discussion: Classic Style
  • I experienced the same thing, I think, and I remember the solution as being something terribly simple.
    Tell me, are you actually stuck *on* the conveyor belt?
  • I experienced the same thing, I think, and I remember the solution as being something terribly simple.
    Tell me, are you actually stuck *on* the conveyor belt?
    Well, I'm stuck in limbo. I can't get away from the bit where you're on the rail.
  • Huh... uhm... Well, you could always try getting close to the part of the conveyor belt with the lever and then clicking the interaction button like crazy.
    If all else fails, you can download saved games for GF here:
    Sometimes an error in the game seems to be tied to the saved game you're using.
  • Late reply (or call of help!)

    I have a similar problem here with fork lift puzzle. Yes, got the patch; yes, matched the exe file with win. 98. Elevator's still waaaay too fast. I tried slowing the game down using the trial CPU killer 3, but it appears to have no results. (I made a new preset to slow it down with a few percent.) I see Turbo mentioned at a lot of boards but I can't find a link to the program that's still active.
  • Try downloading a save point just after that puzzle. Thats what I did when I was stuck on the conveyer belt.
  • Have you tried setting processor affinity for the game to only use one processor? Open up the task manager (Ctrl + Shift + Esc) while the game is running, right click the process for the game, and go to set affinity, and uncheck one of the processors. That might work a bit better than just slowing down both processors.
  • Yes this is a bug that is created by the faster processor of modern computers that the game cannot handle. I was stuck in your exact spot, it isn't really a puzzle it is a glitch. You need to download a program that will slow down your processor speed so you can go up the conveyor belt. VERY ANNOYING i know but that is just how it is.
  • I wrestled with this myself, but found a solution (eventually), the trick is, to go to the point where the conveyor belt turns up, in that indentation, you should be able to stand. Now, watch Manny's head carefully, because you'll have VERY little space to move. Turn him around, and eventually, his head should start facing the lever, looking down at it. Hit enter. Manny will now jump off of the conveyor belt, and you should be able to move on.
  • the problem lies with modern CPUs being to fast. I solved it myself with a tool that slowed mine down. The game ran in a crawl but I did get past it much easier.
  • I just never touched the conveyor belt controls until the very end of that section. I've heard that CPU Killer can help with this problem, but I'm mildly suspicious of any program that features an integral part of my computer and any synonym for destroying that part in its title.
Add Comment