User Avatar Image

"Storage device lost"

posted by Luizao876 on - last edited - Viewed by 24.7K users
For some reason, everytime I play Episode 5, and when it is on loading, this pops on:

"The storage device was removed while saving or loading. The game will now exit to the title screen."

Then, when I restart to where I was, it never loads, it stays in a black screen and never loads.

Does Telltale or someone knows the solution for this?
157 Comments - Linear Discussion: Classic Style
  • They know about the issue, they just don't seem to be willing to comment on it.

    Another thread mentions that they have issued a patch to Microsoft, so hopefully it'll fix this problem along with all the others.
  • User Avatar Image
    MattP Telltale Staff
    Can you provide me with more information on your console? How old is the xbox and the hard drive you are using? Do you have a memory unit or flash drive connected as well? If so, which are you using to store your saves? Are any other devices plugged into the USB ports?
  • I can provide you with all the information I am able. Please forgive me for being remiss in doing so before.

    I have an Xbox 360 Elite bought in early 2008, according to Wikipedia that would make it an Opus motherboard. I am using the 120gb hard-drive that came with the console.

    I have run the game with a USB stick configured for 360 storage connected to the console (my friends bring their profiles to my house in this manner) and tried running it without any storage but the hard drive connected. The error occurs at the same points no matter if a USB is connected or not.

    My save is stored on the 120gb hard drive. In an attempt to problem solve I have moved my profile, the game and the save to a USB stick, removed the hard drive and attempted to play the game from there. The error occurs at the same point.

    The only other device that remains connected to the console is the Xbox 360 HD-DVD drive. I have however disconnected that from the console and tried to play the game but issue persists anyway.

    Note that another profile on my console has been able to play the game through to completion without this "Storage Device Lost" error.
  • So any more movement on this? I know the 360 might not be the platform you prefer but we still have paid money for the game, only to be blocked from playing by errors.
  • I have the same setup as the guy previously mentioned. Only difference I have is I also have a kinect plugged in as well. I have tried clearing my cache on both the hard drive and the mu. I have just deleted the episode from my hd and have reinstalled it. I have even tried starting a new file and skipping to episode 5 with random choices made and the only thing that did for me was have the error appear even earlier than before. I have tried the rewind function and it either loads and then causes the error at the same point as before or loads to a black screen. Any suggestions?
  • Same thing happened on my slim console. Congrats on the game of the year i agree with that but studio??? nah you guys suck at supporting your fans. I only beat the game because i have a second xbox to download it to. I feel bad for the people still waiting to see how their story would turn out.
  • I hope we can get some feedback this week that Telltale are at least working on getting this error fixed.

    With the disc release imminent, hopefully they can now put their attention back to fixing the game for the users who downloaded it.
  • Just got an update from Xbox LIVE but it hasn't made the slightest bit of difference to this issue.

    Still pops up with the Storage Device Lost error at the same place.
  • Still no news on a fix for this error then?
This discussion has been closed.