User Avatar Image

Can't activate switch #5 during train startup ep.3

posted by paulberb on - last edited - Viewed by 2.2K users
The game won't allow me to toggle the switches located at the #5 console during the train startup sequence. I've rewound to the start of that chapter and the bug persists. Really disappointing that I can't continue the story at this point, and I really don't feel like rewinding any further if I can help it. Any advice?
12 Comments - Linear Discussion: Classic Style
  • I am having the same issue, unable to adjust switch five, it is not an active item, only 6&9 are active :(
  • Yeah, I really wish I could finish this game and see where the story goes. Does anyone know if Telltale still actively fixing bugs?
  • Lol, do they even care? Its been almost a MONTH since topic starter pointed at the issue, and they seem to ignore it. I have the same problem with switch 5 and I dont even expect solution, considering the amount of fucks given by support.
  • This is sad. I opened this http://www.telltalegames.com/forums/showthread.php?t=32590 4 months ago and people still having problems with it.
    What kind of support this game gets?
  • I just emailed support, we'll see if they get back to me at all.
  • It seems to differ. I've sent e-mails to Telltale twice and I got a respond both times, but they weren't really helpful. One or two sentences about how they know there is a problem and 'they are working on it'.
    Being a naive person, I'm kinda thinking they ARE indeed working on a fix, even though it's pretty much dead silence on the support forum. Except for a few moderators who are actually helping to fix any problems.
  • It's been over a week since I emailed support and over a month since I created this thread and there has been no response. This is unacceptable to me. I will not be purchasing any more games from Telltale.
  • I received a response from Telltale after 3 weeks of waiting and was told to rewind 2 checkpoints and replay to the point the game broke, and this would fix it. I spent 40 minutes replaying the game and the fix did not work. This is by far the worst experience I have had when it comes to a buggy game and poor support. Telltale should be ashamed.
  • Got another response telling me to try adjusting the resolution. I can tell the difference between a switch not being usable or simply being off the screen. Will this ever be fixed?
  • I have the same problem, cannot activate the switches on panel 5, has this ever been fixed?

This discussion has been closed.