User Avatar Image

TWD crash on connecting

posted by halldorr on - last edited - Viewed by 9.4K users
Picked up a copy of TWD for my wife on Steam as I loved the game but she just can't play the damn thing. We have identical computers as far as hardware goes and it ran just fine for me.

Here are the things we've pulled from the forums and tried so far:

1) Played with compatibility sittings, tried them all but no luck
2) Set run as administrator, no luck, set to all users, no luck
3) Tried replacing a DLL here and there as suggested, no luck
4) We don't have controllers but we pulled all USB stuff one by one, no luck
5) Disable internet connection - this appeared to work

Is there a fix to this? I'd like her to be able to play as the game intended and have the Steam sync work properly for her without having to always disabling her internet connection.

We're both on Windows 7 64bit and we connect tot he web through a home router. Seems odd that it would crash on connecting but that is where we seem to have an issue every time.
151 Comments - Linear Discussion: Classic Style
  • User Avatar Image
    DjNDB Moderator
    VMWare has its own simulated BIOS.

    Be careful, installing an older windows on another partition will at least overwrite the Bootloader and make the other windows inaccessible.

    I just started some specific searching and found something awesome.
    Look at this post and the dxdiag two posts below.

    Almost the same system, and it also crashes on connecting. The Mainboard might be slightly different, but it also identifies as
    System Manufacturer: GBT___
    System Model: GBTUACPI
    and is also based on the P55 chipset.

    EDIT: Wait, there's another one and another one

    That's good news, since it seems to be Mainboard related.
  • So yeah i read through it, only useful thing i've found was an update for Direct X which i didn't try yet. Rest of them are saying it works fine when switching internet off, well it does as well for me but i see no reason for it to be like that and i do need internet connection while playing so that's a solution, just not for me. And i don't see a reason why the game support team never actually posts in this forum? Only moderators (Which are supposed to moderate the forum and not solve tech issues - But just still being very awesome!)

    The only posts i've seen from devs are looking like that :
    "Which version of the game you have" etc.. -.- which is kind of frustrating as they do not pay attention to majority of people who started to thread and have the same issue but look at certain cases which are not related to the topic of the thread.

    At any rate - Yes the game works when i turn internet off. However it is not satisfying as it doesn't work properly. It should work without requiring me to turn off anything just like the majority of users do


    A lot of DxDiag's -.- kinda hard to read through it all, and a lot of people posting about random issues in the same post and keeping it hard to track what exactly kind of solution worked for which issue -.-
  • User Avatar Image
    DjNDB Moderator
    I was not posting it to say there is another solution in there somewhere, but to confirm that it's very likely an incompatibility with your mainboard.
    I pointed that out in my Mod Forum thread, and am currently searching the forums for other chipsets/mainboards affected.
  • Well it would be great to know that it is the issue, but then -.- that means i need to change my mainboard just for 1 game for it to run properly -.- which is kind of ... Ehhh... >_>
  • User Avatar Image
    DjNDB Moderator
    Yeah, i see what i mean. So far working around it is the most reasonable solution.
    At least now there is the possibility it can be reproduced by TTG if they get the same mainboard, which is the first step to figuring out why it happens.
  • Would be way more appreciated if there could be a patch to fix it. But hey man! Thanks for trying to help me so much ^.^ You're awesome! Waiting for a verification about the mainboard
  • User Avatar Image
    DjNDB Moderator
    You did an awesome job too.

    I just had the thought, that some default BIOS setting could be the cause.
    Do you know which Revision of the Mainboard you have?
  • I could check if you told me how to or where at =P

    And about BIOS - If you can give me a guaranteed way to install BIOS and then if it doesn't work how to restore the previous one?
  • User Avatar Image
    DjNDB Moderator
    Here's an image of the mainboard.
    You can see the revision in the upper left corner, on the image it is Rev:1.0.

    That's needed for the BIOS update too. The Mainboard restores the previous one automatically, but i'll have to check the manual for your revision. I had an arbitrary 2.x revision manual before.
  • Motherboard is "Rev 1.0 PCB"
This discussion has been closed.