TWD crash on connecting



  • edited January 2013
    Installed both drivers and it still didn't change anything.

    Going for SP1 and update windows.
  • edited January 2013
    Just got SP1 installed. Windows version is just like yours yet issue persists.... Uffff! That starts to annoy me...
  • DjNDBDjNDB Moderator
    edited January 2013
    I am running out of ideas.

    Best you can try next is the XP VM, i guess.

    I could also take a look at a Wireshark log of a crashed start.
  • edited January 2013
    Thing is, it won't help me if it'll work on a VMWare either XP or W7 ... I am not intending to play the game on a virtual machine.

    I wonder what actually causes this crash on my system. Is it related to hardware? Software? I know it's poking in the dark but i am out of ideas as well. I will try XP on a VMWare but it's not a solution - More of a test =( where results lead nowhere any ways.

    About Wireshark i can open it in a sec. Will post with a link i guess
  • DjNDBDjNDB Moderator
    edited January 2013
    Yeah, i meant the VM as a test as well. Would be strange if it crashed there as well.

    It's probably best if you do the wireshark log during a clean boot, to minimize other network traffic.

    Booting clean in Windows Vista / 7:
    1. Click Start --> Type msconfig --> Press Enter
    2. On the General tab, choose Selective Startup
    3. Uncheck Load Startup Items
    4. Select the Services tab
    5. Check Hide all Microsoft services
    6. Click Disable all
    7. If running the game on Steam, re-check the "Steam Client Service"
    8. Click on OK
    9. Click Restart.
    10. After reboot, run the game to see if it works.

    After performing the necessary steps, restore your settings by doing the following:

    1. Click Start --> Type msconfig --> Press Enter
    2. On the General tab, choose Normal Startup
    3. Click Ok
    4. Click Yes, when asked to restart your computer
  • edited January 2013
    I have noticed a very odd thing. Whenever i fresh install Wireshark on my PC it works fine and finds all network interfaces from which i can capture packets. However after i run Walking Dead, for some reason Wireshark no longer recognize any interface it can capture from and i need to re-install the program entirely for it to start working (A reboot to the system doesn't change anything)
  • DjNDBDjNDB Moderator
    edited January 2013
    That's strange indeed.

    Did you have Wireshark or WinPcap installed already the first time TWD crashed on this fresh installation?
    Does Wireshark also work again if you just reinstall WinPcap? That might narrow the problem down a bit.
  • edited January 2013
    It happens after a reboot (Cannot confirm yet if related to running the game or not. Gonna do this test now after post) and has nothing to do with WinPcap as re-installing it didn't help.
    [Link removed]
    I started the game at entry 290 till 340+
  • edited January 2013
    Update -

    The interfaces vanishing on Wireshark had nothing to do with the game. As soon as i rebooted and started Wireshark it gave me a pop up saying "NPF" driver didn't load and that's what were causing the issue.
  • DjNDBDjNDB Moderator
    edited January 2013
    I see some steam traffic in the data, a lot of UPNP stuff (SSDP) and unknown UDP Traffic.

    It DNS resolves just before the end, but doesn't connect. Does that happen before or after the crash?

    As a last resort you could try adding to the HOSTS file together with the other entries. Be aware that you won't be able to connect to this site as long as it's in there.

    You can also try what happens if you start Steam in Offline mode.
  • edited January 2013
    Niether of these have worked. still gets to same point and crashes.
  • DjNDBDjNDB Moderator
    edited January 2013
    I just had one more crazy idea. Does it also crash if you unplug the cable from your router to the internet?
    That could narrow down if it's actually an internet issue, or being in a network in general.

    I can see why it's not fixed yet, as hard as it seems to track down. You were really helpful in the process. Since you freshly installed Windows multiple times in between I can only develop theories consistent with that.

    Things that did not change as far as i know are:
    - Your Windows Version (If you have an XP, that's worth a test in the VM)
    - Your Hardware (Well, hard to change, but again the VM might be a good test)
    - Your Steam Account (Could be some weird configuration issue in the account of the affected users)
    - Your Network Environment (Maybe some device in the network causes the problem)

    That's the last things i can think of that could be experimented with.
  • edited January 2013
    If i unplug any connection to internet (It doesn't really matter where, either wan connection from router on or directly between my PC and router - Just the fact there is no internet connection at all)

    I have no time to play with VMWare today so i will be forced to give it a shot tomorrow after work (And i'll be home earlier)

    Might try it on one of my work PC's as well XD but they are really pieces of junk so i doubt they'll even meet the min requirements any ways. I'll download Windows XP by the night and try it on VMWare tomorrow (Also will try to install my own windows on VMWare)

    Thanks for the devotion man
  • DjNDBDjNDB Moderator
    edited January 2013
    perilomo wrote: »
    If i unplug any connection to internet (It doesn't really matter where, either wan connection from router on or directly between my PC and router - Just the fact there is no internet connection at all)

    That was not a complete statement. Does it work or crash under these conditions?
  • edited January 2013
    My mistake =O

    Sorry for the lazyness! I have just unplugged my wan connection from the router (Which made my PC be still connected to the router, but having no internet at all) and it still crashed. Which means that something in the interaction of the game with any LAN interface would basically crash the game.
  • DjNDBDjNDB Moderator
    edited January 2013
    perilomo wrote: »
    Which means that something in the interaction of the game with any LAN interface would basically crash the game.

    Good info, that's consistent with us seeing nothing meaningful in Wireshark.
    Now the next question would be, if it only happens if the PC is connected to that router, or also with any other hardware.

    Do you have any other device you can plug the Ethernet cable in?

    There should be no WiFi connection at the same time, so it's best to even turn off the router.
  • edited January 2013
    My only options would be :

    1) Turn my own router as a bridge (So it acts as a modem only) and not use a dailer.
    2) Bring in a modem that is no router by default
    3) Bring in another router and try the same thing.
    4) I have ordered a new Ethernet external card yesterday, so it'll be arriving within the next few days. So i will have 2 "Local Area Connection" . Will see if it has anything to do with the interface itself (Even though the fact i use an external USB for wireless already false this statement, but then comes in the fact the game doesn't like extra USB devices - So will try it out with a whole different hardware in the ethernet field)

    Unfortunately not today already as it's 1 AM - And work tomorrow morning again so i am very sorry but will have to do the first three steps after work tomorrow and the whole thing will have to wait till then
  • DjNDBDjNDB Moderator
    edited January 2013
    perilomo wrote: »
    Unfortunately not today already as it's 1 AM - And work tomorrow morning again so i am very sorry but will have to do the first three steps after work tomorrow and the whole thing will have to wait till then

    Alright, sleep well.

    I like how motivated you are in testing stuff.

    I just had another idea for a test.

    You can keep your wired network connected, and manually set it to an IP address of a different subnet than the router. That way they are connected, but can not communicate above Layer 2.
    perilomo wrote: »
    Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
    IPv4 Address. . . . . . . . . . . :
    Subnet Mask . . . . . . . . . . . :
    Default Gateway . . . . . . . . . :

    An example based on your network info from above.
    You can manually set it to
    IP Address and subnet
    in the Network Adapters IPv4 Settings and try if the game crashes.

    You won't have any network access with that setting.

    That test could show if the crash is caused by the Network Adapter being active and configured at all and/or by some communication that goes on below layer 3.
  • edited January 2013
    Just now have configured IP manually in Ethernet adapter to be at while default gateway was and game started, skipping the "Connecting" part.

    Will try tommorow change my LAN IP all together in the router to and see if changes anything. Also will try with a DG on same segment but none existant (aka ip is and DG as 10.0.1 254 but have nothing connected with that ip)
  • DjNDBDjNDB Moderator
    edited January 2013
    That's great.
    Basically we have disabled all IP communication from the network device, and the game works.
    Now what happened on the network when only the WAN was unplugged and it still crashed?
    That's something i would love to see in a wireshark log. Without WAN the distracting traffic to the internet will not be in there too.
    You can PM it to me of course.

    Also, are any other Devices connected to the router than the PC?
  • edited January 2013
    Nope my PC is the only one and i disable wireless network when i don't use it as i am connecting with a cable so i never need wireless unless i have guests.

    I'll give you the wireshark log + program monitor log when i am home
  • DjNDBDjNDB Moderator
    edited January 2013
    I found out that the game does not try to connect, if it can't DNS resolve the domains.
    For some reason it still can do that, if it's firewalled as we tried earlier, even if the dnscache is flushed before.

    So here is what i figured out.
    The game doesn't try to connect, if it's firewalled, and the DNS Cache is disabled. That way you should be able to start the game, without disabling your entire network.

    I wrote a little batch file for your convenience. You might have to change the path to the WalkingDead101.exe in the firewall rule.

    Then right click the TWD_Disable_DNS.bat and select "run as administrator".

    Start The walking dead, when the Batch file instructs you to. If TWD is in the menu Once you are done playing, you can switch back to the Batch file and press any key, to disable the firewall settings and restart the dns cache.
    If you just close the window, the settings will not be reverted, so always end the batch file properly.

    Sadly we still don't know why wanting to connect crashes the game in the first place, even if it doesn't even send anything on the network.

    If you do another wireshark log, make sure you flush the dns cache first, so we can see when the DNS request is sent. You can do that on a command line by running
    ipconfig /flushdns
  • edited January 2013
    Yea sorry it took so long to arrive back home >_> any ways i am gonna go to work again in 3 hours. Only thing is that i will make sure i can connect to my PC remotely and thus be still able to do testings which do not require PC restart or cutting off network.

    Gonna try your idea now with the batch file and try to save some Wireshark logs

    So yeah it works! I managed to still stay online and the game finally ran! While skype was open...

    Gonna send you a PM with Wireshark logs now. Want me to make a process monitor as well? Or it is not necessary no more?

    I could do debugging if that helps (With the program you specified earlier)
  • DjNDBDjNDB Moderator
    edited January 2013
    I am glad it works that way.

    I think process monitor won't show anything new.

    Debugging without the source code is insanely difficult, even if experienced.
  • edited January 2013
    New problem hehe... I am gonna find you guys a lot of work (Sadly for me as well T_T)

    Have just encountered the following. After running the game i switched tabs and finished the process of the batch file to start DNS again BUT! As soon as i click on "Play" on Ep 1 it closes the game with the same error...

    And when i kept the batch file running it got me to an "Offline mode"? I dunno, but i had to choose between 3 save files which i didn't need to when restarting DNS before the "Play" ingame....
  • DjNDBDjNDB Moderator
    edited January 2013
    The crash on clicking "play" is interesting. Is that when clicking "Play" in the main menu or later?

    Does that also happen if you run the game by disabling the network adapter, but disable it again before pressing play?

    The 3 savegame slots to select sound like the normal behavior, or do you mean something else?
  • edited January 2013
    Well here what happen. When i first ran the Batch file i got to the menu after the first "Connecting" thingy. It skipped it (Just took a long time to load). After getting to the main menue i click on "Start game" or whatever i cannot recall and have no time to check now. When i do so it asked me which type of game i want to start (Standard with hints or the one with less hints). After choosing that it got me to the menu of choosing an episode. After clicking the "Play" button while seeing the Ep1 picture in the background it crashed.

    Second time i tried to run it (While batch file was still running in background and before i re-started DNS) i got the following: Clicked on "Start game" got straight to 3 save files - Chose the first "New Game" and got to the background of Ep1 again where i clicked play and it just started the game
  • edited January 2013
    Oh and by the way i cannot unplug my network cable right now because i need the internet at the moment badly...
  • DjNDBDjNDB Moderator
    edited January 2013
    Okay, i just checked. The game skips the choice of the save slot the first time, so the game behaved normal, except for the crash on "play".

    I don't know why it crashed though. I couldn't see any network traffic caused by the game right after pressing "play".

    The good news for the workaround is, that you still can use your network while playing, even without reenabling the DNS cache. It will just send DNS requests as needed, which will cause a slight delay and extra traffic.

    It is likely though, that the dns cache service starts itself at some point, unless you set it to manual in the services. But that would make the workaround more cumbersome.
  • edited January 2013
    So that's a "Back to the drawing board" kind of -.-

    Basically it seems like something in the games attempt to connect to it's servers or even the thought of it makes it crash for some reason.

    Do we have a way to contact TellTaleGames tech support about it all? -.- I mean you are awesome man, but they might actually find this issue >_> and give more answers (Specially with the source code which i believe is crucial for debugging...)

    I am officially out of ideas >_> i would do any test necessary, but this is so far beyond my knowledge i cannot even start thinking of what might cause it
  • DjNDBDjNDB Moderator
    edited January 2013
    I updated the batch file above, included your experience, and made sure the service doesn't automatically restart.

    I am also at a point where i can't do much more myself. I'll try to get some attention to this issue in our Mod forum.
  • edited January 2013
    How do i restart the service in that case?
    Gonna take a look at the batch to see what was changed
  • edited January 2013
    I don't see a difference between the two batch files really. I believe that if i will not Alt+Tab while in game and will not finish the first Batch it will still run and do all good. The second batch basically is just having the text edited but does the same. It restarts the DNS service only after i finish playing and exit the game.

    So basically if i will not "Press any key" on the first one while still playing it'll be just the same (Just finish the process after finish playing).

    I was about to use that as a temporary solution any way. Just i want to make it work without anything and hopefully make it work for other people as well that are having a similar issue.
  • DjNDBDjNDB Moderator
    edited January 2013
    The new batch does the same but has two extra lines.
    sc config dnscache start= demand
    sc config dnscache start= auto

    They prevent the dnscache service from restarting automatically while you play, which could happen otherwise. It's just an extra security measure, so the game doesn't crash unexpectedly because of that.
  • edited January 2013
    Fair enough. Thanks a ton! At least now i can play with that in the background while still using Skype and other network related things! That's awesome.

    I would still be happy to see this resolved. And please give me a PM or anything or even post here (As i have subscribed to the post) so i can execute any sort of test or logging needed
  • DjNDBDjNDB Moderator
    edited January 2013
    Will do.
    I am glad we at least found a workaround that is less restricting.
    I just posted the thread in the Mod forum.

    Now it's time for a break and making some popcorn...
  • edited January 2013

    Sorry for causing you so much trouble man, and thanks so much again for cooperation!
  • DjNDBDjNDB Moderator
    edited January 2013
    I just reviewed some of the past things we talked about.

    We still have not excluded your router from the equation.
    Does it also crash, if you connect your PC to the internet in any other way?
    Also, what's the type and speed of your internet connection?

    I saw in the UPNP data that the router identifies as NETGEAR DGN2200v2BEZEQ RangeMax NEXT Wireless Router.
  • edited January 2013
    Thing is i don't think it's a router. I have changed my router from D-Link 2650U which i used before (Because it was old and probably broken) and it had the same issue.

    I have an additional router which is a D-Link 2760U but i think it'll have the same issue as it must be something with the program and not hardware. As i said, having this problem for quite some time now
  • DjNDBDjNDB Moderator
    edited January 2013
    I got asked in the Mod thread, that's why I am requesting more info.

    Just for the sake of completeness, it would be good if you could try the other router, and give some details about your internet connection.

    While the problem occurs in the program, it does so only on a few systems. So the question is, what triggers it on these specific systems.
    The interesting part is, that it persisted through Windows installations in your case.
    Therefore it could also help to have more detailed information on your hardware.

    Please run HWiNFO64, and select "Report/Create" from the menu. Choose HTML as export format and confirm. Then zip the report and attach it to a reply.
This discussion has been closed.