User Avatar Image

TWD crash on connecting

posted by halldorr on - last edited - Viewed by 9.5K users
Picked up a copy of TWD for my wife on Steam as I loved the game but she just can't play the damn thing. We have identical computers as far as hardware goes and it ran just fine for me.

Here are the things we've pulled from the forums and tried so far:

1) Played with compatibility sittings, tried them all but no luck
2) Set run as administrator, no luck, set to all users, no luck
3) Tried replacing a DLL here and there as suggested, no luck
4) We don't have controllers but we pulled all USB stuff one by one, no luck
5) Disable internet connection - this appeared to work

Is there a fix to this? I'd like her to be able to play as the game intended and have the Steam sync work properly for her without having to always disabling her internet connection.

We're both on Windows 7 64bit and we connect tot he web through a home router. Seems odd that it would crash on connecting but that is where we seem to have an issue every time.
151 Comments - Linear Discussion: Classic Style
  • Nope my PC is the only one and i disable wireless network when i don't use it as i am connecting with a cable so i never need wireless unless i have guests.

    I'll give you the wireshark log + program monitor log when i am home
  • User Avatar Image
    DjNDB Moderator
    I found out that the game does not try to connect, if it can't DNS resolve the domains.
    For some reason it still can do that, if it's firewalled as we tried earlier, even if the dnscache is flushed before.

    So here is what i figured out.
    The game doesn't try to connect, if it's firewalled, and the DNS Cache is disabled. That way you should be able to start the game, without disabling your entire network.

    I wrote a little batch file for your convenience. You might have to change the path to the WalkingDead101.exe in the firewall rule.

    Then right click the TWD_Disable_DNS.bat and select "run as administrator".

    Start The walking dead, when the Batch file instructs you to. If TWD is in the menu Once you are done playing, you can switch back to the Batch file and press any key, to disable the firewall settings and restart the dns cache.
    If you just close the window, the settings will not be reverted, so always end the batch file properly.

    Sadly we still don't know why wanting to connect crashes the game in the first place, even if it doesn't even send anything on the network.

    If you do another wireshark log, make sure you flush the dns cache first, so we can see when the DNS request is sent. You can do that on a command line by running
    ipconfig /flushdns
  • Yea sorry it took so long to arrive back home >_> any ways i am gonna go to work again in 3 hours. Only thing is that i will make sure i can connect to my PC remotely and thus be still able to do testings which do not require PC restart or cutting off network.

    Gonna try your idea now with the batch file and try to save some Wireshark logs

    So yeah it works! I managed to still stay online and the game finally ran! While skype was open...

    Gonna send you a PM with Wireshark logs now. Want me to make a process monitor as well? Or it is not necessary no more?

    I could do debugging if that helps (With the program you specified earlier)
  • User Avatar Image
    DjNDB Moderator
    I am glad it works that way.

    I think process monitor won't show anything new.

    Debugging without the source code is insanely difficult, even if experienced.
  • New problem hehe... I am gonna find you guys a lot of work (Sadly for me as well T_T)

    Have just encountered the following. After running the game i switched tabs and finished the process of the batch file to start DNS again BUT! As soon as i click on "Play" on Ep 1 it closes the game with the same error...

    And when i kept the batch file running it got me to an "Offline mode"? I dunno, but i had to choose between 3 save files which i didn't need to when restarting DNS before the "Play" ingame....
  • User Avatar Image
    DjNDB Moderator
    The crash on clicking "play" is interesting. Is that when clicking "Play" in the main menu or later?

    Does that also happen if you run the game by disabling the network adapter, but disable it again before pressing play?

    The 3 savegame slots to select sound like the normal behavior, or do you mean something else?
  • Well here what happen. When i first ran the Batch file i got to the menu after the first "Connecting" thingy. It skipped it (Just took a long time to load). After getting to the main menue i click on "Start game" or whatever i cannot recall and have no time to check now. When i do so it asked me which type of game i want to start (Standard with hints or the one with less hints). After choosing that it got me to the menu of choosing an episode. After clicking the "Play" button while seeing the Ep1 picture in the background it crashed.

    Second time i tried to run it (While batch file was still running in background and before i re-started DNS) i got the following: Clicked on "Start game" got straight to 3 save files - Chose the first "New Game" and got to the background of Ep1 again where i clicked play and it just started the game
  • Oh and by the way i cannot unplug my network cable right now because i need the internet at the moment badly...
  • User Avatar Image
    DjNDB Moderator
    Okay, i just checked. The game skips the choice of the save slot the first time, so the game behaved normal, except for the crash on "play".

    I don't know why it crashed though. I couldn't see any network traffic caused by the game right after pressing "play".

    The good news for the workaround is, that you still can use your network while playing, even without reenabling the DNS cache. It will just send DNS requests as needed, which will cause a slight delay and extra traffic.

    It is likely though, that the dns cache service starts itself at some point, unless you set it to manual in the services. But that would make the workaround more cumbersome.
  • So that's a "Back to the drawing board" kind of -.-

    Basically it seems like something in the games attempt to connect to it's servers or even the thought of it makes it crash for some reason.

    Do we have a way to contact TellTaleGames tech support about it all? -.- I mean you are awesome man, but they might actually find this issue >_> and give more answers (Specially with the source code which i believe is crucial for debugging...)

    I am officially out of ideas >_> i would do any test necessary, but this is so far beyond my knowledge i cannot even start thinking of what might cause it
This discussion has been closed.