Let's Play... Simon the Sorcerer 3D



  • edited March 2013
    Doctor Who The Eternity Clock:D

    Wait there is an L in the title for this game. Wasted money then.
  • edited March 2013
    I won't do a Let's Play of The Eternity Cock (snigger). It wouldn't be very interesting.
  • edited March 2013
    I won't do a Let's Play of The Eternity Cock (snigger). It wouldn't be very interesting.

    I beg to differ. You can make any boring LP interestikng. All you need is a terrible game and some dental surgery. Case in point:https://www.youtube.com/watch?v=4ooiBGBmZsw
  • edited March 2013
    I meant a screenshot Let's Play. You can't really do one of those with a platformer. Very dull.

    A VIDEO Let's Play is perfectly doable. I just. Don't. Want. To.

    EDIT: Also, reviewing Simon's list of crimes, I've come to realize that one of them isn't technically Murder, but Animal Cruelty, so I'm retroactively changing it. Sadly, this takes his current kill-count down from Six to Five.

    HOWEVER. I now present, so far, the entire list of crimes Simon has committed. See if you can identify what each one was! Cookie for the first person to do so.

    Murder: 5 counts
    Theft: 2 counts
    Animal Cruelty: 4 counts
    Aiding and Abetting a Fugitive
    Grievous Bodily Harm: 4 counts
    Trespassing (you won't get this one - it's actually for entering the old drunk's hut in the swamp, since he doesn't want you there)
    Animal Poaching: 2 counts
    Child Abuse
  • edited March 2013
    I just. Don't. Want. To.

    Well speaking from experience of a viewer you shouldn't. We were all glad when Drake came to an end.:D
  • edited March 2013
    der_ketzer wrote: »
    We were all glad when Drake came to an end.:D
    Christ, I need to finish that Let's Play at some point. *shudder*

    Also, check my previous post for a chance to win a cookie.
  • edited March 2013
    No-one wanted to try? Oh well, I guess I get all the cookies then.


    (Shut up, the lighting was awful)

    Anyway. I'm still working on the full review of this game, hence the lack of proper updates for a couple of days. They'll return soon, I promise. To make up for it though, here's a clip from said review, highlighting Simon's crimes.

  • edited April 2013
    I'm not sure how I missed this thread before but I've read all 9 pages of it today... good stuff (the 'let's play', not the game itself obviously). Seeing what an uber-nutsack Simon is, will surely make Joe King seem a lot more likable from now on!
  • edited April 2013
    Oh hell, I forgot all about this. Bugger.

    I'll get back to this next week, promise.
  • edited April 2013
    ...and we're back. Finally. Oops.

    The reason for the delay was actually two-fold, so allow me to explain.

    First, there was my review (and subsequent addendum going into more detail about the minigames). As I said in the first post of this thread, I was doing this while the video I captured was being converted in less hard-drive raping sizes. Well, that process had finished and I could finally work on putting the reviews together, which I did, putting this Let's Play on hold during the process.

    Second, and this was the big one - I realized I was missing some footage from the next part of the Let's Play! This meant I had to go back and replay the game to get it, and that would require finding a savegame from before the puzzle had been solved. Which I didn't have.

    So I kind of put the whole thing off and forgot about it. Not very professional, I admit, but there you go. Fortunately, St. Eddie reminded me I really should be getting on with this, so here we are!

    Now then. Where were we?

    Ah yes, we were going to fix everyone up. Let's start with Coneman the Barabrain, since he's the one I had to go back and get new footage for (which'll explain the difference in screenshot size & quality, sorry).

    We have the kid's teeth (from giving him the 'gobstopper') and we have a toy ACTION FIGURE of the man in question, so let's go get our voodoo on.


    We hand over the teeth (which, if you look in the top-right corner, you can see are still bloody) and...


    ...the demons just eat them.


    That... that's just disturbing (and not at all a completely random excuse to insert an animated image from one of my favourite movies, no sir).


    Yes. Yes we have.

    Screw it. Voodoo up that doll, bitches.





    We now have a voodoo doll of Coneman the Barabrain. Why? Because the acupuncturist-demons don't do house calls, so we'll have to get them to do their work on the voodoo doll.

    So let's go do that.




    But... but you're the one who gave...




    Dude, don't encourage him.

    Anyway, he gets his partner to do his thing on the doll.


    Oh, THAT'S encouraging.



    (And yes, he is doing the fist-pump dance thing. It's every bit as stiff and painful to watch as you'd imagine)


    Oh phew. That's a relief.

    And if you've seen my review of the game, then you'll know EXACTLY how that second part turns out and are no doubt counting down the seconds until I cover it here.

    Right. So we've gotten Coneman all fixed up - let's get on with the others. Just to remind us of who we've got to go, here's a handy dandy list:

    - Coneman the Barabrain
    - Jar Nin (the corpse)
    - Prince Charming (the frog)
    - The REAL Mellisa Leg (the hero)

    All this*, next time!

    *DISCLAIMER: We will not cover all of this in the next session
  • edited April 2013
    Yay! I'm glad that you're continuing this. You suffer so that we don't have to. Marsden, us humble forumites salute you.
  • edited April 2013
    ...and we're back. Crickey, two updates in one day? It's almost like I'm apologising or something!

    Up next on the list of heroes is Jar Nin, the guy we killed, so let's go resurrect the guy.

    This is a multi-part quest - we need to find his body (or, as it turns out, his ashes) and his soul, which has been lost somewhere since his death.

    If you recall, Calypso gave us the soul jar he used in the opening cutscene so we could find and contain Jar Nin's soul, and he also told us we needed something valuable to lure him into the jar.

    A brief reminder of what happened when we went to find his body under the tree:


    His body was gone, but there was a nice looking necklace underneath it.


    A necklace we couldn't get.


    Fortunately there were some terrorist woodworms who we struck a bargain with - we get them guns, they chew away the tree so we can grab the necklace.

    Well, we won some toy soldiers at the fair, so let's see if that'll do the job.


    Yes. Robots. Let's... let's go with that.

    And their end of the bargain could be done with a standard image, but I'm feeling a little more animated than that.


    Go Ninja! Gif Ninja! Go Ninja! Gif Ninja!


    Uh-huh. Sure. Whatever helps you sleep at ni-






    Oh jeez, now we've got the son wanting to avenge his fallen fath-



    What is that now, 7? Yeah, seven. Time to change my sig again.


    You. Are. A. DOUCHE.

    Anyway, we grab the necklace and put it in the jar (somehow it fits, don't ask me how) and we're off to find his spirit.

    Time to head back to the inn. If you talk to the barman, he tells you that the inn has recently become haunted - sounds like our guy! Let's head upstairs and see if we can find him.


    Squat diddle. Hmm.


    Wait a second - that voice has a terrible Japanese accent. That must be him! Let's try using the jar.


    Someone who didn't kill the guy in the first place.

    No, I'm never going to let that go.

    Anyway, now we need to find his body, and this, I'm ashamed to admit, had me stumped for the stupidest of reasons.

    You remember that church? Well, we're going back there. Or, rather, we're going round the back of it.


    See that door on the left there? Yeah, that's where we need to go.

    For the life of me though, I continously overlooked this door. I honestly cannot explain why. Maybe I'm just an idiot, I dunno. But there we go. I suck. Whoop-de-doo.



    It's full of memorial plaques.

    If you look closely you can make out a few of them. One says ELVIS, another says Feeble Files, a third says JFK...

    These might actually be faintly amusing if the textures weren't repeated a dozen times, meaning that everyone gets about 10 memorials.


    Anyway. The plaque we're after is this one:


    This is Nin Jar's memorial plaque, and it's actually a map to where his remains are.


    Like so.

    And I don't normally do this, but I have to bring up the delivery of this line by Simon's VA - it's absolutely awful. You know when you get a foreigner to speak an English line and they don't know how the pronounciation goes? He does EXACTLY that. The guy should be ashamed.

    Anyway. Now that we know where Nin Ja...

    Wait. It's actually Nin Jar, not Jar Nin?

    Oh, because he's a Ninja. That's really, really lame. No wonder my mind refused to call him that.

    Sorry. Right. So now that we know where Nin Jar's ashes are, we can fly there on our bird thing. So we do.


    And there are Nin Jar's ashes, just lying out in the open on a stone plinth.

    Where, y'know, a slight breeze could send them flying all over the place.

    Yeah, that sounds completely respectful.

    Whatever. Simon won't pick up the ashes with his bear hands, so we have to vacuum them up. I would show you a picture of Simon doingthis, but there's absolutely no animation for it - you use the vacuum cleaner on the ashes and BOOM, ashes are gone. Considering how long the game took to make I'm frankly amazed I could find them cutting corners, but that was just plain LAZY.

    But hey! We've got the soul and the ashes! What do we do with 'em?

    Well, we can't go back to the temple to resurrect him.

    Why, you may ask?


    Because Simon is a thieving, hateful waste of existance. THAT'S why.

    So we have to go all the way back to Calypso and give HIM the soul and the ashes so HE can resurrect Nin Jar.


    Wait - so it IS Jar Nin? Jesus Christ, this... this shouldn't be that hard! Make up your freakin' mind, game! Is it Jar Nin or Nin Jar? I DON'T KNOW! This is incompetence of the highest magnitude! HOW DO YOU FUCK UP A CHARACTER'S NAME?

    Gah.. Who's left?

    - Coneman the Barabrain
    - Jar Nin/Nin Jar
    - Prince Valiant
    - The REAL Melissa Leg

    We'll do the Prince next time. Lord have mercy.
  • edited April 2013
    Simon won't pick up the ashes with his bear hands, so we have to vacuum them up.

    I think you mean block hands.

    Great to see you back at these though. :) Funny as always.
  • edited April 2013
    flesk wrote: »
    I think you mean block hands.

    Is it sad that characters hands look like they should be in Minecraft rather than a adventure game?
  • edited April 2013
    ...and we're back.

    Right. Let's restore the Prince. To do this, we need to have him be kissed by a Princess, and as you may recall, there's one at the festival where we needed to launch the fireworks *shudder*

    So let's go get treasonous.

    If we re-enter the door that led us to the fireworks *shudder* then we arrive at:


    Only one of these tents is open, and if we crawl inside, guess who we find.


    It's that chick with the lisp (and hamster).


    Wait - who's Johnny?


    THAT'S Johnny, as evidenced by this poster on the wall, which is the only place we ever see anything at all related to this nightmare of a character. Just here. In this spot. Nowhere else.

    As a side note - this is the one and only time that First Person mode is needed.



    So basically we need to make ourselves look like Johnny Lightnin.

    This is a three-part puzzle (because it's ALWAYS three). We need the hair, the glasses and the purple coat.

    Well, the purple thing's easy - we just use our fashion magic to turn our robes purple and BOOM. Done.

    The glasses are easy as well - they were our prize from the arcade machine at the fair.

    As for the hair... well, this one's both obvious and incredibly obtuse (somehow).

    See this?


    Yeah, it's a laundromat. And it's not open during the day. Hell, even at night it's hard to tell you can go in there now since it's kind of out of the way and very easy to run past without noticing.

    So, naturally, we NEED to go in here.


    SEXIST. We can add 'Sexist' to the insults we can lob at Simon. Blimey, that list's going to implode in on itself soon.

    Anyway. You remember when we went to the Wig Lady and swapped our cotten candy (THAT I WAS TOTALLY GOING TO EAT) for some silly blonde wig?


    And you remember that black t-shirt we won from the Strength Test?


    End result:


    One black wig. Perfect.

    We now have all we need to impersonate Johnny Lightnin. BACK TO THE PRINCESS!


    Um. Yeah. That's... that's perfect. Let's just hope she's still half asleep.




    Right. Time to REALLY commit treason.


    Is this beastiality or just simple treason? God, I really have completely lost track of just how illegal this is.


    She actually does scream, by the way, so that should really say AAAAAAAAAAAAAHHHHHHH! But no. Instead we get SCREAM. The subtitles suck, they really do.

    Anyway, she took unwillingly kissing a frog somewhat better than I expected.


    ...sort of.


    I genuinely don't know - I really need to get up to date on my legal terms! Treason's the only one I know for certain, but I have no idea what you call it when you force someone to commit beastiality - Abuse? Animal cruelty? Both? God, the ethical quandries this game has made me explore really are mind blowin-



    ...and the worst part is that Simon didn't do it, so I can't add it to his kill count. God dammit, I had good money on him making double digits.


    Well, at least Prince Valiant is back to normal. Best let him know what's going on.


    Right, well he's on board. Three down, one to go.

    Coneman the Barabrain
    Jar Nin/Nin Jar
    Prince Valiant

    The REAL Melisss Leg

    Now tracking down Melissa is an absolute pain in the arse because it requires us to a variety of things that don't seem to make any sense whatsoever, so we'll tackle that next time.
  • edited April 2013
    I think that one just falls under the crime of romance fraud.

    (Mostly posting this to see if we can get to the next page - it's starting to get slow to load again.)
  • edited April 2013
    Is romance fraud even a thing? I'll have to look that up.


    Romance SCAM. That'll do nicely.
  • edited April 2013
    Wait, I think I missed something. Who died there?
  • edited April 2013
    The wizard with an arrow in his eye. Insert Knightmare "ooooo, nasty" joke here.
  • edited April 2013
    The wizard with an arrow in his eye. Insert Knightmare "ooooo, nasty" joke here.

    Oh, shit, I totally missed that it was an arrow in his eye. With the shit graphics, I thought he was holding something in his right hand.
  • edited April 2013
    I admit, it does work (somewhat) better in motion. Lemme go back and fix that. GIF NINJA - AWAY!

    EDIT: This should be a bit clearer.


    Also, for the record - yes, he DID used to be an adventurer.
  • edited April 2013
    It's a bit fast though. I think I saw it loop through a dozen times until I realized what was going on in that gif.
  • edited April 2013
    Quit your whining. I'm not doing it again.

    Besides, that's kinda how it was in the game, so at least I'm being faithful in its awkwardness.
  • edited April 2013
    Also, for the record - yes, he DID used to be an adventurer.

    Should've hit him in the knee, then.
  • edited April 2013
    WarpSpeed wrote: »
    Should've hit him in the knee, then.
    Yes, that... that was what I was alluding to. Thanks for spelling it out for the slow ones at the back.

    Bored of editing videos now, let's grab some screenshots from 'em instead.

    Right. As I said, finding Melissa is a two part quest. Finding her, and reaching her. Finding her's easy - she's here.


    That is a 'mysterious island' in the open fields from WAY back in the game. We can't reach it by any means, though if you look closely at it from another angle you can see a path under the water.


    No, seriously. That's all we get. An easily missed visual clue that isn't signposted, commented on or even given a description. That's all we get.

    Words fail me on how stupid this is. All it'd take is one character saying how the water used to be lower before the dwarves ruined it, because that would clue us in on what we have to do, but nope. We get NOTHING.

    I feel a well-placed animated GIF is required at this point.


    Ah. That's better.

    So, as you probably figured out, we have to lower the water level here.

    How do we do this?

    ...the stupidest and most ludicrously insane method possible.


    We need to lower the level by doing two things in particular. We'll start with the one in town, because I've already sort-of laid the foundations for it.

    Now. You remember that Cheese truck from earlier?


    Yeah, that one. Well, we're gonna have to make use of him now.

    One last thing to remember - the Lead that Goldilocks was trying to steal from the Church roof.


    That'd be it.

    The Cheese van actually drives right past it, but earlier we couldn't really do with it.


    Now, for absolutely no reason, this... THING is here:


    This is another recurring character from the second game - some stupid hedgehog kid who we're, naturally, going to abuse.

    First we stand in just the right spot so that the Cheese van stops right next to the Church, like so:


    Then we shoot the kid down with the Pea-Shooter.


    Oh, wait - I lied. Sorry. We won a peashooter from the fair, remember?

    Anyway. You shoot his balloons and make him land in the open-topped van.





    (The game actually counted this, by the way)

    Anyway. All that's left is to let the Cheese van past.


    We now need to follow it all the way back to the warehouse are-DAMMIT, sorry.

    As you'd expect, the warehouse owner is not happy that the Cheese has all been eaten.


    And so the driver walks off, leaving his van free for us to drive.

    Oh, and the kid just walked into the warehouse. End result:


    Heh. Fat kids are funny.

    Anyway, now that we have the van, we can drive it back round to the Church and tip the Lead into it.

    So I just do that.


    1) The van drives really slowly and handles like Simon would if he were 500 Lbs.

    2) Simon's hand has turned white while pushing off the lead.

    3) The lead's clearly landing on the wrong side of the hedge and not inside the van at all.

    So, pretty much just a good ol' fashioned failure all round. And yet:



    Anyway. We get back into the van and drive it back towards the bridge.

    Only now it moves even slower.

    And I'm not even kidding. We're talking snail's pace here. I could walk on my hands faster than this thing now.

    We're only going to be driving the thing around the corner, but it takes almost an entire minute to get there - and I could do it in under 10 on foot. Christ.

    Anyway. The in-game reasoning is that we're going to take this lead to the Inn where Goldilocks will sell it and split the proceeds with us. Of course we never see her there, and indeed will not see her again until Simon the Sorcerer 4 (where she mysteriously loses the cockney accent!), but whatever.

    The only reason I mention this is because it gives us a reason to drive this way:


    Across a very rickity old bridge with a 2-Ton weight limit.

    Oddly enough, the lead we're carrying is supposed to be around 2 Tons. I wonder...


    OK, so in case you didn't get that - Simon drove a heavy van over the bridge, it collapsed and is basically acting as a dam now, which has lowered the water level in the great open fields.


    Seriously - the only way you'd know is if you go and check for yourselves, and you've got absolutely no impetus to do so. It's not even remotely hinted that this is what you need to do!

    Where's that bloody meme...


    That'll do it.

    Anyway. That's one half of this nonsense down. We'll tackle the OTHER lowering of the water next time.
  • edited June 2013
    Oh. Right. I was supposed to be doing this, wasn't I. Oops.

    Tell you what - let me make it up to you guys with a MONSTER update. How's that sound?

    Hope your internet's ready for this!

    Right, let's finish lowering the water of this lake thing then. Quite why Simon can't just swim across is best described as 'stupid'. And 'hard to program'.

    Anyway. Here's the end result of us breaking the bridge:


    We've lowered the water level enough for us to create a (completely pointless) path across the lake, but it's not enough to let us reach Melissa Leg. We have to lower it further.



    Once again, I'd like to emphasize that there has been absolutely no indication that we need to do any of this. NONE.

    Anyway. We need to head back to where the tree fell on... Jar Nin? Nin Jar? Whatever.

    Let me show you why.


    Remember this? Well, if you look in the top left, then you'll see a building. I know it's a tad hard to make out, but it's there next to the phone box.

    THAT'S where we need to go. Why? Damned if I know, but we gotta go there anyway.

    Unfortunately, it's locked. Now, see that sign in front of it?


    That's our only hint as to what we need to do. So let's go back to the dwarves!

    If we talk to the one still alive, he says that one of the others (who got eaten) had some keys. Hmm.


    I beg to differ, Simon. I beg to differ.


    So how do we get it out?


    *evil grin*


    Considering all the horrible things he's done to other people, I had absolutely zero problems making him do this.

    Unfortunately, it doesn't work.


    Yes. Simon needs lubrication so he can reach into a dragon's arse.


    Ok, so he's not actually sticking his hand up the Dragon's arse, he sticking that magnet he stole from the fair up it. Only we've stuck the magnet to a stick with the chewing gum we got from the kid who's teeth we broke.


    Like so.

    Still, funny to look at, wasn't it.

    Anyway, lets rub some butter on this device so we can smoothly insert it into the Dragon's rectum.


    No Simon, that would still be you, because I've just made you make an anal toy. You sick, sick man.

    Hang on - wouldn't that make ME a sick man?

    ...NO. That would make the DEVELOPERS sick men (and women, one sort-of hopes). Yeah, let's blame them. Ahem.

    Alright, let's stick this lubricated shaft up the rear end of a Drag- I'm really not helping matters, am I?


    Uh, you might want to give that a bit of a wash before you put it in your pocket. Just sayin'.

    Anyway, we can now get back to that hut, which is a mere phonebooth teleport (or sprint, whatever takes your fancy) away.

    (If you guessed that these phone booths were supposed to be a parody of the TARDIS, then congratulations, you win a non-existent cookie. You also get to slap the developers in the face, because when this game was made DOCTOR WHO WAS OFF THE AIR AND NO-ONE WOULD HAVE GOTTEN THE JOKE)

    Inside the building we find...


    ...stuff. I guess. Those leaflets Simon's standing in front of are just background decoration and you can't do anything with them, by the way.

    On the left is a pulley system which naturally we're going to break. And on the right...


    ...a trap-door in the ceiling. That you have to go into first-person mode to even see because otherwise you'd never even know it was there.

    Well, OK. That's not TECHNICALLY true. Let me just unlock the trap-door with my Kite and I'll show you why.


    OK. Now if we head back... wait.




    Don't care, it's mine now!

    Ahem. Right. Back outside.


    As you can see, there's a ladder we can climb, which leads to the roof of the building.


    And on this roof is...


    So yeah, it's not completely unexplained, but even so, the trap-door's really hard to see from indoors and I'm still not particularly pleased with it.

    But anyway. We may have unlocked the trap-door, but apparently it's stuck. So let's open it.


    Y'know what? I think we need a GIF of that.


    Ah, that was nice.


    Yes, but it also brings me a great amount of pleasure, so SHUT UP.

    Anyway. Here's the room now that we've opened the trap-door.


    No prizes for guessing what we do now.


    Well, duh.


    Aw man, and I really wanted to use that gasoline for something cool. Not burning a rope. WHICH IS A FLAMMABLE OBJECT.


    Oh my god, that's just terrible. And not just because it looks awful. Look how he's wasting it! Gah, you only needed a little bit! Augh, you useless piece of crap!

    ...whatever. Let's just burn this rope and get this stupid puzzle over with.


    Yes, yes. Fire is awesome. We know.


    Did that confuse you? Good, because I have no idea what it was either. Seriously, this game explains NOTHING about this puzzle.

    Anyway, let me look it up and find out what that was. Bear with me.


    OK. Apparently that was a dam gate, and we've just released it, allowing water to siphon away from the main area into some unseen reservoir.

    I THINK.

    Either way, the water level's dropped, so we can now get to that mysterious island. Let's go, shall we?


    Huzzah. Will Simon climb up that rope, or will we need to find some other elaborate way up?


    Well, will wonders never cease.

    What's up here then?


    Ruins! Lovely. And is that... On the left there?

    Why, I think that's actually Melissa Leg! The real one! We've found her at last!

    Let's go say hello.


    Nice shot of her arse there. keep it classy, Simon3D.





    Well, let's go see the damage.


    ...she's not dead? Well, that's the first bit of good luck we've had all sodding game.


    Oh shut up. Just... just shut up.


    She's talking about her arm, so stop that sniggering.


    I sympathise entirely.

    Anyway, she throws a rope up and asks Simon to tie it off on something.


    I like her. Can we make the game about her instead? She seems way more interesting than our douchebag of a protagonist.


    This may look suggestive, but trust me - it's nothing compared to seeing it in action, because not only is Simon pulling the rope like this, but Melissa's making grunting noises at the same time. It's... well, just watch.

    Anyway, long story short, she climbs up the rope with only one functional arm.


    Uh... blatant fan-service?


    Oh right, that too. I guess.


    You'll have to imagine the loud CRACK here, since it doesn't come across in picture form.


    That does though. Fucking pansy.

    (Also, what the hell kind of pattern is that on the soles of his shoes? And why am I focusing on that?)


    Yeah yeah, you big girl's blouse. Get back to Calypso and the others. After you've found your purse and put your lipstick on and inserted your tampon and bought some shoes and asked if your outfit makes your arse look fat and put a thousand pillows on the bed and failed at parallel parking and cleaned the entire house and purged and acted like a drama queen and bought more shoes and spent hours chatting to your friends and done your nails and acted jealous for no reason and failed to make your mind up about anything and put a thousand cushions on the sofa and talked about your sex life with your friends and acted all clingy and bought even more shoes.


    ...ahem. Let's just jump back to the basement, shall we?


    Right. So now that everyone's here, let's make a plan to stop Sordid.


    Oh. They're already doing that. I guess they just felt that Simon was completely extraneous.

    Have I mentioned how much I like these guys?


    "Who's there? Who dares to disturb us?" (since it's a bit hard to make out)





    Oh, hi Runt. That joke was old even when you did it, and you've not done a great job of animating it, so your attempt at humour has completely failed. But hi!


    Now THAT is funny. Just not intentionally.


    I never want to be that close to Coneman's thighs ever again.

    OK Runt, you've had your not-at-all-funny entrance. What else you got?


    I have absolutely no idea what he just did to Coneman. And I have absolutely no interest in finding out.


    What? Fat lot of good you lot are then!


    I repeat my previous statement about Coneman.


    Bwuh? Why wouldn't you bring enough in the first place? You're dealing with the greatest heroes in the world! YOUR PLAN IS FULL OF HOLES!


    This is distinctly underwhelming.


    Oh for fuck's sake, this is the least active group of heroes I've ever seen! Useless, the lot of you!

    And before you ask, no, there's no point in talking to any of them - except one. And we'll get to him last.

    If we talk to the Ninja guy, we get a bad joke about him being poorly translated:


    If we talk to Prince Charming, we get an equally unfunny conversation about him being gay and it being a problem when your standard reward for heroic deeds is a Princess' hand in marriage:


    And if we talk to Melissa Leg, we get a STAGGERINGLY unfunny conversation about how you need to kill bad guys in unconventional ways for them to really stay dead:


    Seriously, there's no point in talking to ANY of these people.


    If we talk to Coneman...


    "One more word! Just one more and I'll tear you into little pieces and feed you to my horse!"




    And now, ladies and gentlemen, I present to you the single greatest moment in the entirety of the game.

    So great, in fact, that we need another GIF for it. Apologies for the large size of it, but i promise you - it's worth it.


    Oh yes. I could watch that all day.

    And I think that's a good note to end on. Don't you?
  • edited June 2013
    You know, just looking at this game, it makes me wonder why people thought ESCAPE FROM MONKEY ISLAND had bad graphics. In comparison, Escape had beautiful backgrounds and much better character models. From now on, every time I consider criticizing that games graphics, I will come here to remind myself that it could be worse...much, much worse.

    PS. I should probably play the first 2 Simon the Sorcerer games at some point.
  • edited June 2013
    You forgot what popped up after you got the item from the dragon:
  • edited June 2013
    Great stuff as always, Marsden. My eyes too were drawn towards the frankly bizarre shoe texture on Simon! The sound of Melissa climbing the rope is really dodgy. There's no way that wasn't done on purpose.

    By the way, one of the image links is broken (due to a missing ']' after '[IMG'). It's the one above the following text...

    "And if we talk to Melissa Leg, we get a STAGGERINGLY unfunny conversation about how you need to kill bad guys in unconventional ways for them to really stay dead"
  • edited June 2013
    EMI has pretty nice graphics for the time. Didn't age well compared to some others, but I remember being blown away when I saw them back in the day.

    Then again, my basis for comparison were the first two Harry Potter games.



  • edited June 2013

    Looking at the low-res texture on those books reminds me of 'Aliens: Colonial Marines'.
  • edited June 2013
    To be honest: the first HP games look way better than EMI.
    Almost everything does.
  • edited June 2013
    I dunno. EMI has more style.



  • edited June 2013
    I dunno. EMI has more style.

    And prerendered backgrounds. Compare only the stuff that is rendered in real time and it falls flat on it's face.
    Also screenshots will not show you the horror of Guybrush in motion.
    HP1 was on Unreal Tournament Engine. Get it on a PC with high resolution and Anti Aliasing and it beats EMI to death. No sense in comparing the lo fi crap version of the Playstation though.
  • edited June 2013
    I only played the Harry Potter games on PC. But the comparison I was making was that EMI looks prettier in the end. This isn't pre-rendered vs. real time, it's just what the total end product looks like. And the pre-rendered backgrounds from EMI make the total game much prettier than the Harry Potter games in my opinion.
  • edited June 2013
    St_Eddie wrote: »
    By the way, one of the image links is broken (due to a missing ']' after '[IMG').
    Fixed. Thanks for pointing it out, I was in kind of a rush when I posted this.

    I am frankly staggered no-one objected to my girly rant. Oh well, good to know you're all on my side :p
  • edited June 2013
    I objected, but very quietly like a girl.

    Because girls are dumb and being compared to being a girl is worse than being compared to a really lame Hitler.
  • edited June 2013
    On the topic of Escape from Monkey Island. Just remember there are actually console games that look horrible. Look at HP & the Chamber of Secrets. The character models looked like utter shit like Snape. Again lets remember. By this stage we had games like Jak & Daxter The Precursor Legacy, Ratchet & Clank, Sly Raccoon/Sly Cooper and the Thievius Raccoonus, Luigi's Mansion, Mario Sunshine, Smash Bros Melee.

    So i would say first that HP & the Chamber of Secrets' graphics is as bad as this piece of shit game's graphics.

    Btw i think Escape from Monkey Island's graphics is better than this game's and HP and the Chamber of Secrets graphics.
  • edited June 2013
    I dunno. EMI has more style.




    That's kind of cheating though, Alcoremortis. You've selected some of the very best looking screens from EfMI. I've always thought that the The Voodoo Lady's place, Meathook's house (plus the dungeon with the iron maiden, the prosthetic shop and the underwater cavern) are easily the nicest looking backgrounds in the entire game. The majority are relatively ugly in comparison...

    ...There's a very strange discrepancy between the quality of the various backgrounds in EfMI. A few are lovely, many are very ugly and the majority are mediocre at best.

    Why Lucasarts thought that shitty pre-rendered graphics was a step up from Curse's (still) gorgeous hand drawn backdrops is beyond me... other than "3D is teh best everz!" of course (but then it's not even true 3D)!
  • edited June 2013
    Of course I cheated! I wanted to win, didn't I?

    Still I was comparing it to stuff like this:


    To explain why I thought the game was pretty gorgeous when I played it. Because it was far prettier than any other 3D game I'd played to date.
Sign in to comment in this discussion.