Mac version crashing during Camcorder sequence (Episode 2)

Hey everyone! First time poster and desperately looking for some help due to a crash that happens every time at the exact same place.

I'm at a bit that I cannot circumvent, and thus cannot progress the game at all. I am literally stuck because of the below crash.

During Episode 2, there is a cutscene where you view the contents of a camcorder. During this cutscene, after some heavy breathing somebody gets knocked out and the camcorder's viewfinder clearly falls into the car and you see a bunny rabbit toy. This is the exact moment where the game crashes. Nothing happens, except some of the background audio continues playing. Eventually, I have to hammer Option + Q to quit out of the game. If I wait, then the screen goes black, and nothing happens.

Can anyone help? :( This is very annoying as I cannot progress at all and I really love the game! I've tried every graphics setting, turning off Anti Aliasing etc. but nothing seems to do any difference - It's always the exact same moment. It's such a shame, because the game runs beautifully otherwise, bar the odd random crash to desktop or the leg chopping crash. :(

Any help would be greatly appreciated. <3 <3 <3



PS: My specs:

2010 MacBook Pro, 15"
Lots of free space
Graphics Switching/Performance Mode switched off (Neither setting affects the game)


  • edited January 2013
    This is the first time I've heard this error.
    Does it happen EVERY time you get to this scene?
    Are you using the Steam version or Telltale version?
  • edited January 2013
    Hi JordyLicht, thanks for your reply! :)

    I'm using the Steam version of the game.

    For reference, the crash is very similar to one I had always at the start of Episode 2 if i chose a certain option: If you choose to chop off the guy's leg with the axe right at the beginning. Upon the second chop, the game crashes the same way (everything stops, audio keeps playing, but eventually the game goes to a black screen and you have to either reboot or try to quit out). Thing with this crash was, I had the choice of leaving him behind rather than chopping his leg off, so I could circumvent this part and progress through the game, even though the choice I made wasn't exactly what I wanted. I've definitely seen people report this leg chop bug exactly like I experienced it, I have a feeling this Camcorder one is to do with something similar.

  • edited January 2013
    The only thing I can think of is trying to switch between fullscreen and windowed mode (CMD+F), but you probably already tried that.
    It sounds like a videocard issue though. I wish I could help you out more.
    Maybe DjNDB will have more information and tips for you. He's a moderator who browses around the support forums a lot.
  • DjNDBDjNDB Moderator
    edited January 2013
  • edited January 2013
    Done. Unfortunately, no change.

    Just tried again with all manner of lowered settings etc. but no change. Crash at exactly the same moment still :( It's a shame as it's quite far beyond the last checkpoint, so each time I want to try I have to sit through about 10 minutes of dialogue.

    I guess all I can hope for right now is that there is a patch in the works. Has there been any indication from TT that they're aware of any Mac issues?

    They announced an upcoming patch for the Xbox 360 version today.
This discussion has been closed.