User Avatar Image

CSI 4 Hard Evidence problems

posted by Ssindossa on - last edited - Viewed by 2.9K users
So I bought the game for my husband who is an almost fanatical CSI fan and he was like a kid in a candy store. We get home and he goes to install it, and it won't install.. at all.

So I take the disc from him and start trying to get it to work. Finally I get it installing after NOT running the auto install but by "explore"ing the DVD and running setup by hand. Also I can not install the full version, it gets some weird errors about the movies. But I get the minimum install to go.

So I go to start the game and the updater runs so fast i can't see it then just shuts down. That was it, nothing more. So I go into the directory and run the game exe instead on the updater exe and get just a black screen. So I start browsing site to find answers. One suggested deleting the "preps.prop" file to force the game to run at minimal settings (which is odd because our systems WAY exceed the recommended) but hey it starts! Or so I thought... it comes up with the CSI screen and then an error pops up "Bink error: error opening file" and only "ok" as an option, then the game screen goes grey/black and just sits there dead.

I checked everything I have found "help" for it so far.

- I made sure all codex's were fine and not in the way
-All drivers for all hardware and software are current
-The disc is in a dvd player that works
-I saw firewalls can be blocking and so went as far as to take mine all the way down as a test
- I tried running from Gameupdate.exe & csi4.exe
- I even fixed my wmp install as someone said worked for them
-I seperated my compter from the internet and my network even
- I even removed the um.dll file to be sure of the internet issue

Please, any and all help would be greatly appreciated!
15 Comments - Linear Discussion: Classic Style
  • Ubisoft's support says something about the bink error.

    If you are experiencing the error when starting the game for the first time after installation, or at other points; the error can be resolved by renaming the binkw32.dll file from the windows system32 folder as this file get in conflict with the one installed in the CSI folder.
    To to do so, open your Windows Explorer and browser to the folder C:\WINDOWS\system32 and locate the file "binkw32.dll" and rename the file to "backup_of_binkw32.dll"
    You can now play the game.

    Or so they hope :)

    Other than that, this is Ubisofts support for hard Evidence:
  • I do not even have the bink file in the system32 folder, so i guess that is not it. Thanks for the try though.

    Yeah the Ubisoft support has nothing at all about the issues that i have found so far.

    And actually right now i can't even log into their "ask a question" section, keeps saying "The site encountered an unexpected error. Please try again later or contact us if the problem persists." and apparently later has not been within the past 24 hours :(
  • User Avatar Image
    A few things I'd like to know so I can narrow down some solutions.

    What operating system are you running?

    If running Vista, do you have User Account Control (UAC) turned on?

    In either case, are you installing the game on an Administrator account?

    Do you have any virus or spyware protection software installed? If so, please tell me the product name and the versions.
  • Oh right! I keep forgetting that UAC thing on Vista.
    Maybe because I have it disabled along with the other crap security on it, lol.

    I have had no problems whatsoever with playing ANY of the CSI games on Vista.
    I've found most games I try play just fine...
    (except Secrets of Da Vinci: Forbidden Manuscript. Only black screen, even on XP combatibility Grrrr)
  • I am running it on XP Pro SP2 release.

    I run AVG free anti-virus and have Advanced Windows Care V2 for spyware and registry error maint.

    For the record the demo works 100% on our systems... if that has any meaning at all.
  • User Avatar Image
    Looks like there's something fishy with the disk drive then. When you do a minimum install, the game attempts to locate all the movies on the disk. The error your getting is that it can't find these files and therefor can't 'find' the disk for some reason.

    Do other CD or DVDs autorun when you insert them into the computer? I'd like to know if it's the disk or the setting is turned off for all disks.

    Also, what is the drive letter of the CD/DVD disk drive (D, E, F, etc)?
    Do you have more than one CD/DVD disk drive on the computer?

    The quick solution would be to do reinstall using a full install, but if you don't have the space for it we can continue troubleshooting.
  • Can you write down the error message you get when you try to run a full install(if you get it again)? The error message can tell something about if there is a physical problem with the dvd or if the issue is somewhere else.
  • Every other cd or dvd put into the drive autoruns just fine. The dvd drive is "E" on my computer, and yes I also have a cd drive on both computers (his and mines computers are 100% identical built).

    I tried the full install again and got the same error as before, which looks as follows:


    Thank you all for trying to help by the way, it is greatly appreciated, regardless of the outcome.
  • That error message means that the installation program can't read from a part of the DVD(or to be accurate, it can read it, but what it reads doesn't match what it expected to read, which usually is a result of a damage disc or production error). Either the DVD disc is defect or there is an issues with your DVD ROM. If you have tried the DVD disc on more than one DVD drive the DVD is probably defect, and it's probably an production error unless you notice scratches on the DVD. My (unofficial) advice is to return the DVD to the store and either ask them to test it on a computer they got there(to confirm the issue) or to give you a replacement disc. At least, that's what I would have done.
  • User Avatar Image
    There is one more thing to try before attempting to try and replace the disk. There might be a firmware update needed for your CD drive. If you tell me the make & model of the computer, and the make/model of the CD drive itself, I can point you in the right direction on where to get any updates.

    To find your CD/DVD Drive make and model:
    1) Locate the 'My Computer' icon. This icon will be located either on your desktop, or in the Start menu.
    2) Right-Click on the 'My Computer' icon and select 'Manage'.
    3) On the left-side of the 'Computer Management' window, click on 'Device Manager'.
    4) On the right-side of the window, you will find a number of objects attached to your computer. Find the 'DVD/CD-ROM drives' section and click on the + sign next to it.
    5) A list of all the DVD/CD-ROM drives will appear. Please list each DVD/CD-ROM drive listed.

    Then I can point you in the right direction to incorporate any firmware updates for the drive. I want to cover this aspect before getting disk replacements in case this fixes the problem.
This discussion has been closed.