User Avatar Image

Poker Night at the Inventory - Mac Crash Info

posted by DesertMaus on - last edited - Viewed by 10.3K users
[UPDATE 3-27-2013]
Steam just posted a client update, now running steam client:
Steam API v012, Updated 3-25-2013, Package Version 1364340477 / 1364340477

This has not resolved the issue, so this leaves me to believe it was the Apple/Mac OS-X update from
10.8.2 --> 10.8.3 released March 14th 2013...

Mr Fist;778560 said:
New post comin' up.

"the game suddenly quits before a new hand is dealt. I've tried doing many graphic configurations as I could but nothing works."

Looks like the latest Steam OR maybe OS-X update did in fact do something.

I am experiencing the same exact problem. Happens in the same spot as this post, just after your hand is dealt and the host says, "Tonights steaks will be ten-thousand dollars" within a few milliseconds, BAM closes out with an Apple debug report. However, if you hit SPACEBAR just before that is said, I can cruise around all the goodies, change tables, card deck styles etc, but when clicking back, just as the music is about to kick in BAM.

1) Mac OS-X 10.8.3 Updated 3-16-2013
2) Steam API v012, Updated 3-15-2013, Package Version 1363394288 / 13633954288

* Seems to be after Apple OS-X 10.8.3 update or Steam Update
* Ran Steam Cache checker, returned without error
* Completely removed from Steam Library and double checked local file system, all files gone - Then re-downloaded
* Tried all video resolutions including full screen and windowed
* Changed sound output settings system-wide to use external headphones or bluetooth headphones.

Crash Report:
If I look at the crash report directly or open 'Console' to load a ReportedCrash. there is a lot of debug information.

Crashed Thread: 0 MainThrd Dispatch queue:

Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000000

VM Regions Near 0:
__PAGEZERO 0000000000000000-0000000000001000 [ 4K] ---/--- SM=NUL /Users/USER/Library/Application Support/Steam/*/

__TEXT 0000000000001000-0000000000002000 [ 4K] r-x/rwx SM=COW /Users/USER/Library/Application Support/Steam/*/

Thread 0 Crashed:: MainThrd Dispatch queue:

Followed by ~370 lines of debug information. I looked for core files to strings against, but not sure how Apple hacked the Darwin kernel to not allow for `core` file dumps but rather some Apple proprietary binary crash log.

I know it's an older game but it's so awesome. My wife and I love to play together, it's a nice stress reliever.

If anyone at TellTale Games wants my output file in full or whatever is needed, I would be more than happy to send along:)

Thanks for any help!
47 Comments - Linear Discussion: Classic Style
  • Wondering the same myself. I actually got PN1 through Humble Bundle Weekly specifically for this game and the fact that it supports the Intel Graphics 3000. If what AriGold34 said is accurate, it's kind of a bummer that Telltale can't fix it. I don't know if it's any different, but I'm having the same issue with Stacking on OSX and Double Fine immediately looked into it and are still working on the fix.

    Ironically, I'm thinking all the other games in the TellTale HBW are going to work. I tested out The Walking Dead (success at optimal settings) after Poker Night crashed.

    If it helps any fellow Mac users to get through this, I downloaded Poker Night 2 on a whim since it's $4.99 on Steam. It works just fine, albeit on low rendering.
  • I can reproduce the crash. Every. Single. Time. :mad: If they'd like to fly me out, put me up in a nice hotel and feed me for a few days - I'm happy to bring my MBP to Telltale and show them the crash? :rolleyes:

    Seriously, though, I think this issue has been ignored. I picked this up cheap in a Humble Bundle, so I'm never going to get my few cents back. I think the only solution is to add a little mental black-mark against Telltale Games. They're just damn lucky that Walking Dead was so good.
  • User Avatar Image
    Jennifer Moderator
    AriGold34;798241 said:
    Usually when an operating system updates, the application updates around the operating system.
    That's true when it's a major release, such as OS X Lion to Mountain Lion or Windows 7 to 8, but not during a minor release, since they are only supposed to be maintenance or bugfix releases. In fact, 10.8.3 is supposed to improve compatibility, but it's in fact done the opposite. So, it's in Apple's hands to make a bugfix release (like they apparently tried to do from 10.8.2 to 10.8.3).

    If what you said before about the installer showing files missing is true, there is not much Telltale can do about it, since the file system of the OS itself is to blame (since previous versions of OS X installed and was able to play the game just fine). If the operating system itself isn't detecting files that are there, it's out of the developer's hands unfortunately.

    As I said before, you can restore a backup of a previous version of OS X with Time Machine, or wait for Apple to release a bugfix update of OS X.
  • What a bummer, This has actually happened to me quite a bit with telltale games... I love adventure games, so they were one of my favorite companies, but now that I've switched to mac I need to think twice before buying anything from them...
  • I just updated to 10.8.4 and all issues are gone. I just wanted everyone to know this. It may or may not work for you but I was having the same issues as you guys now it runs great. Thank you For letting us know it was apple and not you guys :)
  • I am running OS X 10.8.4 (12E55) and the version I got from Humble Bundle plainly refused to launch. The app name is "CelebrityPoker v08.01 NoDRM".

    I checked the app contents and it seemed that the unix executable bit for Contents/MacOS/CelebrityPoker was turned off for whatever reason. After turning it on, the game launches but crashes the moment you click "Done" to start the game.

    Any directions on what can I do to play the game?

    Rolling back with Time Machine is NOT an option.
  • Did upgrading to 10.8.4 solved the crash for anyone else except Randall_Mc?
    I'm still stuck and can see no updates from either Telltale or Apple.
  • In reply to m000

    Did upgrading to 10.8.4 solved the crash for anyone else except Randall_Mc? I'm still stuck and can see no updates from either Telltale or Apple. link

    So just so I'm clear……. i have a macbook pro and it is not able to run because we NEED a older system of mac or?

  • wow this stinks i wasted five bucks telltale just fix this or at least give a refund ill even be all right with you making the buy window say its not mac compatible

  • I just bought the game and i learned that this glitch has been out for more than a year you think whoever works on this game would fix it if you have been waiting for more than three months you should demand a refund

This discussion has been closed.