User Avatar Image

Walking Dead on Mac saved game corruption

posted by aratuk on - Viewed by 490 users
I just had a devil of a time with Walking Dead saved games on a Mac. I bought the game over the weekend and, although there was a fair amount of crashing and a couple of freezes, I could save and load games fine, with Steam sync turned on. (On a 2011 MacBook Pro, by the way, running OS X 10.8.3.)

I reached a stopping point having completed most of Episode 3, planning to return the next day. When I came back, the saved game indicated I was still on Episode 2, and when I tried to load it, it asked if I was sure I wanted to rewind. Whether I said yes or no I would get the same result: black screen with just a mouse cursor. I would have to force quit the game.

Because the game had crashed while saving a couple of times, I figured that was what corrupted the save. So, I found the saved game directory at $user/Library/Application Support/Telltale Games/TheWalkingDead and began a trial-and-error process of restoring previous incarnations of the directory from an automatic file backup, because I knew at some point it had been working. (The cloud version on Steam was corrupted, too.)

I wound up at the end of Episode 2, but at least I didn't have to totally start over. So, I kept playing through to Episode 4 before I stopped again. However, when I came back the next time it was the same issue as before: Episode 2 indicated but unloadable. I turned off Steam syncing, thinking that might have been it, and started to try the same process as before.

I was pretty exasperated at this point — having spent a couple of hours trying to fix the problem and replaying a fairly long stretch of the game — and was starting to think about demanding my money back and writing negative reviews all over the place. Remember, I was looking at replaying part of the game yet again, and continuing to play with the likelihood that this would just keep happening.

I finally found an account online of similar problems, and the importance of making sure the "prefs.prop" file, which exists in two different places, is the same in both. I found that the other place (than the aforementioned saved games directory), on a Mac, is inside the application bundle itself: $user/Library/Application Support/Steam/SteamApps/common/The Walking Dead/

If I manually copy "prefs.prop" from the saved games directory into the application bundle after every newly saved game, the save will load normally and the game will function. I deleted *.plist files associated with the game, too, in an attempt to correct this behavior, but it didn't help. I used Steam to verify the integrity of my downloaded copy of the game, and it checked out.

I have now completed the game, so I can say that for some reason the crashing (once every 45 minutes or so) of the first couple of chapters went away by the last couple, so I didn't have to worry so much about corrupting my saves. I left Steam sync turned off.
So, in summary, it appears that after my saved game was corrupted in a crash, something *also* happened to stop the copy of "prefs.prop" from ever being updated inside the application bundle.

I had a heck of a time figuring out a way around this, and it really shouldn't be this way. A lot of people don't know to look in application bundles, etc., and I came pretty close to giving up. A game as successful as the Walking Dead should not have such game-breaking bugs this long after release, because this *is* the kind of problem that can be solved by throwing money at it, by contracting someone to make the saving system play nice with the Mac version of Steam, if that is the problem, or whatever. There just isn't a good excuse.

Honestly, it's a fantastic game, and at first I was thinking about following it up with another one of your games soon, but now I worry I don't have the patience for more technical problems.
0 Comments - Linear Discussion: Classic Style
This discussion has been closed.