User Avatar Image

Borderlands 2 Head Issues

posted by EvilGremlin on - last edited - Viewed by 687 users
Ok, so I have a preexisting shift account. It's linked to my steam account. I was online when playing. I have the Steam achievement for getting the Necronomicron from Ash. I have gone to the bounties page and clicked the Necronomicron and then clicked download.

I have no message under shift codes for receiving the head. When I check in game it's not in the list of available heads.

I have tried downloading the head while both games are running. When only PN2 is running. When PN2 is running and I'm signed into the shift website. I have tried clicking Okay instead of download. I have tried every possible combination I can think of trying. I've done each one half a dozen times, more for some.

Still no head. What do I have to do? It's very frustrating.

We're having the same issue on a second steam account with the Mechromancer bunny head. Both won this morning.
2 Comments - Linear Discussion: Classic Style
  • Yeah I am experiencing the same thing with both the Axton and Maya head. The first 2 heads I won are there, but not the other two. I have not won Zero's yet. I have sent a ticket into Gearbox and they are looking into it for me. Here is hoping they get it to work.
  • Excactly the same problem here.

    I got all 4 heads. The last one was the mechromancer head. 20 minutes later I won the Glados Bounty.
    Steam achievement pops up. Was counted on steam.

    All other items are marked as won in PN2. All items are in SHIFT codes syetem. All head are available in Borderlands 2. But not Glados. (played round about 20 hours getting it)

    my friend bought PN2, too. He won the first Head (Necronomicon). Steam achievement pops-up. In PN2 it is shown as won.
    But nothing in SHIFT system nor in Borderlands.

    I already contacted Steam. They told me that they can't help. (But I think it was a standard mail without getting the problem)
    I contacted gearbox and they ask my for my SHIFT account mailaddress. Nothing heard since 4 days.

    And at least I contacted Telltalegames and they told me: "Could you please provide a screenshot of your bounties page showing the Glados unlock, and also a screenshot of the achievement for winning the Glados unlock."
    Screenshots were send. No feedback since 4 days, too.



    (there are some messages and threads about this problem, so I guess it is a general problem)
This discussion has been closed.