No Sound - Specific Issue with prefs.prop and concurrent installs

I'll try and keep this brief. Playing TWD on a Mac, installed via Steam. I was replaying TWD because I'm an idiot and didn't backup my save files (and had since done a complete system restore). Wanted to replay it to have a save file for 400 Days and Season 2.

I got to partway through Episode 2, when I heard the news that 400 Days was out AND it was free to people who bought it through TTG's store. I originally did buy it through TTG's store, but due to the Day 1 release issue I had gotten the steam code from TTG and been playing the season via Steam. I thought, hey, it's great that 400 Days is free from TTG but I have a Steam save. The other day I came on the forum and someone who was really helpful explained that the saves work for both versions so I could just swap over to the TTG's version for 400 Days once I was done with all 5 Episodes on Steam.

Wanting to verify that, I installed my TTG's store copy on the same computer as my Steam copy was installed. I booted it up, downloaded episode 2, and double checked. Sure enough, there was my save game and it booted with no problem. I deleted the TTG's store version from my computer, intending to finish the first season on Steam and then switch over (or maybe even toss a few more bones toward this series and buy 400 Days on Steam, hadn't decided yet).

Fast forward to today, I try and boot up the Steam version and have some issues getting passed the "Connecting" screen. I finally do, and load up my game, and low and behold it loads up my old game just fine, and I can hear all the SOUND EFFECTs, but when characters speak I see their lips move and no voice sounds play at all. I tried rewinding to earlier in the chapter. Same problem. I have restarted, checked all my audio settings in game and out, etc.

I verified the file integrity with Steam, and it says 1 file was messed up and it would reacquire, but I didn't see it do anything. Started up the game, same problem. I tried to redo the integrity check several times. No difference.

Then I read some forum posts and was directed to copy my prefs.prop file from the ~/USER/Library/Application Support/Steam/SteamApps/common/The Walking Dead over to the ~/USER/Library/Application Support/TellTale Games/TheWalkingDead folder. So I figured at this point, why not. Booted up the game, and loaded up my save. Weird thing is, the voices were all there but for some reason it reset me to the start of Episode 2. From the "Last Time On" bit, it looks like it saved all my choices from Episode 1, but it was hard to tell as I could only really confirm that Carly was alive and Doug was dead (but I don't know if that is maybe a default choice the game assigned due to not properly loading my save).

So I reversed the process, using the backups of the original prefs.prop files I had, and put the one from the TTG's Application Support into the Steam Application support, hoping that I'd get the right save files back.

Sure enough, when I loaded it up, it went right back to where I was in Episode 2. BUT THE VOICES WERE GONE AGAIN.

I thought maybe there was a value I could edit in the prefs.prop file, so I opened it in TextEdit, but it's just a bunch of gibberish.

So now I turn to the community. Why, after installing and then removing the TTG's version of the game while the Steam version was what I had been playing on, did the voices disappear?

And how can I get the voices back without having to replay Eps 1 and 2 AGAIN just so I can have a save to import into 400 Days and Season 2?

Any and all help would be appreciated. Thank you, and I realize that when I said I'd try to keep this brief, I failed.


  • edited July 2013
    Couple more things:

    1. I thought maybe when I uninstalled the TTG's version that it removed some keys files that were not in the Steam directory (since the saves aren't in the steam directory either). So I did try to re-install the TTG's version to see if that put the files back. It did not, still ran with no voices.

    2. I did note, however, that when I re-installed the TWD app, I did not have to redownload Episode 2, it was already there from when I tested the whole shared save theory. So I have to assume there is even more "other locations" where some of these files are stored and maybe that is where the issue exists. I have no idea what importance that might have but wanted to mention it.
  • DjNDBDjNDB Moderator
    edited July 2013
    That was caused by a broken file in the TTG version for Mac, and is discussed in this thread.
    There were voices in the beginning of Episode 2, but not after chapter 2. That also explains why you had the impression it worked with the prefs.prop that took you back to the start of the episode.
    The issue also happened in your steam version, because you still had the TTG store episode 2 files in your savegame folder, and the game used those.
  • edited July 2013
    Understood, I will move my comments over to the other discussion thread for now. Just as a note, I deleted the SyncF folder from the mentioned location, and now when I go to load my game it just goes to a black screen and the program locks up on the black screen.
This discussion has been closed.