Saved Games not working (Mac)

I was playing the very end of Episode 4, but Steam couldn't reach the server, so I was playing offline. I played through to the end of the episode, including the credits, but then I decided I wanted to see an alternate ending. I copied my current saved game and then played that copy, rewinding to the last chapter of Episode 4. Oddly, at this point, the chapter name and image were incorrect (it looked like it was the chapter "Battery"), but when it loaded, the chapter was correct ("Penultimate"). Also, when the saved game started, it picked up from the last auto-save point in that chapter, instead of at the beginning of the chapter.

Anyway, I played through the last chapter again, saw the alternate ending and liked it more, so after the end credits I went to continue playing from that new game for Episode 5, but the "previously on" section showed my choices from the other (original) saved game. I tried deleting, re-copying, rewinding, and replaying the last chapter a few times, but every time in the recap I got the version I played that very first time.

I quit the game, and restarted Steam. At this point, Steam (now apparently able to connect to the server) prompted me with the information that the cloud version of the game was different from the local version. I should have reverted to the older version, which included my original saved game at the point of almost completing Episode 4, but instead I uploaded the new version to the cloud. Now, no matter how I play through the end of Episode 4, I end up with a scenario based on the first time I did so.

I have read through the solutions for similar problems, but the problem usually seems to lie with the pref files, and I can't seem to even find mine. Please let me know if there is anything I can do about this issue, as it is very frustrating! Is there any way I can just go back to the old version of the files on the Steam cloud?


  • edited July 2013
    By the way, I have tried to run the support tool, but every time it tries to access my autosave data, the terminal says "Access Denied."
  • edited July 2013
    Well, I tried restoring a backup of my Steam files from CrashPlan from a few days ago, and now all of my saves are completely gone. My achievements still show up in Steam, but TWD thinks I'm a new player who has not spent 27 hours playing this dumb game.
  • edited July 2013
    Well, things keep getting stranger and more frustrating. I realized that the files I had been restoring from a backup were my Steam files, rather than my Telltale games files, which includes the prefs.prop file and all of the save files. When I revert to an earlier version of the Telltale folder, and then reopen the game in offline mode, it restores all of my saves from that time. This meant that I could play through the end of Episode 4 again. This time, when I started Episode 5, everything was different, but didn't reflect any version of the game as I had played it (in my first game, I hid the bite and went on my own after Clem; in my second game, I showed the bite and brought Kenny, Omid, Christa, and Ben with me; in the version that plays, I hid the bite and bring Kenny, Omid, and Christa with me).

    If I try to play the game online, I lose all of my saved games again. I can only reinstate them by again reverting to an earlier version of the Telltale game files. I have tried renaming/deleting my prefs.prop file and it doesn't seem to help. The problem now seems to be (in part) that the game files in the cloud are corrupt, but I can't seem to figure out any way to upload my local files to the cloud. For some reason I was offered that option earlier in this mess (see above), but I can't figure out how to reproduce that event. I'm clearly not fixing the right files, but I don't know what else to do. Please help.
  • edited July 2013
    Well, the support process completed (attached here), but I can't imagine it's going to be helpful. Let me know if there's anything else I can do.
  • DjNDBDjNDB Moderator
    edited July 2013
    It looks a bit convoluted, but there's still something you can try.

    -rw-r--r-- 1 alexkrich staff 69K Jul 30 13:37 /Users/alexkrich/Library/Application Support/Steam/SteamApps/common/The Walking Dead/
    -rw-r--r-- 1 alexkrich staff 6.4K Jul 30 21:01 /Users/alexkrich/Library/Application Support/Telltale Games/TheWalkingDead/prefs.prop
    -rw-r--r-- 1 alexkrich staff 63K Jul 25 23:41 /Users/alexkrich/Library/Application Support/Telltale Games/TheWalkingDead/prefs.prop.bak

    First of all, disable the prefs.prop in
    /Users/alexkrich/Library/Application Support/Steam/SteamApps/common/The Walking Dead/
    by renaming it to prefs.prop.bak

    then remove the small ( 6.4K) prefs.prop from
    /Users/alexkrich/Library/Application Support/Telltale Games/TheWalkingDead
    It is most likely not associated with your savegames.

    then rename the prefs.prop.bak in
    /Users/alexkrich/Library/Application Support/Telltale Games/TheWalkingDead
    to prefs.prop

    now check the result.
    If it is not as expected, try moving the prefs.prop.bak from
    /Users/alexkrich/Library/Application Support/Steam/SteamApps/common/The Walking Dead/
    /Users/alexkrich/Library/Application Support/Telltale Games/TheWalkingDead
    and renaming it to prefs.prop.

    In other words, make sure that every prefs.prop that is not in
    /Users/alexkrich/Library/Application Support/Telltale Games/TheWalkingDead
    is deactivated by renaming it.

    Then you can try every prefs.prop you have in
    /Users/alexkrich/Library/Application Support/Telltale Games/TheWalkingDead
    until you get a better result.
  • So, shortly before you posted the above advice, I got so frustrated with the game that I decided to just give it up forever. After allowing myself some time to heal, I decided to try playing it again a month or so ago. Foolishly, I did not try to fix this problem before I started playing, thinking that a new game would alleviate the issue. Well, I got to the final chapter of the game and the same thing happened again. Fortunately, your advice worked 100% and I was able to play through my game to completion without much hassle. I know this a year late, but thank you for your very helpful advice.

    DjNDB posted: »

    It looks a bit convoluted, but there's still something you can try. -rw-r--r-- 1 alexkrich staff 69K Jul 30 13:37 /Users/ale

  • TelltaleMikeTelltaleMike ModeratorTelltale Staff

    Thank you for posting the extra information. I will make sure to pass it along, and hope you are able to enjoy the game!

    alexkrich posted: »

    So, shortly before you posted the above advice, I got so frustrated with the game that I decided to just give it up forever. After

This discussion has been closed.