User Avatar Image

Walking Dead 'Storage Device Lost' Glitch

posted by Mrbman9001 on - last edited - Viewed by 5.7K users
Okay,I and a lot of other people have been having the Storage Device Lost glitch.

However,for me the glitch is not happening in 400 Days. It happens in Episode 2,right when Lee tackles Andy.

I HAVE downloaded 400 Days,and I'm playing on an Xbox 360,and I'm playing on a disc.

I have checked,and it is only happening with this game,so if anyone could give me any kind of advice on how to solve it,I would appreciate it.

Hell,I made an account just for this post,because I was so pissed about this glitch.
13 Comments - Linear Discussion: Classic Style
  • The glitch has been going on for close to a year now and no fix is in sight.

    Unfortunately Telltale are unable to find what causes it and so are unable to fix it.
  • I have fixed it.

    I deleted my save files and the glitch has stopped.
  • I just spent nearly 3 hours trying to fix this issue while playing the game on my Xbox 360. That includes searching the net and forums for a solution...what I found out is that the glitch happens when I was playing from my game in the last (third) game save slot. I deleted the game in the first slot and copied the third game to that slot. It worked. The error code didn't pop up. So, my assumption is that the last slot is where the issue is and it might have a coding issue when it comes to saving/syncing the information or something along that line? So, if you stick to 2 saved games, you're golden.
  • I've had the glitch in every save slot. I've completely removed every trace of the game from my 360 only to get the error again.

    Genuinely I am glad that solutions have worked for you but had you read other threads about this you would have seen that they haven't worked for others.
  • Well I only noticed the problem occurring with 400 days in the second save slot. I was able to play through 400 days twice on the same day it was released with no message. After I deleted the second save file, I copied my first file onto file 2, but the message still came up. Personally I think it might be file 2 as like I said, I played through file 1 with no problems.

    I dunno, just relating my story. I'm still hesitant to erase my save file on 1 for fear the error would show up. I'm pretty sure once Telltale releases season 2, they will iron out any bugs.
  • I have done everything but for example I dont think it is any specific save file so dont go deleting your saves for no reason.
    I played season 1 + 400 days complete with no error on save 1, my brother did the same on save 2....
    i tried playing a new game on save 3 and it started to black screen and crash with storage lost error...
    As not to lose my first playthrough i copied my save 1 to save 3 and deleted save 1 to replay from fresh, and im still getting the error on my save 1.
    How can me and my brother play beginning to end without an issue and all of a sudden all 3 saves are fcked?
    I've had just about enough of this bullsh
    t tbh and i hope something gets fixed before i go and buy season 2 ep 1 and i cant play that either.

  • Wow unbelievable Telltale, it's now 2015 and I just got this game(Season 1 & 2)last week and I've had 2 play throughs without any problems. And now on my 3rd play through on episode 4 of season 1 and I get this "Storage device lost error" and now the game that I've spent all this money on is unplayable now? I looked up the problem just to find out that this has been going on for almost 2 years now and that the people at Telltale are basically just ignoring the problem now but are still going to let people buy the game without warning. I have the older xbox 360 with the 60gb storage I've now deleted every trace of the game and this problem still occurs? Thank you so much Telltale I will now never purchase another episode because of this total neglect to your gaming community and supporters. If I sound mad that's because I am mad because I really did enjoy this series but after having deleted all my content and backing up the data just to get the same problems, it's really disappointing.

    So if there are any people out there who have an xbox 360 and are thinking of purchasing this game I would strongly advise against this because it's a gamble on whether you will get screwed over by Telltale!!

  • Attention
    I may have found a solution to this glitch...well atleast it has worked for me for the first three episodes
    I first deleted everything related to this game (including dlc) on the hard-drive and saves
    I then only re-downloaded the first episode (the one that is free) and started far no error
    I went back into the dashboard to redownload episode 2 and started far no error
    I went back to dashboard to redownload episode 3 and started far no error
    However Once I downloaded episode 4 and started the game the error message that says "The device containing the game has been removed. Press A to return to the Xbox 360 Dashboard" has appeared and cannot continue from the main title screen
    Conclusion: Something has to be wrong with the episode 4 file since everything from 1-3 worked.....I will update if i find fix for Episodes 4-5

  • To my Final Understanding...Episodes 4-5 are just unplayable if you are experiencing this glitch...I would say that hopefully this will be patch soon but considering the fact that its July 2015, the game has been out for 3 years, Season 2 has came out, game of thrones has came out.... I am sorry for all you guys who have spent money on this piece of crap....If I do find a miracle to fix this ill update once more but I find it unlikely

  • Attention I have found the solution..Sorry for the last 2 Comments
    1. Delete everything related to this game (including saves) from the hard-drive
    2. Download the 1st episode (the free one) and start the game...there should be no error at the main title screen...then exit to the dashboard
    3. Download episode 2 and start the game...there still should be no error and exit to the dashboard
    4. Repeat for all episodes
    5. Now you should be able to enjoy every episode in the game

    If you get the error message after downloading a certain episode then delete that episode and then redownload it and continue .... This usually occurs to me on episode 5
    Note I have also notice that if you have an external device such as a flash drive while playing this game, the error message comes up so dont have a flash drive in at all!!!!

This discussion has been closed.