User Avatar Image

Monkey Island has stopped working

posted by lylemcd on - Viewed by 2.5K users

So I decided to play through the excellent TMI series again.

Two days ago I started a new game in episode 1 and played to the end. Hooray.

I went to launch Episode 2 tonite and it crashed when I clicked new game. The same happened on other episodes.

Thinking I might have corrupt copies, I redownloaded all episodes.

Now ALL episodes crash if I try to launch a new game.
Episode 1 will however Resume Game just fine. Though it crashed when I exited.
Episode 1 crashes if I go to Load and Run and attempt to load the save that way.

That tells me that wherever the games are keeping the save files is corrupted but I can't find it on my hard drive.

I'd mentioned that a download of the BTTF game ran just fine.

Help....
Lyle

14 Comments
  • Hmm, so I go to Library/Application Support and there's no folder called Telltale Games.

    I even created a folder and tried rerunning episode 1 and no joy; the same problem persists.

    A search on Telltale Games in the Finder turns up nothing as well.

    Does BTTF happen to keep it's system preferences in the same or a similar place, I'm wondering if I could find the folder that way (since my BTTM downloads do run fine).

    Thank you
    Lyle

    • User Avatar Image
      DjNDB Moderator

      Yes, BTTF uses the same folder.

      Are you sure you opened the correct location?

      You should be able to navigate to the savegame folder by starting Finder, and selecting "Go/Go to Folder..." from the menu or pressing CMD-SHIFT-G, and pasting the path below into it.
      ~/Library/Application Support/Telltale Games/

  • Hi,

    Ok, I was able to find the folder using the Go To command, apparently Mac makes it invisible by default. My apologies.

    I found the folder and trashed all 5 folders with ToMI information. I re-ran Episode 1, it recreated the folder including prefs.prop.

    I attempted to run the installed version. Crashed.

    So I started from scratch, trashed the support folder and redownloaded episode 1 and reinstalled it from the dmg to the applications folder.

    Ran it. Tried to start a new game. Crashes.
    Ran it again, tried to adjust the preferences: changing graphic resolution is fine. Attempting to go away from full screen crashes it when it starts to modify the screen window. This is how it crashes out of the New Game, it sort of 'flashes' the finder window briefly before redrawing the game window and then hangs and crashes.

    Could this be the problem?

    BTTF still runs fine but doesn't appear to do any of the stuff with the screen windows.

    Thank you,
    Lyle

  • User Avatar Image
    DjNDB Moderator

    I am not sure what could cause that, but maybe your system information can give some clues.

    Open a terminal (e.g. by typing terminal into spotlight).
    Run the system profiler to copy selected system information to the clipboard, by copying the command line below into the terminal and pressing enter:

    system_profiler -detailLevel mini SPHardwareDataType SPSoftwareDataType SPDisplaysDataType SPAudioDataType | pbcopy

    pbcopy already copied the output to the clipboard for you, instead of showing it in the terminal. All you have to do now is reply to this thread, make sure the cursor is in the reply input area, and press (Command + V) to paste it.

  • Thank you!


    Hardware:

    Hardware Overview:
    
      Model Name: iMac
      Model Identifier: iMac12,1
      Processor Name: Intel Core i5
      Processor Speed: 2.5 GHz
      Number of Processors: 1
      Total Number of Cores: 4
      L2 Cache (per Core): 256 KB
      L3 Cache: 6 MB
      Memory: 4 GB
      Boot ROM Version: IM121.0047.B1F
      SMC Version (system): 1.71f22
    

    Software:

    System Software Overview:
    
      System Version: Mac OS X 10.7.5 (11G56)
      Kernel Version: Darwin 11.4.2
      64-bit Kernel and Extensions: Yes
      Time since boot: 18:26
    

    Graphics/Displays:

    AMD Radeon HD 6750M:
    
      Chipset Model: AMD Radeon HD 6750M
      Type: GPU
      Bus: PCIe
      PCIe Lane Width: x16
      VRAM (Total): 512 MB
      Vendor: ATI (0x1002)
      Device ID: 0x6741
      Revision ID: 0x0000
      ROM Revision: 113-C2950H-170
      EFI Driver Version: 01.00.544
      Displays:
        iMac:
          Display Type: LCD
          Resolution: 1920 x 1080
          Pixel Depth: 32-Bit Color (ARGB8888)
          Main Display: Yes
          Mirror: Off
          Online: Yes
          Built-In: Yes
          Connection Type: DisplayPort
    

    Audio (Built In):

    Intel High Definition Audio:
    
      Audio ID: 9
    
        Speaker:
    
          Connection: Internal
    
        Headphone:
    
          Connection: Combination Output
    
        Line Input:
    
          Connection: Combination Input
    
        Internal Microphone:
    
          Connection: Internal
    
        S/PDIF Optical Digital Audio Input:
    
          Connection: Combination Input
    
        S/PDIF Optical Digital Audio Output:
    
          Connection: Combination Output
    
        External Microphone / iPhone Headset:
    
          Connection: Combination Output
    
        HDMI / DisplayPort Output:
    
          Connection: Display
    
  • Adding: What I find the most strange is that this all happened like overnight. I started and played a new game of Ep 1 over the weekend.

    When I ran Ep 2 it did ask me to put in my login information (saying I was logged in incorrectly) and I did, apparently correctly.

    Then it crashed. Then Ep 1 wouldn't work anymore. Like whatever happened with Episode 2 corrupted or affected everything.

    But nothing about my system has changed since Ep 1 worked perfectly well this past weekend.

    Thanks!

  • User Avatar Image
    DjNDB Moderator

    One thing you could try is creating a new Mac OS X user account and installing the game there. If it works, some settings are weird in your current account.

  • I'll try that. Thank you.

  • I tried that. Loaded up one of my alternate system accounts, downloaded the game fresh, installed, ran, crashes in the exact same way. I'm going to test it on my laptop to see if it will work there; clearly there is an issue with my overall system (could it be something banal like an updated version of Quicktime or something?) since my desktop has been updated more frequently than the laptop.

    Thank you for your help and fast responses.
    Lyle

  • Googling on the problem I found a thread on this forum suggesting that OS 10.7.5 is the issue. So that's probably it.

    Laptop it is!

    Thank you....

  • Just a quick update. Finally got my Macbook back, which has OS 10.6.8

    Monkeyisland still runs there so it would appear to be an issue with OS 10.7

    Thanks.

This discussion has been closed.