User Avatar Image

Can't play Season 1

posted by lamont on - last edited - Viewed by 527 users

Way back in Oct 2012, I bought my wife a Season 1. We had issues activating the game, then we had black screens on startup and we finally had issues getting episodes downloaded. Seems like I remember these were all issues with DRM.

In spite of herself, my wife loves this game, so she soldiered on until she got stuck on a game-breaking bug somewhere in episode 3 and gave up.

Fast forward a year, she gets a new PC, decides she wants to dig this thing up and re-play it, because we see there's a new season out that she maybe wants to buy. I see things have been updated in the interim, looks like we're on version 3 of the installer anyway, so maybe things will be better.

Of COURSE they aren't. We get to go through the same crap again. Have to jump through hoops to activate her game copy. She's got a license for all episodes plus the bonus content, but the stupid installer doesn't actually install any of this content, she's got to go download it from inside the game, which tells her it's purchased, but she's got to "GET" it, and of course we get server errors when we try to download Episode 2.

We try exiting and restarting the game, but now the game client doesn't start up at all, it just sits on a black screen, no loading screen, no login prompt, no menus, nothing.

Found this:

Mentions a patch that supposedly fixes the issue, obviously that's not the case. Suggested Rewind workaround hasn't fixed anything either. Suggestions?

Assuming we get the black screen thing sorted, what the hell do we need to do to download the content for this?

Does Season 2 have an actual WORKING episode downloader or is it more of the same garbage?

WAY TO GO TELLTALE. Nice to see you've got you shit together. o.O

  • Nice. No replies with any advice. Am I posting in the wrong forum? Is this not where everyone bitches about the total lack of support they are receiving for a $30 title?

    So she worked her way through these issues, and got to the point that she could download Episode 2. She went to bed... then went to work... then came home and the damn thing was still sitting at 33% completion.

    We discovered that not minimizing the game results in a faster download -- tells me all I really need to know about the quality of Ops developers you guys employ there -- and she was able to start playing at about 8PM. OVER 24 HOURS AFTER SHE STARTED DOWNLOADING THE EPISODE WE PAID FOR OVER A YEAR AGO.

    She finished EP2 just now, tried to download EP3 (because you idiots have decided it's better to not let anyone download and play at the same time) and she started getting "Couldn't connect to server" errors. She's now trying to restart the game to re-try downloading the episode before she goes to bed because she REMEMBERS THAT WORKED BEFORE.

    Last year.


    Do you assholes even understand how you are alienating your biggest fans? My wife absolutely LOVES the game. It's the only reason she even ATTEMPTS to put up with the asinine hoops your idiotic DRM scheme foists upon her. She's actually looking forward to trying to play season 2 -- not because the story promises to be any better, but because she maybe WON'T HAVE TO PUT UP WITH YOUR CRAP DRM SERVERS AND NETCODE.

    Her biggest fear, because she's seen this multiple times before, is that season 2 won't "remember" the choices she made in season 1. I can't mollify her fears because the steam forums and forums here are full of people complaining about the exact same problem - season 2 games don't import choices from season 1 -- or if they do, they do it in the most confusion freaking way imaginable. This is something that as a software developer I'd see as a core feature and I really can't understand how it would get to a release state in the condition it appears to be in -- and the suggested fixes I read about don't seem to work for a majority.

    But you guys don't care about any of that, do you? Got your money and that's it, yah? Apparently.

    I say to anyone reading this, DO NOT BUY ANY GAMES FROM TELLTALE. They release broken garbage, refuse to support it, and patently refuse to fix issues that have existed for over a year.

    I'm really curious to see if I get any responses at this point. Given how crazily organized the official website is -- you actively hide the support forums so potential customers wandering in from google won't ever see what an unplayable mess this garbage is, my only assumption is your intent is to shunt people with problems off into a ghetto and ignore them.

    Stick to console games, telltale, you're apparently actually competent at those.

  • ...and she still can't get the damn 360 controller she bought to play your idiotic game with to work either.

    Might as well throw that in since no one's reading anyway. Screw you all.

  • User Avatar Image
    DjNDB Moderator

    Your technical complaints are justified, but please stop the insults.

    I'll try to help as much as I can.

    As for the black screen issue, please follow the instructions to run the TWD Support Tool and post the download link to the resulting "" or "" to your next reply in this thread.

    Download issue:
    If you're connected through WiFi, please try connecting via a cable if possible.
    The ingame downloader is not very fault tolerant. I suggest you try the unofficial download workaround. The semi-automatic download makes it least inconvenient, works pretty reliable in the background and can resume on a by file basis.

    Controller issue:
    I have no system information yet. On Windows 8 the game crashes if joysticks/gamepads are connected. That bug is fixed in Windows 8.1, available for free in the Windows 8 Store.
    If you don't want to upgrade yet, you can try an unofficial workaround. In short, by downloading and extracting this zip file, and copying the dinput8.dll next to the games .exe, you should be able to use the controller normally. Make sure you delete that dinput8.dll after updating to Windows 8.1, to avoid possible problems in the future.

This discussion has been closed.