User Avatar Image

ep3 engine startup bug (ps vita)

posted by ytlumak on - Viewed by 435 users

So I was playing the game my PS vita hot to ep3 with no bug. And when I got to ch4 I had a bug where I can't use the control panel in the locomotive.
the 6 works fine, but i dont seem to be able to change anything in the 5 panel, there is no option either...
I tried to rewind the chapter... Didn't work.... Also tried to quit the game and try again, no success...
anyone faced this bug?

  • User Avatar Image
    TelltaleMike Telltale Staff

    I apologize for the inconvenience. Please make sure you are holding the direction of the panel with both analog sticks, and attempting to select the switches while doing this. If you are still unable to change the panel, I recommend rewinding to the beginning of the Episode, and replay from there.

  • Just rewinded the ep again, only chose different options, got to the start engine yet nothing... There is no indicator to the switches(the white circle) like I saw on a walkthrough... Also I tried pressing different buttons while pointing around the switches, didn't work too... Which only points to a technical bug
    edit: just tried to change controls to touch screen, same results

    • User Avatar Image
      TelltaleMike Telltale Staff

      I apologize for any difficulties that this has caused you. Please contact/email our Support Staff at, and they will be able to assist you further with your issue.

This discussion has been closed.